LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 01-09-2007, 10:31 AM   #1
Score
Member
 
Registered: Oct 2006
Location: Norway
Distribution: Debian Etch
Posts: 105

Rep: Reputation: 15
Parsix Linux - Not able to set default keyboard layout


Right after I have tried to change the current, so called, standard keyboard layout from USA to Norway, I get this message

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation
70101000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

Any ideas? I dont know my way around with US keyboard layout, and some of my Norwegian keys are not where they are supposed to be.

Thanks!
 
Old 01-10-2007, 06:50 AM   #2
Samotnik
Member
 
Registered: Jun 2006
Location: Belarus
Distribution: Debian GNU/Linux testing/unstable
Posts: 471

Rep: Reputation: 40
How did you change you layouts?
 
Old 01-10-2007, 10:42 AM   #3
Score
Member
 
Registered: Oct 2006
Location: Norway
Distribution: Debian Etch
Posts: 105

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Samotnik
How did you change you layouts?
In the gnome menu, I went to "keyboard layout" and added Norway, and put it as default. But it just gave me that error message when I logged in and after I put it to Norwegian.

Is this distro built for non-english/persian users by the way...?
 
Old 01-18-2007, 02:13 AM   #4
Samotnik
Member
 
Registered: Jun 2006
Location: Belarus
Distribution: Debian GNU/Linux testing/unstable
Posts: 471

Rep: Reputation: 40
Sorry for this long silence.
Try to modify /etc/X11/xorg.conf file with your hands. Find a line with Option "XkbLayout" "<something>" and make it Option "XkbLayout" "nr,us" (if nr is the proper two-letter code for Norway).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching keyboard layout - Mandriva2006 - K.D.E. Windows Layout! itz2000 Mandriva 3 08-13-2006 07:43 PM
how to set keyboard-layout during initialization? jonaskoelker Debian 8 07-15-2004 06:00 PM
choosing default keyboard layout in KDE or how to switch languages correctly sensovision Linux - General 3 05-23-2004 05:56 PM
default keyboard layout supernatural Slackware 2 06-13-2003 11:50 AM
SuSE Linux Printer Configuration and Default Page Layout corvus_albus Linux - Distributions 1 01-30-2003 11:27 AM


All times are GMT -5. The time now is 05:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration