LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-23-2004, 11:24 AM   #1
sensovision
Member
 
Registered: Mar 2004
Location: Ukraine
Distribution: Debian "Wheezy"
Posts: 94

Rep: Reputation: 15
choosing default keyboard layout in KDE or how to switch languages correctly


hi folks! just wish to tell in the beginning that probably yesterday I finally realize that Linux is good not only because it's free or because it has great philosophy behind it or because it's more stable than win boxes, it's really better than Window$, it let me solve tasks I'm working on much more easily and fast, and now I finally realized it! I've switched fully from my W2K box to Debian SID maybe about week ago, previously I was on dual boot by prepearing some of my documents to this migration(I was really tired by window$ slowdowns with the time it's running). Sorry I've got offtopic I'm just too excited, I even have in plans to write some article about how easily move from M$ to Linux and what steps you have to take in order to save people errors and trials I've did myself.

Question
But here is my problem I'm not fully decide over Gnome or KDE(mostly because I've comiled KDE 3.2.2 without problems but I failed to comile Gnome 2.6, so I keep on trying, as for default Gnome version which comes on my CD it doesn't work well), anyway I come from Ukraine, mostly I'm typing in English but sometimes I have to switch to Russian, I've no problems in doing this with a keyboard switcher which comes with Gnome although KDE gives me some problem. When I try to add two flags Russian and US(I've also tried Great Britain, US with nodead keys and others) I've go to the third tab and choose let's say CTRL+SHIFT and CTRL+ALT for keyboard switching but these shortcuts won't work the only way for me to switch the keyboard is to click on the flag(this way I'm not interested, as sometimes in ICQ I've talking with various peoples and it would waste me a lot of time if I have to switch languages by mouse) ... after some hour of picking various combinations I've finally spot that there is a WAY to make keyboard switch between English and Russian, but it's a bit tricky... I've to leave only Russian flag in the keyboard layouts and mark "Include latin variant" option, after this switching of groups works like a charm but I've get another even more serious problem(in my opinion) now I have default language Russian, which make me big headache as each new terminal, or URL address is started with Rus. letters and I have to swtich in order to type it in English.
So how can I switch layouts with my keyboard in KDE and have English as my default keyboard layout?
Thank you in advance!
 
Old 05-23-2004, 12:33 PM   #2
ToniT
Senior Member
 
Registered: Oct 2003
Location: Zurich, Switzerland
Distribution: Debian/unstable
Posts: 1,357

Rep: Reputation: 47
Don't know about kde/gnome, but in X level commands like:
setxkbmap 'us', setxkbmap 'us_intl' or setxkbmap 'ru' should do keymap modifications.
Search for symbols.dir from your X configs (located in /etc/X11/xkb in debian) for different variations (and rules/xfree86 for additional options).
 
Old 05-23-2004, 03:32 PM   #3
sensovision
Member
 
Registered: Mar 2004
Location: Ukraine
Distribution: Debian "Wheezy"
Posts: 94

Original Poster
Rep: Reputation: 15
thanks for reply Toni, you've showed me right direction to look for and I've almost reach my aim, I've put this sting in my XFree config:
Quote:
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "CoreKeyboard"
Option "XkbModel" "pc104"
Option "XkbLayout" "us,ru"
Option "XkbVariant" "winkeys"
Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
EndSection
all is working well now except one thing... my variant of keyboard won't become winkeys, so several buttons like "?" type "," instead and vice versa, of course I could ignore this but it's not good idea since all PCs in unviersity are using winkeys layout and it would cause me a lot of problems, could you advice me what I'm doing wrong and where I should put winkeys option?
 
Old 05-23-2004, 04:56 PM   #4
sensovision
Member
 
Registered: Mar 2004
Location: Ukraine
Distribution: Debian "Wheezy"
Posts: 94

Original Poster
Rep: Reputation: 15
ok I've solved the problem by putting this info in my xconfig:
Quote:
Section "InputDevice"
Option "XkbLayout" "us,ru(winkeys)"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Keyboard Shortcuts with different Keyboard Layout hellblade Linux - Software 5 04-18-2006 12:40 AM
shortcut to switch keyboard layout in KDE ihristov Suse/Novell 0 10-23-2004 12:11 PM
How do i switch keyboard layout in Gnome? z-vet Linux - Newbie 1 10-15-2004 05:02 AM
default keyboard layout supernatural Slackware 2 06-13-2003 10:50 AM
How to switch keyboard layout in KDE/RedHat 7.2 Bogdan Linux - Newbie 2 12-20-2001 01:01 AM


All times are GMT -5. The time now is 07:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration