LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 03-12-2008, 02:19 AM   #1
rehan999
Member
 
Registered: Aug 2007
Posts: 134

Rep: Reputation: 15
Unhappy open terminal


Good Morning

I have a simple question.

I have a machnie installed with Redhat Enterprise Linux WS release 4 update 4.with kde3.3.

When i login as a user to the machine and open 10 terminals and reboot the machine.
After the completion of rebooting again when i login as user i should see the 10 opened terminals.

Please help me out.

Waiting for your reply.
Thnaks and regards
Rehan
 
Old 03-12-2008, 02:31 AM   #2
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 62
What user are you logging in as?

There are a few different mechanisms by which KDE auto-runs programs, any of which might be causing the problem:
  • Any executable files in $HOME/.kde/Autostart will be run
  • If you have KDE set up to restore your last session, files from $HOME/.kde/share/config/session should be examined
  • Your .bashrc or .bash_profile or .profile might contain some bad commands, so you should look at these too.
 
Old 03-12-2008, 03:09 AM   #3
rehan999
Member
 
Registered: Aug 2007
Posts: 134

Original Poster
Rep: Reputation: 15
Red face

I didnot get any clue form your hints please help me below are the output of the files mentioned by u.


The out upt of cat $HOME/.kde/share/config/session/kwin_10e39eaa63000120446021700000285370000_1204460228_292665 is

0228_292665
[Session]
active=-1
count=1
desktop=1
desktop1=-1
fsrestore1=0,0,0,0
fullscreen1=0
geometry1=0,970,1280,54
iconified1=false
keepBelow1=false
maximize1=0
resourceClass1=kicker
resourceName1=kicker
restore1=0,970,1280,54
sessionId1=10e39eaa63000120446021700000285370003
shaded1=false
skipPager1=false
skipTaskbar1=false
staysOnTop1=false
sticky1=true
userNoBorder1=false
windowRole1=panel
windowType1=Dock
wmClientMachine1=localhost
wmCommand1=kicker


cat .bashrc
. $ENV_PATH/bashrc


Please help me out.
 
Old 03-12-2008, 03:19 AM   #4
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 62
Can you log into the text console as this user without there being a problem?

What is the user anyway?
 
Old 03-12-2008, 03:20 AM   #5
konsolebox
Senior Member
 
Registered: Oct 2005
Distribution: Gentoo, Slackware, LFS
Posts: 2,242
Blog Entries: 15

Rep: Reputation: 233Reputation: 233Reputation: 233
Do you mean adding another 4 terminals from the default 6 in the console? Modify your /etc/inittab and add another 4 entries from the group that has something like c1:*, c2:*.... for example:

in the section

Code:
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:2345:respawn:/sbin/agetty 38400 tty2 linux
c3:2345:respawn:/sbin/agetty 38400 tty3 linux
c4:2345:respawn:/sbin/agetty 38400 tty4 linux
c5:2345:respawn:/sbin/agetty 38400 tty5 linux
c6:2345:respawn:/sbin/agetty 38400 tty6 linux
add another 4 to make it:

Code:
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:2345:respawn:/sbin/agetty 38400 tty2 linux
c3:2345:respawn:/sbin/agetty 38400 tty3 linux
c4:2345:respawn:/sbin/agetty 38400 tty4 linux
c5:2345:respawn:/sbin/agetty 38400 tty5 linux
c6:2345:respawn:/sbin/agetty 38400 tty6 linux
c7:2345:respawn:/sbin/agetty 38400 tty7 linux
c8:2345:respawn:/sbin/agetty 38400 tty8 linux
c9:2345:respawn:/sbin/agetty 38400 tty9 linux
c10:2345:respawn:/sbin/agetty 38400 tty10 linux
this works most of the time but i don't know if it works with 10

--- EDIT ---
sorry i haven't seen your second reply.. what type of terminal do you mean anyway? do you mean sessions in konsole or gnome terminal or something?

Last edited by konsolebox; 03-12-2008 at 03:28 AM. Reason: mistake
 
Old 03-12-2008, 03:31 AM   #6
rehan999
Member
 
Registered: Aug 2007
Posts: 134

Original Poster
Rep: Reputation: 15
Unhappy

Can you log into the text console as this user without there being a problem?

What is the user anyway?


I can login to the mahcnie with out any problem.
the user is a local user created on the machnie ex:username=testuser.

My question is i dont want to have any extra terminals.

my question is

I logged in grapical mode as by giving user name and passwd sucessfully.

and i opened terminals like suppose 10-15 terminals.
and shutdown my machnie.

the next time when i login i should be automatically open all the terminals (10-15) which i had opened previously.

please help me out.
 
Old 03-12-2008, 03:37 AM   #7
rehan999
Member
 
Registered: Aug 2007
Posts: 134

Original Poster
Rep: Reputation: 15
konsolebox thanks for your reply.

my question is,

I can login to the mahcnie with out any problem.
the user is a local user created on the machnie ex:username=testuser.

My question is i dont want to have any extra terminals.

my question is

I logged in grapical mode as by giving user name and passwd sucessfully.

and i opened terminals like suppose 10-15 terminals.
and shutdown my machnie.

the next time when i login i should be automatically open all the terminals (10-15) which i had opened previously.


please help me out.
 
Old 03-12-2008, 03:46 AM   #8
konsolebox
Senior Member
 
Registered: Oct 2005
Distribution: Gentoo, Slackware, LFS
Posts: 2,242
Blog Entries: 15

Rep: Reputation: 233Reputation: 233Reputation: 233
i don't know how to configure things that way but in my machine running a gentoo dist, i just log my session out without closing the terminals and that's it.. when i go back using 'startx' from the console, everything goes back to where it was even mozilla firefox.

the problem is unlike yours, i don't use a login manager .. i just start x directly from the console and no more login is required.. or perhaps it was not configured to be done that way..

try to logout only when shutting down then try to shutdown from the login screen instead.
 
Old 03-12-2008, 05:58 AM   #9
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 62
Please verify that I understand correctly - you want KDE to remember what windows you had open last time you use the computer, and re-open them next time you log in?
 
Old 03-12-2008, 06:04 AM   #10
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Quote:
the next time when i login i should be automatically open all the terminals (10-15) which i had opened previously.
This says that you want the 10-15 terminals to start the next time you log into KDE.

Quote:
My question is i dont want to have any extra terminals.
This says that you don't.

It you close the "konsoles" before logging out, they shouldn't be there the next time you log in. Then you can go to the KDE configuration and decide if you want your last session saved or not or if you want to start with a blank session.
 
Old 03-12-2008, 06:14 AM   #11
rehan999
Member
 
Registered: Aug 2007
Posts: 134

Original Poster
Rep: Reputation: 15
Quote:
My question is i dont want to have any extra terminals.

This says that you don't.

My answer was to Mr. Konsolebox as he sujjested me to do the below steps.


Do you mean adding another 4 terminals from the default 6 in the console? Modify your /etc/inittab and add another 4 entries from the group that has something like c1:*, c2:*.... for example:

in the section


Code:
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:2345:respawn:/sbin/agetty 38400 tty2 linux
c3:2345:respawn:/sbin/agetty 38400 tty3 linux
c4:2345:respawn:/sbin/agetty 38400 tty4 linux
c5:2345:respawn:/sbin/agetty 38400 tty5 linux
c6:2345:respawn:/sbin/agetty 38400 tty6 linuxadd another 4 to make it:


Code:
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:2345:respawn:/sbin/agetty 38400 tty2 linux
c3:2345:respawn:/sbin/agetty 38400 tty3 linux
c4:2345:respawn:/sbin/agetty 38400 tty4 linux
c5:2345:respawn:/sbin/agetty 38400 tty5 linux
c6:2345:respawn:/sbin/agetty 38400 tty6 linux
c7:2345:respawn:/sbin/agetty 38400 tty7 linux
c8:2345:respawn:/sbin/agetty 38400 tty8 linux
c9:2345:respawn:/sbin/agetty 38400 tty9 linux
c10:2345:respawn:/sbin/agetty 38400 tty10 linuxthis works most of the time but i don't know if it works with 10



Any ways as u have understand my question

Please tell me how should i open the old sessions(first time login sessions) when i login the second time.
waiting for your reply

Thnanks and regards
Rehan
 
Old 03-12-2008, 06:21 AM   #12
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 62
I don't understand what you want. Unless you can clarify your question, I cannot help.
 
Old 03-12-2008, 07:01 AM   #13
konsolebox
Senior Member
 
Registered: Oct 2005
Distribution: Gentoo, Slackware, LFS
Posts: 2,242
Blog Entries: 15

Rep: Reputation: 233Reputation: 233Reputation: 233
It's OK. Perhaps what he means is that my first reply was wrong and that he wants to have his session saved and put back the second time he logs in. Have you already tried the procedure I told you? Did it work?
 
Old 03-12-2008, 07:42 AM   #14
rehan999
Member
 
Registered: Aug 2007
Posts: 134

Original Poster
Rep: Reputation: 15
Thank you so much for all your help.

I really appriciate your suggestions

anyways i got the solution

For KDE

Go to control center -- > KDE components -> session manager-> and check the option restore previous session.

And reboot the machine.

It will work.

For Gnome

Go to Applications->Preferences->morepreferences->sessions and select the Session Options tab.
Check the box for automatically remember running applications when logging out.

Thank you so much.

Thanks and Regards
Rehan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
open a command in new terminal? imanassypov Linux - Desktop 4 12-03-2007 02:11 PM
open in terminal Four Linux - Newbie 2 01-21-2007 07:49 PM
Open A Terminal rmadd Linux - Software 3 09-19-2006 07:31 PM
open a terminal canucks Linux - Newbie 1 08-03-2004 12:24 AM
How to open programs in terminal without being stuck to the terminal?? brynjarh Linux - Newbie 6 07-07-2004 12:52 PM


All times are GMT -5. The time now is 05:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration