LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-18-2004, 06:25 PM   #1
Tink
LQ Newbie
 
Registered: Mar 2004
Location: Wisconsin
Distribution: Redhat 9
Posts: 11

Rep: Reputation: 0
Unhappy Ok i dont know what to do.....


Ok here is the problem. I have redhat 9 installed on a

AMD Athalon 750
Asus Motherboard
256MB Ram
20 Gig hard drive
Ati Rage 128 32MB Vid card

i went into display and set my screen resolution up to 1024x768
no i cant see anything screen is all funky. the problem i have is how to i get it back down so i can see again? I cant do it graphically since i cant see crap. So is there another way to return it to 800x600 so i can see again? Or do i have tho reinstall and loose all the stuff i have done up till this point?


Thnx
Tink
 
Old 03-18-2004, 06:32 PM   #2
Tink
LQ Newbie
 
Registered: Mar 2004
Location: Wisconsin
Distribution: Redhat 9
Posts: 11

Original Poster
Rep: Reputation: 0
Yes i am a newb. So please help......
 
Old 03-18-2004, 06:44 PM   #3
Tink
LQ Newbie
 
Registered: Mar 2004
Location: Wisconsin
Distribution: Redhat 9
Posts: 11

Original Poster
Rep: Reputation: 0
anyone?????????
 
Old 03-18-2004, 07:15 PM   #4
cb_linus
Member
 
Registered: Dec 2003
Location: UK
Distribution: Gentoo
Posts: 81

Rep: Reputation: 15
I don't use Redhat but is there any way you can get to a commandline? From there you should be able to alter your XF86config - which includes graphics options (do su then type xf86cong or xf86config-4 although you may have to be in /etc/X11).

If you can't to this (ie get to the command line at all) then there might be various options with booting from the install cd (cd 1). Also, members who post on the Red Hat part of this forum might be more helpful than me

-Chris
 
Old 03-18-2004, 07:26 PM   #5
Tink
LQ Newbie
 
Registered: Mar 2004
Location: Wisconsin
Distribution: Redhat 9
Posts: 11

Original Poster
Rep: Reputation: 0
thank you ill check out that part of the forum as well.
i will also chek out the first cd
 
Old 03-18-2004, 08:57 PM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
You can also cycle through your allowed screen resolutions from the keyboard. While holding down the CTRL and ALT keys, use the + and - on the keypad to change either up or down in resolution.

Last edited by Hangdog42; 03-18-2004 at 08:58 PM.
 
Old 03-18-2004, 10:07 PM   #7
[WebCarnage]
Member
 
Registered: Jun 2003
Location: USA
Distribution: Slackware 9.1 | netBSD 1.6.2
Posts: 35

Rep: Reputation: 15
you could possibly try:

# X -configure
 
Old 03-18-2004, 10:32 PM   #8
Linux~Powered
Member
 
Registered: Jan 2004
Location: /lost+found
Distribution: Slack`er-current
Posts: 845

Rep: Reputation: 33
Can't you just go to Applications--> Desktop Preferences--> Screen Resolution and choose the 800x600 option and save settings upon logout? Or you could edit your /etc/X11/XF86Config.
 
Old 03-18-2004, 11:27 PM   #9
Brane Ded
Member
 
Registered: Nov 2003
Location: over there
Distribution: Debian Testing
Posts: 191

Rep: Reputation: 30
You could try hitting CTRL+ALT+F1(or F2, or whatever, up to F6), then edit your /etc/X11/XF86Config file to remove the offending resolution. It might also be /etc/X11/XF86Config-4, depending on how Redhat does things. Ideally, you'd also want to shutdown X windows. I don't know how to do it in Redhat, but usually you run the init script for you login manager(gdm,kdm,whatever) with the stop command.

In Gentoo, for example(It might be similar in Redhat), it would be something like:
/etc/init.d/gdm stop

In the worst case scenario, you'll just have to rebuild your XF86Config file. There might be a tool to do so in /usr/X11R6/bin called xf86config that can get the job done for you. I'm pretty unsure about most of this though, as it's been a long time since I've used Redhat, and I don't quite remember how all their stuff is laid out.
 
Old 03-19-2004, 12:56 AM   #10
tyler_durden
Member
 
Registered: May 2001
Posts: 125

Rep: Reputation: 15
To expand on what Brane Dead was saying:

The best way to fix this problem is:

1- hit Ctl+Alt+F1 you will then get a non-graphical window.

2- login as root

3- run "init 3", this will kill X

4- run "redhat-config-xfree" and set you resolution to somehitng lower.
 
Old 03-19-2004, 06:55 AM   #11
Tink
LQ Newbie
 
Registered: Mar 2004
Location: Wisconsin
Distribution: Redhat 9
Posts: 11

Original Poster
Rep: Reputation: 0
thanks guys this was great.

Last edited by Tink; 03-19-2004 at 06:58 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dont no what these mean browser Linux - General 6 10-03-2005 12:04 PM
Dont know what to do ?? :(:( lighter Linux - Distributions 9 08-11-2005 12:50 PM
new to linux dont what distro to use dont no much command xman2007 Linux - Newbie 3 01-02-2004 06:32 PM
I Just dont get it v2-ncl Linux - Software 3 10-17-2003 07:38 AM
Things dont work when you dont understand withoutaclue Linux - Newbie 3 03-12-2003 10:51 AM


All times are GMT -5. The time now is 08:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration