LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-19-2004, 08:16 PM   #1
cheater1034
Member
 
Registered: Aug 2004
Location: Ohio
Distribution: Gentoo
Posts: 141

Rep: Reputation: 15
ld-linux.so error, gentoo


I had this gentoo stage3 install for a while, and then I updated xorg to 6.8.0, and it updated glib , (libc)(which is what the error says) , I dont know if there is a command for it, because i can't run some things, like open office.

---------------------------
/opt/OpenOffice.org/program/javaldx: relocation error: libc.so.6: symbol _dl_starting_up, version GLIBC_PRIVATE not definedin file ld-linux.so.2 with link time reference
/opt/OpenOffice.org/program/pagein: relocation error: libc.so.6: symbol _dl_starting_up, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
/opt/OpenOffice.org/program/soffice.bin: relocation error: libc.so.6: symbol _dl_starting_up, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference

---------------------------

that's the error ^, I dont know if theres something to update or what, but please help
 
Old 10-20-2004, 01:23 AM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
hi,

try in a shell emulator
export LD_ASSUME_KERNEL=2.4.1
then start open office from that shell
and see if it runs
or
export LD_ASSUME_KERNEL=2.4.20
if one of them works you can write it in a script to start certain apps

every shared object can tell the linker it's OS and binary interface version
for one thing so you can direct it different places for cross platform or reverse compatability purposes

beyond that, is to update the things that won't run to be compiled against the new glibc i think ???
 
Old 10-20-2004, 01:49 PM   #3
cheater1034
Member
 
Registered: Aug 2004
Location: Ohio
Distribution: Gentoo
Posts: 141

Original Poster
Rep: Reputation: 15
I still get the same error is it something in the kernel maybe?

kernel version = gentoo-2.6.8-r3, the newest in portage is gentoo-2.6.8-r10, unless i go for a vanilla kernel from kernel.org, and get 2.6.9? or maybe back to 2.6.7
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
emerge error in gentoo xcalibra Linux - Software 9 11-20-2005 12:00 PM
X error in Mozilla Firefox 1.0 on Gentoo LInux when running Flash goldenratiophi Linux - Software 8 01-27-2005 02:54 PM
pkg-config error with emerge -aD gnome-python on Gentoo 2.6.9-gentoo-r6 ghrellin Linux - Software 2 12-22-2004 06:37 PM
gentoo instillation error Kaiser Linux - Distributions 1 02-17-2004 08:34 PM
Gentoo NVIDIA error dalek Linux - General 2 10-15-2003 09:31 PM


All times are GMT -5. The time now is 08:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration