LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-20-2004, 12:28 AM   #1
ghrellin
Member
 
Registered: Dec 2004
Location: USA
Distribution: Gentoo Linux
Posts: 41

Rep: Reputation: 15
pkg-config error with emerge -aD gnome-python on Gentoo 2.6.9-gentoo-r6


I'm running Gentoo Linux, kernel version 2.6.9-gentoo-r6 with a few unstable packages (gaim, mplayer, not many) and the dependencies for gnome-python emerge perfectly. However, when I try to emerge gnome-python (2.6.1, unstable) I get the following:
Code:
checking for GTK+ - version >= 2.4.0...
*** 'pkg-config --modversion gtk+-2.0' returned 2.4.9, but GTK+ (2.4.13)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GTK+. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
 no
configure: error: maybe you want the gtk-gnome-1-2 branch?
Although gnome-python 2.6.1 is unstable, I get the same error when I try to emerge the stable version. I'm going for unstable because rbscrobbler (rhythmbox audioscrobbler plugin) requires it, just to head off answers telling me to use the stable version.
 
Old 12-22-2004, 01:21 PM   #2
uman
Member
 
Registered: Sep 2004
Distribution: Gentoo
Posts: 134

Rep: Reputation: 15
I had this same problem when trying to emerge gtkglarea. I think the problem in your case is two conflicting versions of GTK+
Did you ever install GTK+ yourself? (without portage, by doing ./configure && make && make install)
If so, uninstall it, then remerge GTK+ through portage.
 
Old 12-22-2004, 06:37 PM   #3
ghrellin
Member
 
Registered: Dec 2004
Location: USA
Distribution: Gentoo Linux
Posts: 41

Original Poster
Rep: Reputation: 15
This problem went away when I did
Code:
emerge -aDu world
a few days ago.
Unfortunately, I didn't write down which packages were updated. Anyway, it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't emerge gnome on gentoo due to ffmpeg plugins aeruzcar Linux - Software 3 07-02-2006 11:55 AM
emerge error in gentoo xcalibra Linux - Software 9 11-20-2005 12:00 PM
gentoo emerge gconf error besson3c Linux - Distributions 2 12-20-2004 01:01 PM
Please help. Gentoo: Emerge gentoo-dev-sources fails sendas4 Linux - Newbie 3 07-19-2004 11:44 AM
gentoo emerge kde error busbarn Linux - Software 2 03-08-2003 11:07 AM


All times are GMT -5. The time now is 09:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration