LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-07-2007, 06:43 AM   #1
lordrakim
LQ Newbie
 
Registered: May 2006
Posts: 4

Rep: Reputation: 0
Is Beryl possible with Intel chipset on a P3-600 256mb cuz I can't make it work....


Hello... I am running MEPIS 6.0 with Beryl and Emerald installed and well I can't get the compositing to work at all....

I have a P3 600 mhz with 256 megs of ram....


I get the no compositing error.... I'm not running it now so I can't repeat it BUT here's my xorg.conf

Code:
Section "ServerLayout"
  Identifier "XFree86 Configured"
  Screen 0 "Screen0" 0 0
 #Screen 0 "ATIScreen" 0 0
  InputDevice "Keyboard0" "CoreKeyboard"
  InputDevice "PS/2 Mouse" "CorePointer"
 #InputDevice "USB Mouse" "CorePointer"
 #InputDevice "Touchpad" "CorePointer"
 #InputDevice "Stylus" "CorePointer"
 #InputDevice "Eraser" "CorePointer"
 #InputDevice "Cursor" "CorePointer"
 #InputDevice "Serial Mouse" "CorePointer"
 Option "AIGLX" "on"
EndSection

Section "ServerFlags"
  Option "AllowMouseOpenFail" "true"
EndSection

Section "Files"
# Xorg 7.0 font paths
    FontPath 	"/usr/share/X11/fonts/misc:unscaled"
    FontPath 	"/usr/share/X11/fonts/cyrillic"
    FontPath 	"/usr/share/X11/fonts/Type1"
    FontPath 	"/usr/share/X11/fonts/util"

# Legacy font paths
    FontPath 	"/usr/X11R6/lib/X11/fonts/misc:unscaled"
    FontPath 	"/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath 	"/usr/X11R6/lib/X11/fonts/Type1"
    FontPath 	"/usr/X11R6/lib/X11/fonts/util"

# Other font paths
    FontPath 	"/usr/share/fonts/truetype/ttf-lucida"
    FontPath 	"/usr/share/fonts/truetype/arphic"
    FontPath 	"/usr/share/fonts/truetype/freefont"
    FontPath 	"/usr/share/fonts/truetype/kochi"
    FontPath 	"/usr/share/fonts/truetype/latex-xft-fonts"
    FontPath 	"/usr/share/fonts/truetype/openoffice"
    FontPath 	"/usr/share/fonts/truetype/ttf-bitstream-vera"
    FontPath 	"/usr/share/fonts/type1/gsfonts"
    FontPath 	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath 	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"

EndSection

Section "Module"
  Load "GLcore"
  Load "bitmap"
  Load "dbe"
  Load "ddc"
  #Load "dri"
  Load "extmod"
  Load "freetype"
  Load "glx"
  Load "int10"
  Load "record"
  Load "type1"
  Load "v4l"
  Load "vbe"
  Load "synaptics"
EndSection

Section "InputDevice"
  Identifier "Keyboard0"
  Driver "keyboard"
  Option "CoreKeyboard"
  Option "XkbModel" "pc105"
  Option "XkbLayout" "us"
  Option "XKbOptions" ""
EndSection

Section "InputDevice"
  Identifier "Serial Mouse"
  Driver "mouse"
  Option  "Protocol" "Microsoft"
  Option  "Device" "/dev/ttyS0"
  Option  "Emulate3Buttons" "false"
  Option  "Emulate3Timeout" "70"
EndSection

Section "InputDevice"
 Identifier "Touchpad"
 Driver "synaptics"
 Option "Device" "/dev/psaux"
 Option "Protocol" "auto-dev"
 Option "LeftEdge" "1700"
 Option "RightEdge" "5300"
 Option "TopEdge" "1700"
 Option "BottomEdge" "4200"
 Option "FingerLow" "25"
 Option "FingerHigh" "30"
 Option "MaxTapTime" "180"
 Option "MaxTapMove" "220"
 Option "VertScrollDelta" "100"
 Option "MinSpeed" "0.06"
 Option "MaxSpeed" "0.12"
 Option "AccelFactor" "0.0010"
 Option "SHMConfig" "on"
 Option "Repeater" "/dev/input/mice"
EndSection

Section "InputDevice"
  Identifier "PS/2 Mouse"
  Driver "mouse"
  Option "Protocol" "auto"
  Option "Device" "/dev/psaux"
  Option "Emulate3Buttons" "false"
  Option "Emulate3Timeout" "70"
  Option "ZAxisMapping" "4 5"
  Option "Buttons" "5"
EndSection

Section "InputDevice"
  Identifier "USB Mouse"
  Driver "mouse"
  Option "Device" "/dev/input/mice"
  Option "Protocol" "ExplorerPS/2"
  Option "ZAxisMapping" "4 5"
  Option "Buttons" "5"
EndSection

Section "InputDevice"
  Identifier "Stylus"
  Driver "wacom"
  Option "Mode" "Absolute"
  Option "Type" "stylus"
  Option "Device" "/dev/input/wacom"
Endsection

# Settings for wacom eraser
Section "InputDevice"
  Identifier "Eraser"
  Driver "wacom"
  Option "Mode" "Absolute"
  Option "Type" "eraser"
  Option "Device" "/dev/input/wacom"
Endsection
# Settings for wacom cursor (mouse)
Section "InputDevice"
  Identifier "Cursor"
  Driver "wacom"
  Option "Mode" "Absolute"
  Option "Type" "cursor"
  Option "Device" "/dev/input/wacom"
Endsection

Section "Monitor"
  Identifier "Monitor0"
  VendorName "unknown"
  ModelName "unknown"
 #Option "DPMS" "true"
  HorizSync    30.0 - 75.0 # Warning: This may fry old Monitors
  VertRefresh  50.0 - 70.0 # Very conservative. May flicker.
  Modeline "640x480"     25.175 640  664  760  800   480  491  493  525 #60Hz
  Modeline "800x600"     40.12  800  848  968 1056   600  601  605  628 #60Hz
  Modeline "1024x768"    75    1024 1048 1184 1328   768  771  777  806 -hsync -vsync
  Modeline "1024x768"    85    1024 1056 1152 1360   768  784  787  823
  ModeLine "1152x864"    65    1152 1168 1384 1480   864  865  875  985 Interlace
  Modeline "1152x864"    92    1152 1208 1368 1474   864  865  875  895
  Modeline "1152x864"   110    1152 1240 1324 1552   864  864  876  908
  Modeline "1152x864"   135    1152 1464 1592 1776   864  864  876  908
  Modeline "1152x864"   137.65 1152 1184 1312 1536   864  866  885  902 -HSync -VSync
  Modeline "1280x768"    80.14 1280 1344 1480 1680   768  769  772  795
  ModeLine "1280x800"    80.58 1280 1344 1480 1680   800  801  804  827 -HSync -VSync
  Modeline "1280x1024"   80    1280 1296 1512 1568  1024 1025 1037 1165 Interlace
  Modeline "1280x1024"  110    1280 1328 1512 1712  1024 1025 1028 1054
  Modeline "1280x1024"  126.5  1280 1312 1472 1696  1024 1032 1040 1068 -HSync -VSync
  Modeline "1280x1024"  135    1280 1312 1456 1712  1024 1027 1030 1064
  Modeline "1280x1024"  135    1280 1312 1416 1664  1024 1027 1030 1064
  Modeline "1280x1024"  157.5  1280 1344 1504 1728  1024 1025 1028 1072 +HSync +VSync
  Modeline "1280x1024"  181.75 1280 1312 1440 1696  1024 1031 1046 1072 -HSync -VSync
  Modeline "1440x900"   106.47 1440 1520 1672 1904   900  901  904  932 +HSync +VSync
  Modeline "1400x1050"  129    1400 1464 1656 1960  1050 1051 1054 1100 +HSync +VSync
  Modeline "1600x1200"  162    1600 1664 1856 2160  1200 1201 1204 1250 +HSync +VSync
  Modeline "1600x1200"  189    1600 1664 1856 2160  1200 1201 1204 1250 -HSync -VSync
  Modeline "1600x1200"  202.5  1600 1664 1856 2160  1200 1201 1204 1250 +HSync +VSync
  Modeline "1600x1200"  220    1600 1616 1808 2080  1200 1204 1207 1244 +HSync +VSync
  Modeline "1680x1050"  147.14 1680 1784 1968 2256  1050 1051 1054 1087
  ModeLine "1800x1440"  230    1800 1896 2088 2392  1440 1441 1444 1490 +HSync +VSync
  ModeLine "1800x1440"  250    1800 1896 2088 2392  1440 1441 1444 1490 +HSync +VSync
  Modeline "1920x1200"  230    1920 1936 2096 2528  1200 1201 1204 1250 +HSync +VSync
EndSection

Section "Monitor"
  Identifier  "ATIMonitor"
  VendorName "unknown"
  ModelName "unknown"
 #Option "DPMS" "true"
  HorizSync    30.0 - 75.0 # Warning: This may fry old Monitors
  VertRefresh  50.0 - 70.0 # Very conservative. May flicker.
EndSection

Section "Device"
  Identifier  "Card0"
  Driver "i810"
  BoardName "unknown"

Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"

 #BusID  "PCI:1:0:0"
 #Option "sw_cursor" # needed for some ati cards
 #Option "hw_cursor"
 #Option "NoAccel"
 #Option "ShowCache"
 #Option "ShadowFB"
 #Option "UseFBDev"
 #Option "Rotate"
  Option "UseInternalAGPGART" "no"

# savage special options, use with care
 #Option "NoUseBios"
 #Option "BusType" "PCI"
  Option "DmaMode" "None"

# nvidia special options, use with care
  Option "CursorShadow" "1"
  Option "CursorShadowAlpha" "63"
  Option "CursorShadowYOffset" "2"
  Option "CursorShadowXOffset" "4"
  Option "FlatPanelProperties" "Scaling = native"
  Option "NoLogo" "false"
  Option "IgnoreEdid" "true" # needs to be true for some nvidia cards
EndSection

Section "Screen"
  Identifier "Screen0"
  Device "Card0"
  Monitor "Monitor0"
  DefaultColorDepth 16
  
  SubSection "Display"
  Depth 8
  Modes "1600x1200" "1280x1024" "1024x768"
  EndSubSection
  SubSection "Display"
  Depth 15
  Modes "1600x1200" "1280x1024" "1024x768"
  EndSubSection
  SubSection "Display"
  Depth 16
  Modes "1600x1200" "1280x1024" "1024x768"
  EndSubSection
  SubSection "Display"
  Depth 24
  Modes "1600x1200" "1280x1024" "1024x768"
  EndSubSection
  SubSection "Display"
  Depth 32
  Modes "1600x1200" "1280x1024" "1024x768"
  EndSubSection
  
  # Only the official NVIDIA driver supports twinview
  # these setting are an example
  Option "TwinView" "false"
  Option "SecondMonitorVendorName" "unknown"
  Option "SecondMonitorModelName" "unknown"
  Option "SecondMonitorHorizSync" "30-75"
  Option "SecondMonitorVertRefresh" "50-70"
 #Option "MetaModes" "1024x768, 1024x768"
  Option "TwinViewOrientation" "RightOf"
  Option "ConnectedMonitor" "dfp,dfp"
EndSection

Section "Screen"
  Identifier "ATIScreen"
  Device "Card0"
  Monitor "ATIMonitor"
  DefaultColorDepth 24
Option "XAANoOffscreenPixmaps"
Option "AddARGBGLXVisuals" "On"
  
  SubSection "Display"
  Depth 24
  Modes "1600x1200" "1280x1024" "1024x768"
  EndSubSection
EndSection

Section "DRI"
  Mode 0666
EndSection

Section "Extensions"
         Option "Composite" "Enable"
#        Option "Composite" "0"
EndSection
not a linux guru by any stretch but I'm learning and not too afraid of the commandline *LOL*

Thanks in advance!

EDIT: Forgot to mention I did launch beryl-manager from yaKuake if thats a difference..... and when I try to make Beryl my window manager I get no window decorations and I can bring windows to the front, etc. (I've seen other folks posts about getting this error when they can't do compositing)...

and I installed (using aptitude) xserver-xgl mepis-beryl-6.0 aquamarine beryl beryl-plugins-extra compiz-manager beryl-manager beryl-settings

typing
glxinfo|grep direct

says I am using Direct rendering..

Last edited by lordrakim; 03-07-2007 at 08:08 AM.
 
Old 03-07-2007, 07:24 AM   #2
jens
Senior Member
 
Registered: May 2004
Location: Belgium
Distribution: Debian, Slackware, Fedora
Posts: 1,197

Rep: Reputation: 164Reputation: 164
Did you actually try it?
Start it from the "scary" command line like this:
Code:
beryl-manager
...do post all errors if it doesn't work.

Your xorg.conf seems ok for the beryl part.
Do you have 3D acceleration (needed for beryl)?
(no idea how this is done on intel cards, but once this works, so should beryl)

Do you have all needed packages (depends on the repo you're using)?
see: http://wiki.beryl-project.org/wiki/Install/Debian

Last edited by jens; 03-07-2007 at 07:43 AM.
 
Old 03-07-2007, 07:52 AM   #3
lordrakim
LQ Newbie
 
Registered: May 2006
Posts: 4

Original Poster
Rep: Reputation: 0
when I can get the session kde-3d to work again (fiddling with xorg.conf right now) I will post my exact errors.....

with the xorg.conf I posted above, I can't get in the session anymore, it just bounces me back to KDM. Maybe I'll look at the other distros I have installed on the HD for help... (Elive 0.6.3 andPCLinux 07 test 2 which I also can't get Beryl to work in and according to the 3d configuration there I can't do 3d effects ALTHOUGH it does have compositing on ????????)

EDIT: tryin PCLinux's xorg killed everything *LOL* thank god for backup files... hehehe

Last edited by lordrakim; 03-07-2007 at 09:23 AM.
 
Old 03-09-2007, 05:41 AM   #4
lordrakim
LQ Newbie
 
Registered: May 2006
Posts: 4

Original Poster
Rep: Reputation: 0
ok I installed Mepis 6.5 beta 5 ( I had an updated 6.0 running at first) and I am still unsuccesful at getting Beryl to work...

the error I get now is....

[DRM:i810wait_ring_error:]*error*:space:65512 wanted 65528
[DRM:i810wait_ring_error:]

(I retyped it so the syntax may not be exact)

Funny, the only PC I got it to work with (and with no real work) was my Athlon 5200+ with a GeForce 7600 GS. I tried Vector Linux's latest Live CD and installed Mepis 6.5 beta 5 on it.

My main reasoning for a working Beryl is it's a great way to get folks who don't wanna upgrade to Vista to jump to Linux and I fix PCs on the side, so it'd be nice to show one more advantage Linux has over M$
 
Old 12-21-2007, 10:43 AM   #5
Kaboosh
LQ Newbie
 
Registered: Feb 2005
Location: Edmonton, AB
Distribution: PCLinuxOS
Posts: 19

Rep: Reputation: 0
Unclutter

Try removing extraneous options such as UseInternalAGPGART and that NVidia stuff from your video card section.
 
Old 12-21-2007, 09:32 PM   #6
Ryptyde
Member
 
Registered: Jun 2004
Location: Tragic City,Michigan,USA
Distribution: Fedora 18 Fedora 17
Posts: 242

Rep: Reputation: 37
I've a P3 550MHz with a nVidia 420 and the only way that desktop effects would work was with increasing my RAM from 256MB to 512MB.

Then the performance is a bit on the low side compared to a machine with a faster processor and newer graphics card with >256MB memory.

I run Fedora 7 and Fedora 8 on four computers with various nVidia graphics cards and processors and will recommend more RAM for the P3 machine as it won't matter what distro you try desktop effects will not work properly or at all on low specs.

Beryl is history as far as I know and in Fedora repos it is now compiz-fusion and you use compiz-fusion-icon as the manager.
 
  


Reply

Tags
beryl, intel, mepis


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Display washed out with Beryl on Intel G965 chipset montylee Linux - Newbie 11 01-10-2007 06:41 AM
how to get linux suse 10 work on intel 915 chipset psycho_tmr Linux - Hardware 3 03-30-2006 09:49 PM
Terratec Cinergy 600 tv -> how can I make infrared work? chaosd Linux - Hardware 0 11-24-2005 06:33 AM
Which 3D accelertor card's work with Intel 815eg chipset? sergeantroach Linux - Hardware 6 11-05-2003 10:38 AM
Intel 810e Graphics Chipset Doesn't work on Slackware 8 Dvorak2099 Slackware 9 07-04-2002 06:13 PM


All times are GMT -5. The time now is 05:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration