LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-16-2004, 03:00 AM   #1
mrgrieves
Member
 
Registered: Apr 2004
Location: north of 52, south of 54
Distribution: slackware 10.0
Posts: 108

Rep: Reputation: 15
IDE-SCSI emulation on /dev/hdc


Apparently, I can't burn cd's because scsi emulation isn't enabled. K3b gives me this:

Quote:
cdrdao 1.1.7 does not support ATAPI
The configured version of cdrdao does not support writing to ATAPI devices without SCSI emulation and there is at least one writer in your system not configured to use SCSI emulation.
Solution: The best and recommended solution is to enable ide-scsi (SCSI emulation) for all writer devices. This way you won't have any problems. Or you install (or select as the default) a more recent version of cdrdao.
No support for ATAPI with cdrdao
You will not be able to use all your reading devices as copy sources since there is at least one not configured to use SCSI emulation and your system does not support ATAPI with cdrdao.
Solution: The best and recommended solution is to enable ide-scsi (SCSI emulation) for all devices. This way you won't have any problems.
I think its something to do with /etc/fstab but I can't remember how.

-Thanks in advance for any help
 
Old 05-16-2004, 05:07 AM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
You need to pass the option "hdc=ide-scsi" to your kernel at boot time. If you use Grub, simply add "hdc=ide-scsi" (without the quotes) on the kernel line in your /boot/grub/menu.lst. If you use Lilo, you can add "append=hdc=ide-scsi" (again, without the quotes!) and rerun /sbin/lilo.

Reboot and then load the ide-scsi module: modprobe ide-scsi
You should now be able to access your CD-ROM as a SCSI device called /dev/sg0 or /dev/scd0.


Håkan
 
Old 06-26-2004, 06:07 PM   #3
brettybaby
LQ Newbie
 
Registered: Jun 2004
Location: USA california
Distribution: fedora 2 and suse 9
Posts: 8

Rep: Reputation: 0
i need to set my cdrw and dvd drive as scsi


how do i do this step i did the step above just fine

Reboot and then load the ide-scsi module: modprobe ide-scsi 'how do i do this
 
Old 06-26-2004, 07:01 PM   #4
mrgrieves
Member
 
Registered: Apr 2004
Location: north of 52, south of 54
Distribution: slackware 10.0
Posts: 108

Original Poster
Rep: Reputation: 15
Thanks! worked for me.

brettybaby,

I believe you need to type that in the command line.
 
Old 06-26-2004, 10:07 PM   #5
brettybaby
LQ Newbie
 
Registered: Jun 2004
Location: USA california
Distribution: fedora 2 and suse 9
Posts: 8

Rep: Reputation: 0
tell me exactly how to type it into the command line

like is it in the Run command section because when i type it there i get error *could not run the specific command

or do i run it in the Konsole shell

what is the exact code that i type to get modprobe ide-scsi to work

im very new to this and i dont even know how to compile my own kernal

i do know how to edit the bootloader in the Yast2 and get into the sysconfig area to modify the kernal. well i think i am

i need specific very very specific directions please
 
Old 06-26-2004, 10:20 PM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,175

Rep: Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784Reputation: 784
brettybaby,
modprobe is located in the /sbin directory. You need to be logged in as root in order to run modprobe.
 
Old 06-26-2004, 10:27 PM   #7
Ironica
Member
 
Registered: Jan 2003
Distribution: LFS
Posts: 64

Rep: Reputation: 15
Thanks for that. I remember when I installed RedHat a while ago, it automatically added that parameter. But I forgot what the parameter was >.<

brettybaby, you need to login as root before you can use modprobe.
$ su
***** (root password)
# /sbin/modprobe ide-scsi
 
Old 06-27-2004, 05:43 PM   #8
brettybaby
LQ Newbie
 
Registered: Jun 2004
Location: USA california
Distribution: fedora 2 and suse 9
Posts: 8

Rep: Reputation: 0
ok i just tried that and i got a new error

KDE Man Viewer Error
No Man page matching to /sbin/modprobe ide-scsi found. You can extend the search path by setting the environment variable MANPATH before starting KDE
 
Old 06-28-2004, 11:23 AM   #9
brettybaby
LQ Newbie
 
Registered: Jun 2004
Location: USA california
Distribution: fedora 2 and suse 9
Posts: 8

Rep: Reputation: 0
are you going to help me
i logged in as admin and tried to do everything above and got errors still
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ide-scsi emulation RestInPieces Linux - Newbie 3 10-31-2004 05:45 PM
No ide SCSI emulation on 2.6? moger Linux - General 1 01-17-2004 10:42 PM
ide-scsi emulation vabaliukas Linux - Hardware 0 07-09-2003 10:14 AM
ide-scsi emulation vabaliukas Linux - Hardware 2 07-07-2003 09:39 PM
What does that mean hdc= ide - scsi dark_light Linux - General 1 07-03-2003 05:34 PM


All times are GMT -5. The time now is 10:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration