LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-11-2011, 07:32 AM   #1
Ezilop
LQ Newbie
 
Registered: May 2010
Location: Kiev, Ukraine
Posts: 10

Rep: Reputation: 0
How to disable any keyboard/mouse input in GRUB?


I've found that my USB mouse causes some I/O bug BIOS, but in operation system it works fine. Problem is freezing GRUB caused by fake input from the mouse. Possible decision is disabling any input for grub, but I don't know how to do it.

Sorry for my English.
 
Old 01-11-2011, 11:25 AM   #2
Snark1994
Senior Member
 
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,630
Blog Entries: 3

Rep: Reputation: 345Reputation: 345Reputation: 345Reputation: 345
I may be wrong, but I think you need to jump hoops to get GRUB to recognise your mouse (Wikipedia implies you can, I've never seen it done)

So unless you can normally use the mouse in your GRUB setup, I feel it's unlikely that changing anything to do with GRUB will fix this problem. And when you said "possible solution is disabling any input for grub", I assume you mean just mouse input? Or am I missing something here?
 
Old 01-11-2011, 05:23 PM   #3
jefro
Guru
 
Registered: Mar 2008
Posts: 11,552

Rep: Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406Reputation: 1406
Wonder if an bios setting for legacy usb or other such entry might help? Anything in bios that would suggest something like that?
 
Old 01-12-2011, 03:17 AM   #4
Ezilop
LQ Newbie
 
Registered: May 2010
Location: Kiev, Ukraine
Posts: 10

Original Poster
Rep: Reputation: 0
No, I don't need GRUB boot menu at all. But my USB mouse causes hang up on this menu. Now I must unplug them until OS booted.

BIOS recognize this mouse as keyboard and sets them "primary" status. So, real keyboard is inactive either in GRUB menu and BIOS setup menus. Mouse actions are recognized as some key pressings, so, GRUB shows menu instead of loading OS immediately. I want GRUB to ignore this inputs.

It's a BIOS problem, but BIOS settings of my computer don't provide any USB rules.
 
Old 01-12-2011, 03:06 PM   #5
Valery Reznic
ELF Statifier author
 
Registered: Oct 2007
Posts: 666

Rep: Reputation: 133Reputation: 133
Quote:
Originally Posted by Ezilop View Post
No, I don't need GRUB boot menu at all. But my USB mouse causes hang up on this menu. Now I must unplug them until OS booted.

BIOS recognize this mouse as keyboard and sets them "primary" status. So, real keyboard is inactive either in GRUB menu and BIOS setup menus. Mouse actions are recognized as some key pressings, so, GRUB shows menu instead of loading OS immediately. I want GRUB to ignore this inputs.

It's a BIOS problem, but BIOS settings of my computer don't provide any USB rules.
You can try LILO instead of GRUB
 
Old 01-12-2011, 03:32 PM   #6
arizonagroovejet
Senior Member
 
Registered: Jun 2005
Location: England
Distribution: SLED, openSUSE
Posts: 1,022

Rep: Reputation: 173Reputation: 173
Maybe if you set the grub timeout to 0 that would be an effective workaround. Maybe.
 
Old 01-13-2011, 12:28 PM   #7
Ezilop
LQ Newbie
 
Registered: May 2010
Location: Kiev, Ukraine
Posts: 10

Original Poster
Rep: Reputation: 0
Menu timeout is currently 0. But pseudo-keyboard input calls them. LILO's behavior is same, so it will not solve this problem.
 
  


Reply

Tags
grub


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable and re-enable mouse and keyboard input? weijie90 Linux - Hardware 2 08-12-2007 07:17 PM
Disable mouse, keyboard or other input devices / drivers bastl Programming 0 05-15-2005 06:39 AM
how do i disable keyboard input? thebover Linux - Newbie 5 08-24-2004 10:13 AM
my mouse input is takes as keyboard input in BASH e1000 Slackware 5 12-08-2003 03:00 PM
Keyboard and mouse input problems in 9.1 soup Slackware 6 09-30-2003 02:57 PM


All times are GMT -5. The time now is 07:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration