Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 12-07-2003, 10:55 PM   #1
Registered: Oct 2003
Location: California
Distribution: Ubuntu
Posts: 582

Rep: Reputation: 30
my mouse input is takes as keyboard input in BASH

I'v fixed my mouse so that I can use the mouse wheel to schrol (by changing protocol from PS/2 to IMPS/2), but now when I exit X-windows the command line thinks my mouse input is my keyboard. (although my keyboard still works 100%)

what I mean by this is that if I moove my mouse around it will be as if I just started mashing my keyboard wildly. especially the aarow keys, cause it has a tennancy to execute commands I have done recently, or just act as if I had presed enter like 20 times. As I said this is all caused by me merely moving the mouse after exiting X-windows. if I start up X windows back up the problem will go away (untill i close x-windows again or restart).

although this never hapens on boot up before I have a chance to open and close X-windows.

so does anyone know whats hapening or how I can stop it?
Old 12-07-2003, 11:23 PM   #2
Registered: Jul 2003
Posts: 658

Rep: Reputation: 30
You probably have the "gpm" program running.
It activates the mouse in the consoles.
try killing it using "killall gpm"
then edit the rc scripts to disable it from loading at bootup
Old 12-08-2003, 12:48 AM   #3
Senior Member
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Why on earth would you want to disable gpm? It's not gpm that's causing the problem.

I'd check the connections of your mouse and keyboards to make sure they're secure.

However, such symptoms are usually due to faulty or soon-to-be faulty mice... By the way, you mouse wouldn't happen to be from A4Tech now would they?
Old 12-08-2003, 02:50 AM   #4
Registered: Dec 2003
Location: USA (Pacific coast)
Distribution: Vector 5.8-SOHO, FreeBSD 6.2
Posts: 513

Rep: Reputation: 34
I have to agree with Azmeen that running gpm while in a GUI is not the problem.......I have the gpm started at boot up and use the IMPS/2 protocol for my Logitech wheel mouse in the gui and never experienced any anomalies in the terminal window in the GUI or when switching to the CLI.....
Old 12-08-2003, 11:01 AM   #5
Registered: Oct 2003
Location: California
Distribution: Ubuntu
Posts: 582

Original Poster
Rep: Reputation: 30
I am having no problems while I'm in Xwindows, nor do i have problems when I boot up. but as soon as I do startx and then exit xwindows (via ctrl+alt+backspace, or killing it by the command in the fluxbox menu) after that my mouse acts posesed while in command line, but if i carefully (without touching the mouse) type in startx to get xwindows back up, the mouse works perfectly while xwindows is going.
Old 12-08-2003, 03:00 PM   #6
Senior Member
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Shot in the dark, but check out rc.gpm. Sometimes the console mouse will 'work' but be configured differently. Maybe it's going haywire from being a imps2 in X to a ps2 in console or something.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
X11 Input drivers (keyboard and mouse), events Cyborg16 Linux - Software 1 05-22-2005 09:01 AM
Disable mouse, keyboard or other input devices / drivers bastl Programming 0 05-15-2005 06:39 AM
Keyboard/Mouse Input Freezes - Slackware 10 - Powerbutton fixes it johnp05 Linux - Hardware 0 08-22-2004 10:13 PM
Keyboard and mouse input problems in 9.1 soup Slackware 6 09-30-2003 02:57 PM
newbie installation problem: no keyboard/mouse input vytlacil Linux - Newbie 0 08-09-2003 06:03 PM

All times are GMT -5. The time now is 08:31 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration