LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 04-25-2006, 08:02 PM   #1
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Rep: Reputation: 30
ffmpeg


To whom it may concern,

I have recently update my ffmpeg program for fedora core 4 and I am trying to title my mp4 files for the psp using the -title command. I am encoding my avi files to mp4 and am using the -title command to name the mp4 file when I put it on the psp. When I use this command this is what comes up: ffmpeg -i c1.avi -title constantine -f psp -r 29.970 -b 450 -ar 2400 -ab 64 -s 320x240 M4V00002.MP4
ffmpeg version CVS, build 3342336, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --prefix=/usr --libdir=/usr/lib --mandir=/usr/share/man --cpu=x86 --extra-cflags=-O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables --enable-mp3lame --enable-libogg --enable-vorbis --enable-theora --enable-faad --enable-faadbin --enable-faac --enable-libgsm --enable-xvid --enable-a52 --enable-a52bin --enable-pp --enable-shared-pp --enable-shared --enable-gpl --disable-debug --disable-opts --disable-strip
built on Apr 1 2006 03:02:33, gcc: 4.0.2 20051125 (Red Hat 4.0.2-8)
Segmentation fault
Can someone give me a step by step command on how to fix this problem and be able to title my mp4 files for the psp?
 
Old 04-25-2006, 09:30 PM   #2
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Excerpt from http://gentoo-wiki.com/HOWTO_PSP

Quote:
The media-video/ffmpeg tool does everything we need to convert videos to play on PSP devices.

1. Emerge the lastest version of ffmpeg with the aac flag

#ACCEPT_KEYWORDS="~x86" USE="aac" emerge -pv ffmpeg

2. Convert the video to PSP format

#ffmpeg -i Video.avi -f psp -r 29.970030 -b 768 -ar 24000 -ab 64 -s 320x240 M4V00001.MP4

2.1. Remember, we must use names like M4V00001.MP4, M4V00002.MP4, ...

3. Extract the thumbnail image

#ffmpeg -y -i Video.avi -f image2 -ss 5 -vframes 1 -s 160x120 -an M4V00001.THM

3.1. Use the same output file name, but replace the file extension with THM.

4. Mount PSP device

#mount -t vfat -o shortname=win95,check=s /dev/sda1 /mnt/PSP

5. Make the folder, if inexistant, to put your videos

#mkdir /mnt/PSP/MP_ROOT/100MNV01

6. Copy the file

#cp M4V00001.MP4 /mnt/PSP/MP_ROOT/100MNV01/
 
Old 04-25-2006, 10:09 PM   #3
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
What does number 1 mean? Does it mean that the ffmpeg version with the aac flag will work? Do I have to update it again or is that the command under number 1?
 
Old 04-25-2006, 10:26 PM   #4
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Yes, It's just saying you need to have aac configured with ffmpeg. Sorry, that command is specific to gentoo. I don't think FedoraCore uses emerge so you will need to get the aac libraries separately (they are not part of ffmpeg). I belive they are called libfaac & libfaad. You can find them on http://www.rpmfind.net

...drkstr
 
Old 04-30-2006, 05:02 PM   #5
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
It is still not working and I have all the updates for faac and faad. Is there an update for aac for Fedora Core 4? Any answer will be greatly appreciated. Thank you.After I do the same command the samething comes up:ffmpeg -i b1.avi -title batman1 -f psp -r 29.970030 -b 768 -ar 24000 -ab 64 -s 320x240 M4V00001.MP4
ffmpeg version CVS, build 3342336, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --prefix=/usr --libdir=/usr/lib --mandir=/usr/share/man --cpu=x86 --extra-cflags=-O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables --enable-mp3lame --enable-libogg --enable-vorbis --enable-theora --enable-faad --enable-faadbin --enable-faac --enable-libgsm --enable-xvid --enable-a52 --enable-a52bin --enable-pp --enable-shared-pp --enable-shared --enable-gpl --disable-debug --disable-opts --disable-strip
built on Apr 1 2006 03:02:33, gcc: 4.0.2 20051125 (Red Hat 4.0.2-8)
Segmentation fault
 
Old 04-30-2006, 05:48 PM   #6
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
When you built ffmpeg from the source, what did you specify for your configuration? I belive it needs to be configured something like this:
Code:
./configure --enable-memalign-hack -enable-gpl --enable-xvid --enable-faac
I noticed that the line in bold wasn't listed in your
'Configuration:' section. I'm not sure if it's what's causing the problem or not but you might want to give it a try.

regards,
...drkstr

Last edited by drkstr; 04-30-2006 at 05:50 PM.
 
Old 04-30-2006, 07:12 PM   #7
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
When I do the configure command this is what comes up: enable -f -memalign-hack -f -enable-gpl -f --enable-xvid -f --enable-faac
enable .
enable :
enable [
enable alias
enable bg
enable bind
enable break
enable builtin
enable caller
enable cd
enable command
enable compgen
enable complete
enable continue
enable declare
enable dirs
enable disown
enable echo
enable enable
enable eval
enable exec
enable exit
enable export
enable false
enable fc
enable fg
enable getopts
enable hash
enable help
enable history
enable jobs
enable kill
enable let
enable local
enable logout
enable popd
enable printf
enable pushd
enable pwd
enable read
enable readonly
enable return
enable set
enable shift
enable shopt
enable source
enable suspend
enable test
enable times
enable trap
enable true
enable type
enable typeset
enable ulimit
enable umask
enable unalias
enable unset
enable wait
What does this mean? I see that none of what I want enabled is on that list? All of this help is greatly appreciated thank you so much for your patience.
 
Old 04-30-2006, 09:08 PM   #8
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
'enable' has to due with printers and is not the command you are looking for. The command you need is:
Code:
./configure --prefix=/usr --enable-memalign-hack --enable-gpl --enable-xvid --enable-faac
which must be done in the main directory of the ffmpeg source code. Please note I added in --prefix=/usr to the configure options. I'm pretty sure it does this by default but you should add it in there just to be sure. You will then compile with 'make', and install with 'make install'. Before you compile and install ffmpeg from the source, I would make sure you remove any previous ffmpeg packages you might have installed. Also, make sure libfaac & libfaad are installed in /usr and not in /usr/local. If they are, create simlinks in /usr pointing to the correct directory.

regards,
...drkstr
 
Old 05-07-2006, 10:08 PM   #9
Polanski
Member
 
Registered: Sep 2004
Posts: 234

Original Poster
Rep: Reputation: 30
I have updated everything and this is what comes up when I try ffmpeg again: ffmpeg -i henderson.avi -title henderson -f psp -r 29.970 -b 450 -ar 2400 -ab 64 -s 320x240 M4V00002.MP4
ffmpeg version CVS, build 3342336, Copyright (c) 2000-2004 Fabrice Bellard
configuration: --prefix=/usr --libdir=/usr/lib --mandir=/usr/share/man --cpu=x86 --extra-cflags=-O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -m32 -march=i386 -mtune=pentium4 -fasynchronous-unwind-tables --enable-mp3lame --enable-libogg --enable-vorbis --enable-theora --enable-faad --enable-faadbin --enable-faac --enable-libgsm --enable-xvid --enable-a52 --enable-a52bin --enable-pp --enable-shared-pp --enable-shared --enable-gpl --disable-debug --disable-opts --disable-strip
built on Apr 1 2006 03:02:33, gcc: 4.0.2 20051125 (Red Hat 4.0.2-8)
Input #0, avi, from 'henderson.avi':
Duration: 01:38:40.8, start: 0.000000, bitrate: 991 kb/s
Stream #0.0, 25.00 fps(r): Video: mpeg4, yuv420p, 640x352
Stream #0.1: Audio: mp3, 48000 Hz, stereo, 32 kb/s
File 'M4V00002.MP4' already exists. Overwrite ? [y/N] y
Output #0, psp, to 'M4V00002.MP4':
Stream #0.0, 29.97 fps(c): Video: mpeg4, yuv420p, 320x240, q=2-31, 450 kb/s
Stream #0.1: Audio: aac, 2400 Hz, stereo, 64 kb/s
Stream mapping:
Stream #0.0 -> #0.0
Stream #0.1 -> #0.1
[mpeg4 @ 0x4be2e8]removing common factors from framerate
[aac @ 0x4be2e8]libfaac doesn't support this output format!
Error while opening codec for output stream #0.1 - maybe incorrect parameters such as bit_rate, rate, width or height
What should I change? Thank you for your patience and time.
 
Old 05-10-2006, 02:52 PM   #10
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Quote:
I have updated everything and this is what comes up when I try ffmpeg again:
When you say you updated everything, do you mean you ran the ./configure with the correct options then recompiled/installed? Did you make sure the new ffmpeg you are running is the new one you just compiled? I still do not see --enable-memalign-hack in the configure options you posted. To be honest, I am not sure what this is but I have seen it on any howto referring to this topic; I'm pretty sure it's necessary but I could be wrong.

If you are sure you installed correctly, I would try running the command exactly as it is in the howto before adding in your own options.
Code:
ffmpeg -i Video.avi -f psp -r 29.970030 -b 768 -ar 24000 -ab 64 -s 320x240 M4V00001.MP4
If this works, add your changes one by one to figure out where it craps out on you. You will then be able to determine the fix more easily.

regards,
...drkstr
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Polanski Linux - Laptop and Netbook 5 01-11-2006 08:01 PM
Problem with ffmpeg.. BDiddy Linux - Software 0 10-18-2005 04:38 PM
ffmpeg Polanski Linux - Software 0 07-25-2005 11:05 PM
ffmpeg RySk8er30 Linux - Software 3 06-25-2005 12:10 PM
ffmpeg vs mplayer Lobais Linux - Software 1 01-12-2005 01:47 PM


All times are GMT -5. The time now is 04:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration