LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-03-2004, 12:00 PM   #16
alberto2498
LQ Newbie
 
Registered: May 2002
Location: USA
Distribution: Mandrake 9.0
Posts: 26

Rep: Reputation: 15

I checked the printer that you have on linuxprinting.org for that particular printer and is not listed, that could be part of the reason, is not fully compatible, eventhough it prints something, is not using the right driver, I will try to check on the net to see if there is a particular ppd file that you can use with this one.

Alberto
 
Old 03-03-2004, 03:48 PM   #17
matt3333
Member
 
Registered: Dec 2002
Location: Winnipeg, Manitoba, Canada
Distribution: Slackware
Posts: 371

Original Poster
Rep: Reputation: 30
Ok thank-you alberto2498. Awhile Back i was checking out the site and i noticed someone there had it working and they were just trying to get digital thing where u put your memory stick and it reads the digital picutes that way. I tried emailing him and i asked him about how he got it working he said that he didnt know and that someone else hooked it up for him. So hopefully we can get it working!!
Thank-you So much1!!

Matt3333
 
Old 03-03-2004, 08:38 PM   #18
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Do you have a BJC-7000 driver, try and give that a try I was googling around and somebody said that the Canon i470D works with the BJC-7000 driver.

HTH
 
Old 03-04-2004, 09:31 AM   #19
matt3333
Member
 
Registered: Dec 2002
Location: Winnipeg, Manitoba, Canada
Distribution: Slackware
Posts: 371

Original Poster
Rep: Reputation: 30
Ok i get the same problem with it printing out a test page fine then when i try it in mozilla nothing happens. Hmm when you go to crtl+P you get this box which says postscript/default then on the side of that theres the properties botton when you click that you get the command. It printing with do you know what i mean? I noticed it was using lpr instead of cups which im using maybe thats just the defualt way of printing?? anyhow i thought i would ask. I really hope we can get this working!!!!! Thank-you guys for all your time so far!!!

Matt3333
 
Old 03-04-2004, 12:36 PM   #20
alberto2498
LQ Newbie
 
Registered: May 2002
Location: USA
Distribution: Mandrake 9.0
Posts: 26

Rep: Reputation: 15
This is the command from my machine,(the one Im using in this ver moment)
lpr ${MOZ_PRINTER_NAME:+'-P'}${MOZ_PRINTER_NAME}
I think if not wrong that that is the default way of printing, eventhough you see that part of lpr it will print, basically what happens is that the lpr command filters the information and sends it to cups which at the same time will send to your printer, do you have lpr installed? that could be part of the problem.

Alberto
 
Old 03-05-2004, 07:49 PM   #21
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
I found this thread in the forums, seems to be the same problem you are having with being able to print a test page but not able to print from mozilla, might help you out also.

http://www.linuxquestions.org/questi...hreadid=153890
 
Old 03-06-2004, 11:48 AM   #22
matt3333
Member
 
Registered: Dec 2002
Location: Winnipeg, Manitoba, Canada
Distribution: Slackware
Posts: 371

Original Poster
Rep: Reputation: 30
Thats AWSOME it work it work it work it real;llly works yayayayay thank-you for that link!! ok now how would i set it up so it uses lpr-cups for everything now??? THANK-YOU SOOO MUCH!!!!!I cant believe thats all it was!!

Matt3333
 
Old 03-06-2004, 05:08 PM   #23
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
From what I could pick up from that link it seems that Mozlla would be the only application that needs the printer setup like that, the rest of your programs should work.
 
Old 03-14-2004, 01:52 AM   #24
matt3333
Member
 
Registered: Dec 2002
Location: Winnipeg, Manitoba, Canada
Distribution: Slackware
Posts: 371

Original Poster
Rep: Reputation: 30
Actually Mozilla is the only program that works!! Im trying to print off my resume Using OpenOffice.org1.1.0 and its not working again ibelieve with the whole default printer and printing with lpr and not lpr-cups is there a ways to make the command lpr-cups as Default????AbiWord is also not working!!! If there was a way to put these files onto mozilla i would just do that and print them off there but not happening. Oh i also tried exporting them as pdf's and printing with xpdf i think and that doesnt work as well!! Please help me !! Thank you!!

Matt3333
 
Old 03-15-2004, 01:08 AM   #25
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Did you use the printer set-up function with open office, I believe you should be able to change it the way you did mozilla, just go into your menu and choose printer setup, if it isn't there then try this at a prompt: /path/to/openoffice/installation/oopadmin this should allow you to set your printer up like in Mozilla.

HTH.

Let us know if it works, hopefully we will nip this in the bud soon, sorry I didn't respond sooner but I was out of town this weekend.
 
Old 03-16-2004, 12:09 AM   #26
matt3333
Member
 
Registered: Dec 2002
Location: Winnipeg, Manitoba, Canada
Distribution: Slackware
Posts: 371

Original Poster
Rep: Reputation: 30
Oh i c well its too late now. All i did was make a symbolic link from lpr to lpr-cups so now every frigen program works lol hehe!! Thank-you for your help and patience with this damn issues hehe thanks again!

Matt3333
 
Old 03-16-2004, 11:41 PM   #27
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Way to go !!! Glad you finally got all the programs printing what a relief phewww!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
get Page size eshwar_ind Programming 9 09-29-2014 12:46 PM
Help printer from a samba shared printer from linux (using cups) epod69 Linux - Networking 3 12-04-2005 11:44 PM
parrellel printer in CUPS? No parellel printer option... servnov Linux - General 3 10-31-2004 03:08 PM
cups printing: can print test page, but printer not available in openoffice hamish Linux - Software 4 07-05-2004 12:50 PM
Programs are not using my printer (even though test page in cups works) TheOneAndOnlySM Slackware 4 10-14-2003 09:04 PM


All times are GMT -5. The time now is 08:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration