LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-19-2003, 07:57 AM   #1
raid517
Member
 
Registered: Feb 2002
Posts: 393

Rep: Reputation: 30
Cannot Get KDE to compile


Does anyone know what this means and hwo to fix it? It happens when trying to download and compile KDE. I'm using Gentoo Linux.

code:# emerge mysql
Calculating dependencies ...done!
>>> emerge (1 of 7) dev-db/mysql-4.0.13-r3 to /
>>> md5 src_uri ;-) mysql-4.0.13.tar.gz
*
* If you're upgrading from MySQL-3.x, you must recompile the other
* packages on your system that link with libmysqlclient after the
* upgrade completes. To obtain such a list of packages for your
* system, you may use the: /usr/portage/dev-db/mysql/files/rebuilder.sh
* script.
*
>>> Unpacking source...
static
ssl
* MySQL does not support building statically with SSL support

!!! ERROR: dev-db/mysql-4.0.13-r3 failed.
!!! Function src_unpack, Line 54, Exitcode 0
!!! MySQL does not support building statically with SSL support.



Apparently Gentoo wants to install MySQL in order to compile/install KDE.

Its not just KDE that is refusing to compile becuase of this. A lot of things seem to want to use MySQL. I just don't seem able to get it to compile.

I edited my USE flags and removed SSL (though this was after most of the system was installed, but this had no effect.

All advice is welcome.

Q
 
Old 06-19-2003, 08:29 AM   #2
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
go into the portage directory where mysql is and
try some of the other versions in there.

/usr/portage/dev-db/mysql
 
Old 06-19-2003, 08:48 AM   #3
raid517
Member
 
Registered: Feb 2002
Posts: 393

Original Poster
Rep: Reputation: 30
Erm... sorry for being such a Gentoo n00b (and I have asked about this on their forums but didn't get a response) but I'm not sure what it is your recommending I do. Which version of MySQL would you recommend? And what would I tell poratage to do? Emerge MySQL_version number... Do you know of a version that will compile with static SSL support. And what exactly is "static" ssl support? I assume SSL means Secure Socket Layer, but what about the static part?

Thanks very much for the response.

Q
 
Old 06-19-2003, 09:19 AM   #4
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
there's usually several versions of programs in the
ebuilds directory, and when i need one to work that
doesn't, i try the others there. more often than not,
one does work, and i can continue on. it's been a while,
but i think i mean for you to enter the directory with
the specific ebuilds, and emerge full_ebuild_name
 
Old 06-19-2003, 09:37 AM   #5
raid517
Member
 
Registered: Feb 2002
Posts: 393

Original Poster
Rep: Reputation: 30
No man I read the docs a little more closely. Here's what I found.

If i don't want to use something, or something is giving me trouble, then I can ommit it in my USE flags: For example:

Code:
USE="-mysql"
If howeve a particular component is giving me trouble I can ommit that specific component. In this case:

Code:
USE="-mysql"
Now when I compile MySQL everything goes smoothly.

I just thought I'd let you know I'd fixed it in case anyone else ever experiences it.

Thanks for the response anyway.

Q
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kde 3.4 compile error forrest44 Linux - Software 4 04-04-2005 05:06 AM
KDE 3.3 Compile Error AFI_Flame Linux - Software 2 09-26-2004 07:51 PM
KDE 3.2.2 Won't Compile AFI_Flame Linux - Software 13 05-23-2004 07:51 AM
kde 3.2.2 compile jxn Linux - Newbie 2 04-24-2004 11:58 AM
Before I compile KDE 3.1... cmckay Linux - Software 1 01-29-2003 08:08 PM


All times are GMT -5. The time now is 10:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration