LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 04-01-2005, 03:11 AM   #1
Cogvos
Member
 
Registered: Feb 2005
Distribution: Suse 9.3 also Redhat 9, Umbuto, Mandriva 2005
Posts: 31

Rep: Reputation: 15
Unhappy ./autogen.sh Sheepshaver fails to detect xorg DGA extension


Dear all,

Once again I am afraid that I am stuck. I'm trying to compile the latest SheepShaver CVS on Ubuntu's Hoary Hedghog distribution. The problem I am having is that ./autogen.sh is not detecting the DGA extension to X.

I have checked the libggi-target-x package and that is installed. Running DGA displays a corrupted screen and then pressing keys displays varying muddy shades of grey rather than colours. However pressing q gets me back to the terminal with what appears to be a correct output displayed so I am guessing that DGA is ok, but not sure.

Also ./autogen.sh does not detect vidmode, but I know even less about this that I do about DGA, and I know practically nothing about that

So my questions

How do I confirm that DGA is installed
How do I get sheepshaver to detect either DGA or Vidmode, if that's what it needs.

Many thanks

John.
 
Old 04-01-2005, 10:52 PM   #2
kak
Member
 
Registered: Jul 2004
Location: Moriarty, NM, USA about 100 yards form Rattle Snake Coutry
Distribution: Slackware , Ubuntu
Posts: 269

Rep: Reputation: 30
Check your xorg.conf (in /etc/X11)
The relevent section in mine it currently reads:
Quote:
# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
I am not sure of the reasoning behind it but I believe Xorg disables DGA by defualt (at least in every install of Xorg I've had with Slackware).
Just comment out this section and restart X.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg -configure doesn't detect my PS/2 mouse whoever Linux - Newbie 2 08-11-2005 01:01 PM
Disable Xorg Monitor Auto Detect! wh33t Linux - Software 1 06-02-2005 06:02 AM
Xorg Composite Extension Slow with nVidia Twinview jaws_tas Linux - Software 1 04-26-2005 09:12 AM
Enabling transparency in Xorg 6.8.0 with composite extension...?! SBing Linux - Software 8 09-12-2004 09:09 AM
slackware, vmware, dga-extension enable? neenee Slackware 5 07-25-2003 07:43 AM


All times are GMT -5. The time now is 04:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration