LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-02-2003, 05:58 AM   #1
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Rep: Reputation: 30
Unhappy slackware, vmware, dga-extension enable?


hi everyone.

today i installed vmware 4 workstation. installation had a few
problems, but i sorted them out using some guides and how-
tos i found using the ever useful google.

i wanted to install windows xp - but when i attempt to do
so, vmware warns me about the lack of dga support.

i tried commenting out the omit dga extension bit in
XF86Config, but that just made it so that my windows no
longer had round corners and transparency was no longer
supported in X / Gnome; vmware could still not find the
dga extension..

my question is:

how would i go about enabling the dga extension?

thank in advance for any ideas leading to a solution.
 
Old 05-02-2003, 11:48 AM   #2
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Original Poster
Rep: Reputation: 30
oh... and i get this error:

Could not open /dev/vmnet0: No such device
Device Ethernet0 will start disconnected

i do have /dev/vmnet0 through something.. but
how do i make it usable for vmware?

thanks in advance.

*update..

i remembered that vmware worked before i rebooted;
i then retraced the steps i took in my head... then i ran
/usr/bin/vmware-config.pl; and i noticed that two modules were
created:

vmmon
vmnet

and i have added those to /etc/rc.d/rc.local to load
them on boot.

and now it works. yay

(but the dga-problem remains)

Last edited by neenee; 05-02-2003 at 01:23 PM.
 
Old 05-02-2003, 10:13 PM   #3
Magnetar
Member
 
Registered: Feb 2003
Location: Somewhere in the Milky Way Galaxy
Distribution: FC3, Ubuntu Hoary, Gentoo sometimes
Posts: 31

Rep: Reputation: 15
read this http://www.cs.ucr.edu/~jbyrne/vmware.htm
there are files created during install that are place in rc.? directories - they are process scripts that enable your virtual adapters and devices - they are virtual devices that are intermediaries between vmware and the host os- without those u cant access sound cards etc - sounds like youre missing this step- u can include the script to run at startup - i prefer to make a link and start it right before starting my virtual machine - hope it helps
 
Old 05-05-2003, 02:34 AM   #4
pesho_p
Member
 
Registered: Oct 2002
Location: 42 42' N, 23 19' E
Distribution: Slackware 8.1
Posts: 77

Rep: Reputation: 15
Quote:
Originally posted by neenee
(but the dga-problem remains)
Code:
Section "Module"
	Load  "dbe"
	Load  "glx"
	SubSection "extmod"
	#	Option "omit xfree86-dga"
	EndSubSection
	Load  "type1"
	Load  "freetype"
EndSection
neenee, commenting or removing 'Option "omit xfree86-dga"' line from my '/etc/X11/xF86Config' works for me (MGA G400 DualHead). See here:

http://www.geocities.com/pesho_pv/vmware.png (~410KB, 2048x768)

I was a so curio to see this release of VMWare (and even more new Fontconfig 2.2, in fact) that I installed my Slackware 8.1 again (10 hours backups on CDs, installing, compiling, tweaking, etc. but now everything works OK). Probably you have problems with your video drivers (NVIDIA?), because, as I've already told you, it works like a charm on my DualHead "dragon"

Last edited by pesho_p; 05-05-2003 at 03:05 AM.
 
Old 05-06-2003, 04:45 AM   #5
neenee
Member
 
Registered: Feb 2003
Location: Netherlands
Distribution: debian (sid)
Posts: 693

Original Poster
Rep: Reputation: 30
magnetar: thank you. i had overlooked a section to
create a vmware load script. i have done that now and
it works like a charm.

pesho: silly me. i commented out the whole subsection
extmod; now that i commented out only the omit-bit,
it works.
 
Old 07-25-2003, 07:43 AM   #6
ramania
LQ Newbie
 
Registered: Jul 2003
Posts: 1

Rep: Reputation: 0
Additional comment...

In pesho_p's comment, include some fault

-----------------------------------------------------------
Section "Module"
Load "dbe"
Load "glx"
SubSection "extmod"
# Option "omit xfree86-dga"
EndSubSection

Load "extmod" # <--Here...

Load "type1"
Load "freetype"
EndSection
-----------------------------------------------------------

The point "Here". load extmod to use dga extention.
Many guys commit this fault...

Minus '#' from /"# Option "omit xfree86-dga" /", and
add /" Load "extmod" /"...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
./autogen.sh Sheepshaver fails to detect xorg DGA extension Cogvos Linux - Software 1 04-01-2005 10:52 PM
does VMware 4.5.1 requires DGA in Xfree86? jogurt666 Linux - Software 4 11-02-2004 01:15 PM
vmware , xfree4.3 ,dga, ati szymon Linux - Software 0 03-31-2004 03:00 PM
XF86Config: How to enable DGA? trey85stang Slackware 2 03-20-2004 02:51 PM
vmware black screen dga russian_knight Linux - Software 0 11-05-2003 12:25 PM


All times are GMT -5. The time now is 03:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration