-   Linux - Software (
-   -   ./ Sheepshaver fails to detect xorg DGA extension (

Cogvos 04-01-2005 03:11 AM

./ Sheepshaver fails to detect xorg DGA extension
Dear all,

Once again I am afraid that I am stuck. I'm trying to compile the latest SheepShaver CVS on Ubuntu's Hoary Hedghog distribution. The problem I am having is that ./ is not detecting the DGA extension to X.

I have checked the libggi-target-x package and that is installed. Running DGA displays a corrupted screen and then pressing keys displays varying muddy shades of grey rather than colours. However pressing q gets me back to the terminal with what appears to be a correct output displayed so I am guessing that DGA is ok, but not sure.

Also ./ does not detect vidmode, but I know even less about this that I do about DGA, and I know practically nothing about that :(

So my questions

How do I confirm that DGA is installed
How do I get sheepshaver to detect either DGA or Vidmode, if that's what it needs.

Many thanks


kak 04-01-2005 10:52 PM

Check your xorg.conf (in /etc/X11)
The relevent section in mine it currently reads:

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
I am not sure of the reasoning behind it but I believe Xorg disables DGA by defualt (at least in every install of Xorg I've had with Slackware).
Just comment out this section and restart X.

All times are GMT -5. The time now is 12:41 AM.