LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-18-2004, 04:40 AM   #1
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
alsa settings not saved


Since I upgraded to KDE 3.3 my alsa settings don't save anymore. I have tried to reconfigure alsa-base to autosave always but it doesn't work. When I reboot the line that says it stores the alsa settings is there but after the reboot all volumes are at 0 again. I disabled the kde soundserver BTW cause it doesn't allow more than 1 program using the sound card.
 
Old 08-18-2004, 05:13 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Have you tried this?

Open a terminal, issuing "alsmixer" as a normal user and set the mixer.
Then login as root and issue "alsactl store" to save the settings.
This is the proper way according to the instructions from ALSA.
 
Old 08-18-2004, 05:13 AM   #3
phase9
Member
 
Registered: Mar 2004
Location: austria, vienna
Distribution: slackware-10.2
Posts: 89

Rep: Reputation: 15
Hi!

Quote:
alsa settings don't save anymore
Tried to save the settings with `/usr/sbin/alsactl store' (as root)?

Quote:
disabled the kde soundserver BTW cause it doesn't allow more than 1 program using the sound card
Try "Auto-suspend if idle after" "0 seconds" (KDE/Soundsystem). I had a simmilar problem. KDE blocked the sound for XMMS, but after setting the idle time to 0 sec., the problem was solved.
 
Old 03-04-2005, 09:07 AM   #4
nukey
Member
 
Registered: Dec 2004
Location: Netherlands
Distribution: Slackware
Posts: 173

Rep: Reputation: 30
Re: alsa settings not saved

Quote:
Originally posted by darkleaf
Since I upgraded to KDE 3.3 my alsa settings don't save anymore. I have tried to reconfigure alsa-base to autosave always but it doesn't work. When I reboot the line that says it stores the alsa settings is there but after the reboot all volumes are at 0 again. I disabled the kde soundserver BTW cause it doesn't allow more than 1 program using the sound card.
I am having the same problem.

Ran alsamixer as normal user
As root ran alsactl store

logged in as the normal user and the settings were all still there.

The i started X, opened a terminal and ran alsamixer and the settings are gone..
 
Old 03-11-2005, 11:43 AM   #5
zerget
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Rep: Reputation: 0
Mine saved after I restarted alsa
Code:
/etc/init.d/alsasound restart
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
application settings not saved in 9.2 gavinbeatty Suse/Novell 0 12-09-2004 04:43 PM
Where are settings for apps saved? vbmark Mandriva 1 11-19-2004 08:58 AM
ALSA settings not saved on shutdown hamish Linux - Software 4 06-06-2004 12:06 PM
Firewall settings aren't saved Error1312 Mandriva 10 05-31-2004 10:47 AM
NIC settings not being saved supa2003 Linux - Networking 4 01-17-2004 07:20 PM


All times are GMT -5. The time now is 07:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration