LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   alsa settings not saved (http://www.linuxquestions.org/questions/linux-software-2/alsa-settings-not-saved-219144/)

darkleaf 08-18-2004 05:40 AM

alsa settings not saved
 
Since I upgraded to KDE 3.3 my alsa settings don't save anymore. I have tried to reconfigure alsa-base to autosave always but it doesn't work. When I reboot the line that says it stores the alsa settings is there but after the reboot all volumes are at 0 again. I disabled the kde soundserver BTW cause it doesn't allow more than 1 program using the sound card.

Bruce Hill 08-18-2004 06:13 AM

Have you tried this?

Open a terminal, issuing "alsmixer" as a normal user and set the mixer.
Then login as root and issue "alsactl store" to save the settings.
This is the proper way according to the instructions from ALSA.

phase9 08-18-2004 06:13 AM

Hi!

Quote:

alsa settings don't save anymore
Tried to save the settings with `/usr/sbin/alsactl store' (as root)?

Quote:

disabled the kde soundserver BTW cause it doesn't allow more than 1 program using the sound card
Try "Auto-suspend if idle after" "0 seconds" (KDE/Soundsystem). I had a simmilar problem. KDE blocked the sound for XMMS, but after setting the idle time to 0 sec., the problem was solved.

nukey 03-04-2005 10:07 AM

Re: alsa settings not saved
 
Quote:

Originally posted by darkleaf
Since I upgraded to KDE 3.3 my alsa settings don't save anymore. I have tried to reconfigure alsa-base to autosave always but it doesn't work. When I reboot the line that says it stores the alsa settings is there but after the reboot all volumes are at 0 again. I disabled the kde soundserver BTW cause it doesn't allow more than 1 program using the sound card.
I am having the same problem.

Ran alsamixer as normal user
As root ran alsactl store

logged in as the normal user and the settings were all still there.

The i started X, opened a terminal and ran alsamixer and the settings are gone..

zerget 03-11-2005 12:43 PM

Mine saved after I restarted alsa
Code:

/etc/init.d/alsasound restart


All times are GMT -5. The time now is 06:27 PM.