LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-23-2007, 11:31 PM   #1
rajat
LQ Newbie
 
Registered: Jan 2007
Posts: 20

Rep: Reputation: 0
DNS error : "localhost.zone file not found"


Hi All,

I'm using Fedora Core 6, kernel 2.6.18-1.2798.fc6. I have a problem with the DNS server. I'm using

1. bind-9.3.2-41.fc6.i386.rpm
2. bind-chroot-9.3.2-41.fc6.i386.rpm

I have created a few zone files of my own and these new zone files get loaded perfectly, yet the problem is with the default localhost.zone file. The error is:

Apr 23 12:03:36 localhost named: zone localhost/IN: loading master file localhost.zone: file not found
Apr 23 12:03:36 localhost named: _default/localhost/IN: file not found
Apr 23 12:03:36 localhost named: zone 0.0.127.in-addr.arpa/IN: loading master file named.local: file not found
Apr 23 12:03:36 localhost named: _default/0.0.127.in-addr.arpa/IN: file not found
Apr 23 12:03:36 localhost named: zone gan/IN: loaded serial 200211152
Apr 23 12:03:36 localhost named: zone org/IN: loaded serial 200211152


Please suggest what could be wrong here.

Regards,
Rajat
 
Old 04-24-2007, 03:43 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,898

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
You have the 2 zones: localhost and the reverse 0.0.127.in-addr.arpa in your named.conf, but you don't have the respective zone files. You should create 2 zone files (use the names already in your named.conf):
localhost zone:
Code:
localhost       A       127.0.0.1
0.0.127.in-addr.arpa
Code:
1                   PTR   localhost.
 
Old 04-25-2007, 11:26 PM   #3
rajat
LQ Newbie
 
Registered: Jan 2007
Posts: 20

Original Poster
Rep: Reputation: 0
Resolved this problem. Found that the the caching-nameserver rpm was missing. After having installed this rpm the problem got resolved.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error: File ".Blanguage" not found dr_zayus69 Linux - Software 1 04-06-2005 06:08 PM
Error: "A required .DLL file, CYGPCRE -0.DLL, was not found" when using man dipperdan Linux - Newbie 2 04-28-2004 03:55 PM
blender ERROR file ".Blanguages" not found adhara Linux - Software 2 12-25-2003 03:37 PM
MA-311 on eth0 inaccessible via Linux, "Network Unreachable" error, no localhost ping LGMike Linux - Networking 14 09-21-2003 11:11 PM
DNS lookup going out for "localhost"?? chris_mate Linux - Networking 6 12-22-2002 02:24 AM


All times are GMT -5. The time now is 06:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration