LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 09-20-2003, 01:26 AM   #1
LGMike
LQ Newbie
 
Registered: Sep 2003
Location: USA
Distribution: Mandrake
Posts: 22

Rep: Reputation: 15
Unhappy MA-311 on eth0 inaccessible via Linux, "Network Unreachable" error, no localhost ping


I am using Linux kernel 2.4.21-0.13mdk (Linux Mandrake 9.1's default kernel), and my problem is that I am unable to access the network card, a Netgear MA311 using the Orinoco driver (it's a Prism 2.5 card, I believe), through Linux. When I boot into Windows 98 (it's a dual boot server), I am able to do things fine, but I need Linux to work with it. It is running as my Primary Domain Controller via Samba.
Pinging any and all IPs, including the loopback IP, local host's IP, default gateway, internet IPs and other local network hosts returns a "Network Unreachable" error.
I have attempted both static and DHCP IP address assignment. The router has a static IP address it always assigns this system, so I shouldn't be having problems with that, and when I have set up static addressing on this system, I am sure to set the router's static IP for the host and the local system's IP to be equal.
Physically the network is fine, as Windows 98 is able to access the network fine. Encryption has been checked numerous times.
I have disabled all internal firewalling in order to troubleshoot.
I asked my CCNA instructor what he thought and he wants to know how I fix it once I do so, so... any ideas anyone?
When I use Mandrake's Mandrake Control Center, networking section in X, it tells me e0 is up, but when I tell it to "connect", it says it's "connecting", then a few seconds later says "not connected" in the status bar. When I just attempted to connect it said it "sent 4.3kb, recieved 0b" and both send and receive times were at "0ms".
Wait! The status is now "87 bytes received 5.5 kb sent" about a minute later after I clicked on "logs"
My system is as follows:
Linux Mandrake 9.1 (kernel 2.4.21-0.13mdk)
firewall (IP Chains/shorewall) is off
Compaq AMD K-2 380mhz
ifconfig came up w the following about ethernet port 0 (eth0):
eth0
Link encap:Ethernet HWaddr *my mac address*
inet addr:192.168.0.3 Bcast: 192.168.0.255 Mask: 255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets: 144 errors:231 dropped:231 overruns:0 frame:182
TX packets: 0 errors:600 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes: 38694 (37.7 Kb) TX bytes: 68386 (66.6 Kb)
Interrupt:11 Base address: 0xa000 Memory: 41100000-41100fff

lo
Link encap: Local Loopback
inet addr:127.0.0.1 Mask 255.0.0.0
UP LOOPBACK RUNNING MTU: 16436 Metric:1
RX packets: 1668 errors:0 dropped:0 overruns: 0 frame:0
TX packets: 1668 errors:0 dropped:0 overruns: 0 carriedr:0
collisions:0 txqueuelen:0
RX bytes:121342 (118.4 Kb) TX bytes: 121342 (118.4 Kb)

Default gateway is set to the router at 192.168.0.1
Subnet mask is Class C (255.255.255.0)
Currently the IP address configuration is set to statically assign the IP address to the system, this setting matches the router's routing table.
The IP address is set to be assigned each time the host boots up.


If anyone has any ideas please reply and/or email me, or if you need more information, please tell me!

Mike

Last edited by LGMike; 09-20-2003 at 02:00 AM.
 
Old 09-20-2003, 01:49 AM   #2
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
So, if I understand your posted info, eth0 is set to the same exact ip address as your router?(192.168.0.1)?? This is not going to work, try this: "ifconfig eth0 192.168.0.2", or some other ip address on that subnet that is not the same as your router.
 
Old 09-20-2003, 01:58 AM   #3
LGMike
LQ Newbie
 
Registered: Sep 2003
Location: USA
Distribution: Mandrake
Posts: 22

Original Poster
Rep: Reputation: 15
no, the router's table matches w/ the server, more or less, this is what the routing table looks like:

Router 192.168.0.1 255.255.255.0
Linux1 192.168.0.3 255.255.255.0
(other hosts on the network)

the Linux server is set to statically assign its own IP as 192.168.0.3, there's a word for these matching values.... I just forgot what it is, at the moment!
 
Old 09-20-2003, 02:04 AM   #4
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
Quote:
and when I have set up static addressing on this system, I am sure to set the router's static IP for the host and the local system's IP to be equal.
I'm sorry, maybe I misunderstood the above statement, it sounds to me like you're saying that you're setting the router's static ip and eth0 to be equal.

Quote:
eth0
Link encap:Ethernet HWaddr *my mac address*
inet addr:192.168.0.1
Quote:
Default gateway is set to the router at 192.168.0.1
and the above posted info indicates the same thing: eth0 and your router are "assigned" the same ip address, is this not the case?
 
Old 09-20-2003, 02:07 AM   #5
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
suddenly, the posted info is edited...
 
Old 09-20-2003, 02:33 AM   #6
LGMike
LQ Newbie
 
Registered: Sep 2003
Location: USA
Distribution: Mandrake
Posts: 22

Original Poster
Rep: Reputation: 15
lol I edited it when I saw my typo, before you replied, after I replied (12:00)

sorry!

Mike
 
Old 09-20-2003, 02:50 AM   #7
LGMike
LQ Newbie
 
Registered: Sep 2003
Location: USA
Distribution: Mandrake
Posts: 22

Original Poster
Rep: Reputation: 15
anyway, that would not have any affect on the loopback address (127.0.0.1), which I believe I mentioned also results in "Network Unreachable". To be precise, everything but the loopback produces "Network Unreachable", loopback produces nothing. Since the firewall is disabled, ICMP should be getting through (unless my security settings are preventing this... yes and no--I disabled those settings and 127.0.0.1 still never responds to a ping on itself).
To me, this appears to most likely be a problem with OSI Layer 3 (networking), but could possibly be a Layer 2 (data link) networking problem too.
But just knowing that it is likely a problem with one of these two layers isn't helping me much!
The configuration appears to be correct to me. I don't see any obvious errors (besides that typo!). What could it be?!
 
Old 09-20-2003, 11:59 PM   #8
LGMike
LQ Newbie
 
Registered: Sep 2003
Location: USA
Distribution: Mandrake
Posts: 22

Original Poster
Rep: Reputation: 15
it's a WI-FI 802.11b network utilizing encryption, and the loopback address won't work
any hints?
 
Old 09-21-2003, 11:16 AM   #9
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
does the output of the route command show what you want it to?
does iwconfig show the correct settings, ie: mode, rate, key, etc.?
does iwconfig show "Access Point" and the correct MAC address for your router?
the ifconfig you posted shows quite a few bytes rx/tx'd, and has rx packets, but strangely no tx packets. If your card is atmel based, this is sadly a normal quirk of the driver from atmelwlandriver.sourceforge.net, if it's not an atmel card, the lack of tx packets makes me wonder, possibly a radio problem.
are the vars in /etc/sysconfig/network correct?
finally, how does /etc/sysconfig/network-scripts/ifcfg-eth0 look, are the vars set correctly?

here's what my route cmd shows:
Code:
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.2.0     *               255.255.255.0   U     0      0        0 eth0
127.0.0.0       *               255.0.0.0       U     0      0        0 lo
default         wrouter         0.0.0.0         UG    0      0        0 eth0
edit:
forgot to add that the "wrouter" above works because it is listed in /etc/hosts

Last edited by akaBeaVis; 09-21-2003 at 11:17 AM.
 
Old 09-21-2003, 01:29 PM   #10
code_slinger
LQ Newbie
 
Registered: Sep 2003
Location: Texas
Distribution: Mandrake 9.1
Posts: 8

Rep: Reputation: 0
You might check in /etc/sysctl.conf
I wasn't able to ping my linux box or even ping local host but then I changed the line that read:

net.ipv4.icmp_echo_ignore_all=1
to:
net.ipv4.icmp_echo_ignore_all=0

and it now lets me ping localhost from the linux box and to ping the known ip from the windows box.

If nothing else it would help you test your network setup on the localhost linux machine. Hope this helps.
 
Old 09-21-2003, 08:24 PM   #11
LGMike
LQ Newbie
 
Registered: Sep 2003
Location: USA
Distribution: Mandrake
Posts: 22

Original Poster
Rep: Reputation: 15
hey, thanks!!! It was a pretty dumb error on my part, I screwed up my essid on eth0, capitalized incorrectly!!! THANKS!!!!

Mike

btw,
the security audit that just ran on my system says a sniffer may be installed on my system; why might it think this and how can i find it and remove it? Thanks!
Also, it says eth0 is in promiscuous mode... how do i change this in Linux?

Last edited by LGMike; 09-21-2003 at 08:25 PM.
 
Old 09-21-2003, 08:49 PM   #12
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
promiscous mode is set by doing an ifconfig ethx promisc, I've never seen a distro setup a card with it on 'out of the box', check your ifcfg-eth0 for that, to turn it off manually, do ifconfig ethx -promisc. I've used it before on 2 cards in the same box to use the box as a adhoc router, but otherwise it seems odd to have it on.
 
Old 09-21-2003, 10:15 PM   #13
LGMike
LQ Newbie
 
Registered: Sep 2003
Location: USA
Distribution: Mandrake
Posts: 22

Original Poster
Rep: Reputation: 15
yeah... I'm using Mandrake 9.1....
Even if I disable it, if I've been rooted, it makes little difference....
Perhaps raising security...?
How far does Linux close up when set to maximum security? (e.g. the "paranoid" setting under Mandrake)
It describes it as completely closed and it looks pretty secured as far as file system security settings.
 
Old 09-21-2003, 10:28 PM   #14
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
I think I tried the max setup once on mdk8.0, it was annoyingly non-functional, kind of like a bad zonealarm setup. Let us know if there are any glitches...so how did promisc mode get turned on anyway?

by the way, for reference purposes, what driver is in use for the netgear wireless card?
 
Old 09-21-2003, 11:11 PM   #15
LGMike
LQ Newbie
 
Registered: Sep 2003
Location: USA
Distribution: Mandrake
Posts: 22

Original Poster
Rep: Reputation: 15
it's using orinoco_pci

I didn't turn promisc mode on, so I'm not sure how it got turned on
kwrited displayed a security audit when i logged in as root informing me it was on and that a sniffer was suspected on my system...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Network is unreachable" in Mandrake 10.1 Powerpack RAMMS+EIN Linux - Networking 2 05-10-2005 10:00 AM
SiS900 Ethernet Problem "Network is unreachable" mertos Linux - Networking 7 04-04-2005 09:01 AM
Getting message "connect: Network is unreachable" trying to access the Internet denver1980 Linux - Networking 5 12-29-2004 05:22 PM
"Destination Host Unreachable" on local network radupastia Linux - Networking 0 08-13-2003 09:46 AM
tftp - "Destination Unreachable" due to "Port Unreachable" renjithgopal Linux - Security 5 07-24-2003 10:36 AM


All times are GMT -5. The time now is 10:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration