LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-14-2004, 01:08 AM   #1
rehj
LQ Newbie
 
Registered: Oct 2004
Location: Daytona Beach, FL USA
Distribution: Fedora Core 6
Posts: 4

Rep: Reputation: 0
wheel mouse is acting screwy in xwindows under Slack-10


I'm having what seems to be an odd issue because I can't find anyone with the same.

I'm running Slackware 10, everything stock, I havn't upgraded any packages.

When I use my wheel on my mouse it just jumps the cursor halfway up the screen instad of scrolling.

I have tried 3 button emulation. I have tried adding the "ZAxisMapping" "4 5" to no avail.

When I boot the system with a Knoppix disc I have no problem with the mouse, but it is using a different version of x so the config file is different, I have tried every option in that any way, but that didn't help

The Mouse is a basic optical PS/2 mouse made by IBM

--------- /etc/X11/xorg.conf ---------
Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/mouse"

Option "Emulate3Buttons"
Option "Emulate3Timeout" "70"

------------------------------------------------------

Any assistance will be greatly appreciated.
 
Old 10-14-2004, 01:23 AM   #2
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
Hmm...try using "IMPS/2" protocol instead of PS/2. I'm not sure if it'll work though
 
Old 10-14-2004, 01:29 AM   #3
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,091

Rep: Reputation: 45
here's my mouse info in slack 10...give this a try...it should work for you...


# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"
 
Old 10-14-2004, 01:42 AM   #4
rehj
LQ Newbie
 
Registered: Oct 2004
Location: Daytona Beach, FL USA
Distribution: Fedora Core 6
Posts: 4

Original Poster
Rep: Reputation: 0
that was the problem using the IMPS/2 worked perfectly

Thanks guys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hmm...My mouse wheel is acting as a third button EOHooligan Linux - General 2 01-27-2005 03:42 AM
Some really screwy things with a PS2 mouse. vash_stewy Linux - Hardware 4 10-10-2004 05:29 PM
how to enable mouse wheel in slack 9.0? Alucard Belmont Slackware 5 10-15-2003 02:55 AM
How to enable wheel mouse in Slack 9.0? Harp00 Slackware 12 10-03-2003 08:59 AM
wheel mouse in slack 8.1 bass Slackware 7 11-22-2002 08:44 PM


All times are GMT -5. The time now is 04:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration