LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-27-2002, 12:25 PM   #1
bass
LQ Newbie
 
Registered: Apr 2002
Posts: 23

Rep: Reputation: 15
wheel mouse in slack 8.1


i tried to enable the wheel of my mouse. i found a
description going like this:
changing

Section "InputDevice"
Identifer "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/mouse"
EndSection

to

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "Buttons" "5"
Option "ZAxisMapping" "4" "5"
EndSection

i didn't change Mouse1 to Mouse0 because
i thought Mouse1 was the right value for
slackware. after a reboot kdm couldn`t start.
i read the kdm.log file and it said that value
5 in the ZAxisMapping line was a wrong value.
how can i get my wheelmouse working?
i have not installed gpm and imwheel. i heard
that gpm can cause problems and i want to install
imwheel afterwards.

bass
 
Old 09-27-2002, 03:22 PM   #2
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
Here is the relevant portion from my /etc/X11/XF86Config file:


Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Note that there is only a space between the 4 and 5.
Leave your Identifier to whatever it was previously (with a working X), or
change it in the ServerLayout section as well. . .

Probably the important part to change is "ZAxisMapping" "4 5".

Cheers,
Moses
 
Old 09-27-2002, 04:50 PM   #3
bass
LQ Newbie
 
Registered: Apr 2002
Posts: 23

Original Poster
Rep: Reputation: 15
i will give it a try! thanks!
 
Old 11-21-2002, 04:22 PM   #4
R0N1N
Member
 
Registered: Sep 2002
Location: United States
Distribution: Slackware 8.1, 9.0 / Debian 3.0
Posts: 44

Rep: Reputation: 15
Did that fix your problem with the mouse wheel?

The reason I ask is because Slackware is by far my favorite distro, but I have never been able to get the mouse wheel on my Intellimouse Optical USB to work with slackware 8.1.

I have had no trouble getting it to work with EVERY other distro I've used.

If you did get it to work, did you have to do anything other than modifying your XF86config file? I've done that and also tried every other protocol.
 
Old 11-21-2002, 11:20 PM   #5
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
R0N1N, I use a Logitech USB wheel mouse under slack 8.1 on my notebook, and the wheel works perfectly. It is currently configured as the second mouse because the touchpad is the first pointing device. That way both will work, or just the touchpad if USB mouse not present. My config follows.

# For Touchpad
Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/mouse"
Option "Resolution" "300"
EndSection

# For USB Wheel mouse
Section "InputDevice"
Identifier "Mouse2"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mouse0"
Option "Resolution" "300"
Option "ZAxisMapping" "4 5"
EndSection

I would think you only need to modify the Identifer to "Mouse1". If anybody else is interested for a second pointer device I also had to add the following line to the ServerLayout section after the first pointer is declared near the bottom of the config file.

InputDevice "Mouse2" "SendCoreEvents"

Now I will state also that I had to really play with the modules for it work right. So perhaps that might be an area you could investigate as well. The only load order that I could get to work was the following from my rc.local file. I would think that "insmod" would work instead of "modprobe" just as well.

#USB mouse modules (device - /dev/input/mouse0)
/sbin/modprobe input
/sbin/modprobe usbmouse
/sbin/modprobe hid
/sbin/modprobe mousedev

You can use "lsmod" to view the current modules loaded and the order. Top of the list is loaded last and the bottom is loaded first.

Cheers.
 
Old 11-22-2002, 06:17 AM   #6
bass
LQ Newbie
 
Registered: Apr 2002
Posts: 23

Original Poster
Rep: Reputation: 15
yes it works!

itīs quite a long time ago! my whell mouse works with nearly all apps (in spite of ghostview). it even works with mozilla without any problems. i can`t tell about optical mice and stuff like that. i`m using the standard logitech wheelmouse. but as you can see, my problems were caused by a typingerror in a linux mag. so never trust the experts ;-)(only kidding!)

good luck

bass
 
Old 11-22-2002, 04:24 PM   #7
R0N1N
Member
 
Registered: Sep 2002
Location: United States
Distribution: Slackware 8.1, 9.0 / Debian 3.0
Posts: 44

Rep: Reputation: 15
Quote:
I would think you only need to modify the Identifer to "Mouse1". If anybody else is interested for a second pointer device I also had to add the following line to the ServerLayout section after the first pointer is declared near the bottom of the config file.
Thanks, I'll check that out tonight for sure. Maybe I'm not loading a certain module or in a different order. I didn't think that would be a problem, since the mouse was working great otherwise.

I also don't think I have this line :

(InputDevice "Mouse1" "SendCoreEvents")
 
Old 11-22-2002, 08:44 PM   #8
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Your FIRST pointer device should use CorePointer as in:

InputDevice "Mouse1" "CorePointer"

It is only the SECOND pointer device (Mouse2) that uses SendCoreEvents. From my config example, use the Mouse2 section (that is USB) but modify the identifier to Mouse1.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PS2 wheel mouse/wheel not working jayhel Linux - Hardware 2 06-18-2006 07:54 PM
4d wheel mouse - scroll wheel no worky CamelofCamelot Linux - Hardware 1 10-28-2004 09:33 PM
wheel mouse is acting screwy in xwindows under Slack-10 rehj Linux - Newbie 3 10-14-2004 01:42 AM
how to enable mouse wheel in slack 9.0? Alucard Belmont Slackware 5 10-15-2003 02:55 AM
How to enable wheel mouse in Slack 9.0? Harp00 Slackware 12 10-03-2003 08:59 AM


All times are GMT -5. The time now is 12:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration