LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 01-07-2006, 08:16 PM   #1
badgerbox76
Member
 
Registered: Dec 2005
Location: USA
Distribution: Ubuntu, and other Live-CDs
Posts: 156

Rep: Reputation: 30
Unhappy Video Card Nvidia Driver Xlib: extension "GLX" missing on display ":0.0". HELP!


I just downloaded americas army and wanted to install my video card driver becasue when i ran the glxinfo commmand i found the rendering was off so i followed the instructions from this site http://ubuntuguide.org/#installnvidiadriver and when i rebooted my box and ran the command this is what i got. what should i do?

glxinfo | grep direct
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
 
Old 01-07-2006, 08:41 PM   #2
Keruskerfuerst
Member
 
Registered: Oct 2005
Location: Lat: 482356N, Lon: 104145E
Distribution: Gentoo 2006
Posts: 719

Rep: Reputation: 31
The video driver is not installed properly.
 
Old 01-07-2006, 09:29 PM   #3
badgerbox76
Member
 
Registered: Dec 2005
Location: USA
Distribution: Ubuntu, and other Live-CDs
Posts: 156

Original Poster
Rep: Reputation: 30
So how can i fix this problem? is there a howto or guide i could use and do i have to uninstall the driver before reinstalling it and if that is the case how do i uninstall the driver. Thanks
 
Old 01-08-2006, 05:46 AM   #4
Flesym
Member
 
Registered: Aug 2005
Location: Germany
Distribution: Ubuntu, Debian
Posts: 189

Rep: Reputation: 31
Try to install the driver from nVidia's binary, that you will find on here:
http://www.nvidia.com/object/linux_d..._1.0-8178.html
Read and follow their detailed README! Maybe you need to remove your current installed nvidia and glx stuff by hand before, but often this isn't necessary at all.

Note: You need the linux-headers of your kernel. If you use Ubuntu, then you have to run the binary within run-level 1! To get there type:

sudo telinit 1

to get back:

sudo telinit 2

Good luck!
-flesym
 
Old 01-08-2006, 11:56 AM   #5
badgerbox76
Member
 
Registered: Dec 2005
Location: USA
Distribution: Ubuntu, and other Live-CDs
Posts: 156

Original Poster
Rep: Reputation: 30
ok i run the command telinit 1 as root and when the command it finished it tells me that i have to push ctrl-D and then it starts the services back up again, what am i doing wrong?

Added: i also cant find XF86Config on mu system why would this be.

here is some more information about my system:

nos@ubuntu:~$ lspci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia] (rev 05)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia AGP]
0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1a)
0000:00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1a)
0000:00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
0000:00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 50)
0000:00:08.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)
0000:00:09.0 Communication controller: Conexant: Unknown device 2f14 (rev 01)
0000:00:0a.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
0000:00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
nos@ubuntu:~$

xorg.conf file

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/CID"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
Driver "nv"
BusID "PCI:0:8:0"
EndSection

Section "Monitor"
Identifier "DELL D1025TM"
Option "DPMS"
HorizSync 30-85
VertRefresh 50-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
Monitor "DELL D1025TM"
DefaultDepth 24
Option "IgnoreEDID" "1"
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

Last edited by badgerbox76; 01-08-2006 at 12:29 PM.
 
Old 01-08-2006, 12:23 PM   #6
Flesym
Member
 
Registered: Aug 2005
Location: Germany
Distribution: Ubuntu, Debian
Posts: 189

Rep: Reputation: 31
This is strange... Do not press ctrl-D (indeed, this will bring you back). Try pressing 'Enter' or ctrl-C to get a command-line. If this does not work, you may also install the driver in the Recovery Mode of Ubuntu.

Btw: I don't know your linux skills so here one little note, that might be helpful, if the driver won't install properly, so that X won't start. In this case you have to open the file '/etc/X11/xorg.conf' (with 'vi', 'nano' or so...) and set "Driver" in section "Device" (of your Video card) from "nvidia" to "nv" or "vesa". You won't have 3D-Acceleration but your system will run stable, so you can come back and post your problem ;-)
 
Old 01-08-2006, 12:40 PM   #7
Flesym
Member
 
Registered: Aug 2005
Location: Germany
Distribution: Ubuntu, Debian
Posts: 189

Rep: Reputation: 31
Oh wait! Now I see your xorg.conf this is wrong configured. Change the following:

Disable both in the "Module"-section:
Load "GLcore"
Load "dri"

Change in "Device"-section of your video card:
Driver "nv"
to
Driver "nvidia"

And add to the same section:
Option "RenderAccel" "true"
 
Old 01-08-2006, 12:40 PM   #8
badgerbox76
Member
 
Registered: Dec 2005
Location: USA
Distribution: Ubuntu, and other Live-CDs
Posts: 156

Original Poster
Rep: Reputation: 30
ok let me try that real quick
 
Old 01-08-2006, 01:04 PM   #9
badgerbox76
Member
 
Registered: Dec 2005
Location: USA
Distribution: Ubuntu, and other Live-CDs
Posts: 156

Original Poster
Rep: Reputation: 30
after i edited the file and restated the system x refused to stat and i got an error saying it was not configured properly so i had to use my backup xorg.conf file to get the system to boot x. so what should i do now?
 
Old 01-08-2006, 01:07 PM   #10
Flesym
Member
 
Registered: Aug 2005
Location: Germany
Distribution: Ubuntu, Debian
Posts: 189

Rep: Reputation: 31
Try install the binary as discribed before.
 
Old 01-08-2006, 01:09 PM   #11
badgerbox76
Member
 
Registered: Dec 2005
Location: USA
Distribution: Ubuntu, and other Live-CDs
Posts: 156

Original Poster
Rep: Reputation: 30
when i have tryed that it tells me that it cant find that kernal tree or some thing, so how would i fix that?
 
Old 01-08-2006, 01:18 PM   #12
Flesym
Member
 
Registered: Aug 2005
Location: Germany
Distribution: Ubuntu, Debian
Posts: 189

Rep: Reputation: 31
Do you have the headers installed? -If so and it doesn't find the kernel tree then indicate the install path explicite with then parameter:
--kernel-install-path
(type 'NVIDIA-Linux-x86-1.0-8178-pkg1.run -A' to get more information)

I.e. run:
./NVIDIA-Linux-x86-1.0-8178-pkg1.run --kernel-install-path=/usr/src/linux-headers-2.6.12-10-386/
 
Old 01-08-2006, 01:20 PM   #13
Flesym
Member
 
Registered: Aug 2005
Location: Germany
Distribution: Ubuntu, Debian
Posts: 189

Rep: Reputation: 31
Oh, you will also need gcc-3.4 not gcc-4.0! So do:
sudo apt-get gcc-3.4
before installing. You may also need some other packages, but the installer will tell you if so.
 
Old 01-08-2006, 01:22 PM   #14
badgerbox76
Member
 
Registered: Dec 2005
Location: USA
Distribution: Ubuntu, and other Live-CDs
Posts: 156

Original Poster
Rep: Reputation: 30
I have already added gcc 4.0 and 3.4 useing the package mangager in my system but nvidia does not see it.

nos@ubuntu:~$ gcc
gcc: no input files


nos@ubuntu:~$ sudo apt-get gcc-3.4
Password:
E: Invalid operation gcc-3.4
 
Old 01-08-2006, 01:25 PM   #15
Flesym
Member
 
Registered: Aug 2005
Location: Germany
Distribution: Ubuntu, Debian
Posts: 189

Rep: Reputation: 31
Ups, my fault. Of course:
sudo apt-get install gcc-3.4
;-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xlib: extension "GLX" missing on display ":0.0". jrk5050 Linux - Hardware 5 05-08-2008 11:19 PM
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 03:07 PM
Video Card Nvidia Driver Xlib: extension "GLX" missing on display ":0.0". badgerbox76 Linux - Games 13 01-11-2006 04:47 PM
Xlib: extension "GLX" missing on display ":0.0". tekmorph Linux - Hardware 1 12-05-2004 01:52 AM
Xlib: extension "GLX" missing on display ":0.0" Evohack Linux - Software 18 10-23-2003 10:10 PM


All times are GMT -5. The time now is 02:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration