LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-03-2003, 02:27 AM   #1
Evohack
LQ Newbie
 
Registered: Aug 2003
Posts: 15

Rep: Reputation: 0
Xlib: extension "GLX" missing on display ":0.0"


When I try to exec my Neverwinter Nights game I get this error.

Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error

I have already checked the XFree config and it has the load "glx" line.

Any ideas or suggestions would be helpfull.
 
Old 08-03-2003, 07:20 AM   #2
zero_copy
Member
 
Registered: Aug 2003
Location: CT
Distribution: Slackware
Posts: 45

Rep: Reputation: 15
what video card do u have....hopefully an NVIDIA witht here drivers installed... cause those are the only ones i ahve experience with....

make sure you ahve nvidia's drivers...you can get them from there site.

if its an nvidia and you have there drivers go to a prompt and type 'lsmod' to make sure the nvidia.o is loaded.

when u start X flip back to the terminal that u started X from so u can read the console output. if the GLX module is loading right, you should see a line that says it was loaded, if not there is a problem with the XF86Config file or your drivers.

in the XF86Config file make sure that GLX is uncommented and 'dri' is commented out.

hope that helps
 
Old 08-03-2003, 08:08 AM   #3
Devboy
Member
 
Registered: Jul 2003
Location: IOM
Distribution: Slackware 10.
Posts: 194

Rep: Reputation: 30
if its a nvidia card then:

If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore




have you done that?
 
Old 08-03-2003, 01:40 PM   #4
Evohack
LQ Newbie
 
Registered: Aug 2003
Posts: 15

Original Poster
Rep: Reputation: 0
Yes I have a NVIDIA GeForce 4 card. I already downloaded t he drivers and installed them.
 
Old 08-03-2003, 01:48 PM   #5
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
Heh, I had same prob for 7 months!! No 3D acceleration, I was irked for the longest time.........in your XF86config file type this in the Screens Section
Option "IgnoreEDID" "1"
here's what mine looks like........
Code:
# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
    Identifier  "Screen 1"
    Device      "NVIDIA GeForce"
    Monitor     "Gateway EV 700"
    DefaultDepth 24
    Option "IgnoreEDID" "1"
    
    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes        "1152x864" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection
 
Old 08-03-2003, 01:56 PM   #6
Evohack
LQ Newbie
 
Registered: Aug 2003
Posts: 15

Original Poster
Rep: Reputation: 0
Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 MX (generic)"
VideoRam 65536
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

I checked and yes dri is loaded. I'm not sure what to do everyone is telling me different things.
 
Old 08-03-2003, 02:05 PM   #7
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 58
ok first....your driver is "nv" so no you are not using nvidias drivers, so thats where you have to start evohack...there is a sticky thread in the general fourm on how to go about getting the nvidia drivers and installing them...
as of "320mb" what does IgnoreEDID have to do with 3d acceleration, the EDID (Extended Display Identification Data) is for the monitor, and the other thing is, is if you have installed the nvidia drivers and they are working then you will have 3d acceleration, not ifs ands or buts about it.
 
Old 08-03-2003, 02:09 PM   #8
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 58
oh and you dont' want dri loaded nor glcore, as you will see in that sticky thread in the newbie fourm(i said general in my last post, that was my bad )...you are going to be removing these options from your config when your setting up the nvidia drivers.

actually here is the thread MasterC lays it out in a step by step manner..
 
Old 08-03-2003, 02:11 PM   #9
Evohack
LQ Newbie
 
Registered: Aug 2003
Posts: 15

Original Poster
Rep: Reputation: 0
We'll I already installed the NVIDIA driver. I exited out of X and all that. So I don't know why it's not showing I did.
 
Old 08-03-2003, 02:27 PM   #10
Evohack
LQ Newbie
 
Registered: Aug 2003
Posts: 15

Original Poster
Rep: Reputation: 0
Just delete "load "glx""? I don't have GLcore so I guess I'm good there.
 
Old 08-03-2003, 02:32 PM   #11
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 58
d00d, your config says:
----->>> DRIVER "NV" <<<-------
if you were using the nvidia drivers it would say:
----->>> DRIVER "NVIDIA" <<<------
and in the --> Section "Module" <-- in your XF86Config file :
YOU SHOULD NOT HAVE:
Load "glcore"
Load "dri"
AND YOU SHOULD HAVE:
Load "glx"
....and whatever else i didn't mention should also be there.
 
Old 08-03-2003, 02:37 PM   #12
Evohack
LQ Newbie
 
Registered: Aug 2003
Posts: 15

Original Poster
Rep: Reputation: 0
Here's my config


# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "ViewSonic A75f"
DisplaySize 330 240
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 MX (generic)"
VideoRam 65536
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


I guess I should just try to install the driver again.
 
Old 08-03-2003, 04:09 PM   #13
Evohack
LQ Newbie
 
Registered: Aug 2003
Posts: 15

Original Poster
Rep: Reputation: 0
Okay I just finished installing the driver again, but with the same results that it doesn't show up config file.

Here's what I did to install it

ctrl+alt+f2
login as root
cd to file directory
sh NVIDIA-Linux-x86-1.0-4496-pkg2.run
Reboot
 
Old 08-03-2003, 04:39 PM   #14
Mega Man X
Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 63
Oh my god. Read carefully what DrOzz is saying...:

----->>> DRIVER "NV" <<<-------
if you were using the nvidia drivers it would say:
----->>> DRIVER "NVIDIA" <<<------
and in the --> Section "Module" <-- in your XF86Config file :
YOU SHOULD NOT HAVE:
Load "glcore"
Load "dri"
AND YOU SHOULD HAVE:
Load "glx"
....and whatever else i didn't mention should also be there.

If you don't switch driver nv to nvidia, you can keep installing as much as you want It won't use Nivida drivers...
 
Old 08-03-2003, 04:43 PM   #15
Devboy
Member
 
Registered: Jul 2003
Location: IOM
Distribution: Slackware 10.
Posts: 194

Rep: Reputation: 30
if you had just followed my post you would have been okay.

if its a nvidia card then:

If you already have an XF86Config file working with a different driver
(such as the 'nv' or 'vesa' driver), then all you need to do is find
the relevant Device section and replace the line:

Driver "nv"
(or Driver "vesa")

with

Driver "nvidia"

In the Module section, make sure you have:

Load "glx"

You should also remove the following lines:

Load "dri"
Load "GLcore




have you done that?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xlib: extension "GLX" missing on display ":0.0". jrk5050 Linux - Hardware 5 05-08-2008 11:19 PM
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 03:07 PM
Xlib: extension "XFree86-DRI" missing on display ":0.0". fostiator Linux - Hardware 15 02-20-2005 07:13 AM
Xlib: extension "GLX" missing on display ":0.0". tekmorph Linux - Hardware 1 12-05-2004 01:52 AM
bash-2.05b# Xlib: extension "XFree86-DRI" missing on display ":0.0". citrus Linux - General 8 02-22-2004 10:43 AM


All times are GMT -5. The time now is 08:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration