LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-31-2015, 01:47 PM   #1
dilettante9
Member
 
Registered: Jun 2012
Location: U.S.
Distribution: Debian, Xubuntu
Posts: 46

Rep: Reputation: Disabled
Unwanted Recovery Mode option when rebooting


In Mint Cinnamon 17.1, every time I reboot, I get an option in GRUB to boot into recovery mode. I have to then manually select normal (not recovery mode) booting, after which I get to the regular Cinnamon desktop. This started happening after the computer froze one time and I had to power it off, but it happens every time I reboot now. Bottom line: on reboot, I need to go through an extra, unnecessary step of selecting normal, rather than recovery, mode. Does anyone know how to get rid of this recovery mode option in GRUB?
 
Old 05-31-2015, 02:10 PM   #2
ugjka
Member
 
Registered: May 2015
Location: Latvia
Distribution: Arch, CentOS, ChakraOS
Posts: 275
Blog Entries: 5

Rep: Reputation: 214Reputation: 214Reputation: 214
Grub should remember which entry you select across reboots. In your case it doesn't save it anymore.

Do you have the following in /etc/default/grub:

Code:
GRUB_DEFAULT=saved
GRUB_SAVEDEFAULT=true
 
Old 05-31-2015, 02:34 PM   #3
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 7,278

Rep: Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380Reputation: 1380
The entry in grub2 which is booted is the one show in the /etc/default/grub file on the first line:

Quote:
GRUB_DEFAULT=0
The entry above would boot the first "menuentry" line in the grub.cfg file. I don't know why that would have changed to the recovery option. Simply count down the menuentry lines to the one you want and put that number in the /etc/default/grub file. Count starts at zero not one, and run update-grub after making the change.
 
Old 05-31-2015, 02:57 PM   #4
dilettante9
Member
 
Registered: Jun 2012
Location: U.S.
Distribution: Debian, Xubuntu
Posts: 46

Original Poster
Rep: Reputation: Disabled
Thanks for the responses, guys! However, I think maybe I didn't explain my problem well. Normal (not recovery) is the first boot option listed in Grub. The problem is that the boot process stops at the Grub screen and makes me manually select (by pressing enter) the first option, which is normal boot mode. Of course, what it should do is boot directly into normal boot mode and bring up the Cinnamon desktop and graphical login screen.

(Incidentally, I did check and confirm that GRUB_DEFAULT is set to 0, which is the normal, not recovery, menuentry in grub.cfg.)

Any thoughts?
 
Old 05-31-2015, 03:09 PM   #5
dilettante9
Member
 
Registered: Jun 2012
Location: U.S.
Distribution: Debian, Xubuntu
Posts: 46

Original Poster
Rep: Reputation: Disabled
Never mind! It has just now inexplicably stopped doing it, and is now booting directly to the graphical login screen and doesn't stop at the Grub boot menu any more. Not sure why, but it's all good. Thanks for your responses.
 
Old 05-31-2015, 03:16 PM   #6
ugjka
Member
 
Registered: May 2015
Location: Latvia
Distribution: Arch, CentOS, ChakraOS
Posts: 275
Blog Entries: 5

Rep: Reputation: 214Reputation: 214Reputation: 214
I reccomend that you run fsck on your hardrives and memtest on your ram. You could have some faulty sectors on your filesystem causing some corruptions
 
Old 05-31-2015, 03:17 PM   #7
dilettante9
Member
 
Registered: Jun 2012
Location: U.S.
Distribution: Debian, Xubuntu
Posts: 46

Original Poster
Rep: Reputation: Disabled
Thanks for the suggestion, Ugika. I'll do that. Don't want it to break.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
boot from harddisk option is not available after rebooting suse swapnil5752 SUSE / openSUSE 6 05-06-2014 08:07 AM
Unwanted Option at Bootup ceil210 Linux - General 6 03-25-2013 09:20 AM
Ubuntu - single user mode. How can it be done, without rebooting the computer? pr_deltoid Ubuntu 8 08-07-2010 07:51 PM
How do I get into Recovery mode without rebooting? jacatone Linux - Newbie 3 03-31-2008 12:32 PM
how to specify to lilo a boot option before rebooting entropyv Linux - Software 2 08-21-2005 01:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration