LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-24-2009, 05:17 PM   #1
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7
Posts: 872

Rep: Reputation: 112Reputation: 112
Trying to configure grub


Okay on /dev/sda
sda1 is windows xp
sda2 slackware /boot /system files
sda3 slackware swap
sda5 Centos LVM

Now my question is when I install CentOS grub did not automaticly setup the slackware partition and I have to configure it manually.

And I am a little lost.

This is my grub.conf file

Quote:
[root@centos ~]# cat /boot/grub/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,4)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol01
# initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,4)/grub/splash.xpm.gz
hiddenmenu
title CentOS (2.6.18-92.el5)
root (hd0,4)
kernel /vmlinuz-2.6.18-92.el5 ro root=/dev/VolGroup00/LogVol01 rhgb quiet
initrd /initrd-2.6.18-92.el5.img
title Slackware
root (hd0,1)
kernel /vmlinuz-generic-2.6.29.6
title Other
rootnoverify (hd0,0)
chainloader +1
How should I do the slackware in grub?

Thanks for the help

Last edited by jmc1987; 10-24-2009 at 05:25 PM.
 
Old 10-24-2009, 05:38 PM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
So Slackware /boot is on sda2 (To grub, this is (hd0,1))

Suppose that the kernel image is named "vmlinuz", and the initrd image is named "initrd" **.

the grub menu.lst entry will be:

title Slackware
root (hd0,1)
kernel /boot/vmlinuz root=/dev/sda2 ro
initrd /boot/initrd

**I always set up soft links in /boot so that these exact names can be used in the config files. This way, I never have to keep track of the exact file names.
 
Old 10-24-2009, 06:15 PM   #3
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7
Posts: 872

Original Poster
Rep: Reputation: 112Reputation: 112
Okay I tried what you said

Quote:
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,4)/grub/splash.xpm.gz
hiddenmenu
title CentOS (2.6.18-92.el5)
root (hd0,4)
kernel /vmlinuz-2.6.18-92.el5 ro root=/dev/VolGroup00/LogVol01 rhgb quiet
initrd /initrd-2.6.18-92.el5.img
title Slackware
root (hd0,1)
kernel /boot/vmlinuz root=/dev/sda2 ro
initrd /boot/initrd
title Windows
rootnoverify (hd0,0)
chainloader +1
but is says file not found when I try to boot.

Any ideas?

Just to verify that slackware is on /dev/sda2 I mounted it and check the files and it is there.
 
Old 10-24-2009, 07:05 PM   #4
sysfce2
Member
 
Registered: Jul 2009
Distribution: Slackware
Posts: 96

Rep: Reputation: 39
What do you get when you enter 'find /boot/vmlinuz' at the GRUB prompt?
 
Old 10-24-2009, 07:13 PM   #5
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7
Posts: 872

Original Poster
Rep: Reputation: 112Reputation: 112
file not found
 
Old 10-24-2009, 07:26 PM   #6
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,900

Rep: Reputation: 261Reputation: 261Reputation: 261
for your grub kernel entry use the following:
kernel /boot/vmlinuz root=/dev/hda2 ro
or

kernel /boot/vmlinuz root=/dev/sda2 ro

if neither one works then there is good chance centos grub will not boot a slackware partition.
take your slackware install disk and install lilo to the root partition of slackware, then make the following entry in your grub
rootnoverify (hd0,1)
chainloader +1
 
Old 10-24-2009, 07:40 PM   #7
sysfce2
Member
 
Registered: Jul 2009
Distribution: Slackware
Posts: 96

Rep: Reputation: 39
Did you make a separate boot partition?
Your kernel may be /vmlinuz

Does 'find /vmlinuz' (at GRUB prompt again) find your slackware partition (hd0,1)?

EDIT: I guess also that your kernel could be named something else. Check that there is a vmlinuz in /boot.

Last edited by sysfce2; 10-24-2009 at 07:43 PM.
 
Old 10-24-2009, 07:55 PM   #8
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7
Posts: 872

Original Poster
Rep: Reputation: 112Reputation: 112
in my slackware boot I have

boot_message.txt
config
config-generic-2.6.29.6
config-generic-smp-2.6.29.6-smp
config-huge-2.6.29.6
config-huge-smp-2.6.29.6-smp
diag1.img
README-.initrd
slack.bmp
System.map
System.map-generic-2.6.29.6
System.map-generic-smp-2.6.29.6-smp
System.map-hug-2.6.29.6
System.map-hug-smp-2.6.29.6-smp
vmlinuz
vmlinuz-generic-2.6.29.6
vmlinuz-generic-smp-2.6.29.6-smp
vmlinuz-huge-2.6.29.6
vmlinuz-huge-smp-2.6.29.6-smp

This is everything in my /boot file
 
Old 10-24-2009, 08:14 PM   #9
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,900

Rep: Reputation: 261Reputation: 261Reputation: 261
to install lilo go back into setup with the slackware install disk select the partition you installed to again, but do not format. get back to the main menu select configure system select no or cancel untill you get to the lilo setup. select simple, install to root partion. after installing lilo select cancel and no to all other prompts untill you get back to the main screen reboot. add the chainloading entry to grub.
 
Old 10-24-2009, 08:15 PM   #10
sysfce2
Member
 
Registered: Jul 2009
Distribution: Slackware
Posts: 96

Rep: Reputation: 39
That's kind of weird then that GRUB couldn't find it.
What file system is being used?

The file not found could be coming from the ram disk though - I don't see initrd in your listing - try removing that line from grub.conf.

Another option could be to copy the kernel to the CentOS boot folder and then using:

root (hd0,4)
kernel /boot/vmlinuz root=/dev/sda2 ro
 
Old 10-24-2009, 08:18 PM   #11
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,900

Rep: Reputation: 261Reputation: 261Reputation: 261
sysfce2 idea will work too, never thought about doing that.
 
Old 10-24-2009, 08:31 PM   #12
jmc1987
Member
 
Registered: Sep 2009
Location: Oklahoma
Distribution: Debian, CentOS, windows 7
Posts: 872

Original Poster
Rep: Reputation: 112Reputation: 112
Quote:
Originally Posted by colorpurple21859 View Post
to install lilo go back into setup with the slackware install disk select the partition you installed to again, but do not format. get back to the main menu select configure system select no or cancel untill you get to the lilo setup. select simple, install to root partion. after installing lilo select cancel and no to all other prompts untill you get back to the main screen reboot. add the chainloading entry to grub.

I am not trying to use lilo I am trying to use grub.

File system I selected when I installed slackware was ext3
 
Old 10-24-2009, 08:57 PM   #13
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,900

Rep: Reputation: 261Reputation: 261Reputation: 261
I know your not using lilo. I was in the middle of typing when sysfce2 had posted. most grubs from other distos will not boot a slackware formatted partition, I was telling you one way to get slackware to boot from centos grub because I also use a grub that will not boot a slackware partition, however sysfce2 way will work too, and is an easier way. if you have ide harddrive use /dev/hda2, sata then /dev/sda2. will need to copy vmlinuz-huge-smp-2.6.29.6-smp to centos boot directory and use it in your kernel line of grub, vmlinuz is a link to it

Last edited by colorpurple21859; 10-24-2009 at 09:06 PM. Reason: more info
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure GRUB don_wombat_73 Linux - Newbie 6 08-01-2008 08:57 AM
how 2 configure grub ? crazyjedi Linux - Newbie 2 05-14-2006 05:09 PM
Grub configure? harzfled Linux - Newbie 6 03-03-2005 09:21 AM
grub configure achal Linux - Newbie 16 02-25-2005 12:09 AM
configure grub : NL-Stitch Linux - Newbie 4 08-01-2004 03:40 PM


All times are GMT -5. The time now is 08:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration