LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-12-2002, 11:47 PM   #1
Waldo X
LQ Newbie
 
Registered: Feb 2002
Location: Portland OR
Distribution: Slackware
Posts: 5

Rep: Reputation: 0
Trouble loading joystick modules: Device or resource busy


Ok, here's the setup.

Slackware 8
Kernel 2.2.19
Sound Blaster Live Value
Microsoft Sidewinder Gamepad

I have no problems loading emu10k1-joy and joystick, but when I try to load joy-sidewinder (or any other joystick module) I get this error:

Using /lib/modules/2.2.19/misc/joy-sidewinder.o.gz
/lib/modules/2.2.19/misc/joy-sidewinder.o.gz: init_module: Device or resource busy
/lib/modules/2.2.19/misc/joy-sidewinder.o.gz: Hint: insmod errors can be caused
by incorrect module parameters, including invalid IO or IRQ parameters

I suppose I may need to pass on some parameters when I load emu10k1-joy or joystick, but I can't figure out what they are. I've searched deja, the web and many other newsgroups, but can't find an anwser to what shoud be a simple problem.

Since this seems to be one of the more active linux boards on the net, I'm hoping someone here has got a working soundblaster joystick port and can offer me some advice.

Any help would be greatly appeciated.

Thanks.
 
Old 02-13-2002, 10:29 PM   #2
Waldo X
LQ Newbie
 
Registered: Feb 2002
Location: Portland OR
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
Awww, c'mon! Somebody has to know! Tell ya what, if you can give me the answer to this, I'll give you a cookie! You like cookies don't you?
 
Old 02-13-2002, 11:45 PM   #3
Waldo X
LQ Newbie
 
Registered: Feb 2002
Location: Portland OR
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
Problem Solved.

I finally found the answer on deja. I just needed to add io=0x200 when I insmod'd emu10k1-joy.

Like so: insmod emu10k1-joy io=0x200

Woo hoo! Now I can play my roms!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Device or Resource Busy ..by what xrado Linux - General 1 04-23-2005 07:05 AM
Device or resource busy mikedurant Linux - Newbie 4 03-29-2005 08:52 PM
Device or Resource Busy deepfrybonanza Linux - Wireless Networking 1 02-18-2005 04:27 PM
Device or resource busy teeno Linux - Newbie 3 03-09-2004 11:12 AM
Trouble loading joystick modules: Device or resourse busy. Waldo X Linux - General 1 02-13-2002 12:22 AM


All times are GMT -5. The time now is 01:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration