Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-17-2004, 07:35 PM   #1
LQ Newbie
Registered: Mar 2004
Posts: 2

Rep: Reputation: 0
Device or resource busy

I just got a new system, which I am dual booting WinXPPro and Linux
(Fedora), but can't seem to access the Ethernet NIC. eth0 fail at startup, with this message "SIOCSIFFLAGS: Resource or Device Busy".
Doing an ifup <device> generates the same message. Both cards seem to be working under XP. Are there some good tricks, tips, or tools for diagnosing the probelms?

| Determining IP information for eth0...
| SIOCSIFFLAGS: Device or resource busy
Old 03-17-2004, 08:51 PM   #2
LQ Newbie
Registered: Mar 2004
Posts: 2

Original Poster
Rep: Reputation: 0
anyone knows anything about this error ?

pls hlp.
Old 03-18-2004, 02:04 AM   #3
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Use the search, mate ...

No, I didn't read those threads, but then I don't
have that problem, either .... anyway, there's 29
threads besides yours that come up as a result
searching for the following words:
SIOCSIFFLAGS: Device or resource busy

Old 11-04-2004, 07:47 AM   #4
LQ Newbie
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
SIOCSIFFLAGS: Device or resource busy

I'm not sure if you found the answer or not, but turn off the Plug and Play OS in your bios. That should reslove the issues you may have.
Old 03-29-2005, 07:52 PM   #5
Registered: Feb 2005
Location: US
Distribution: Slackware
Posts: 30

Rep: Reputation: 15
I'm getting the exact same error on a box I just set up to use slackware,
turned off the plug and play OS setting in my bios, but I still get the error
any other suggestions?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to fix Device or Resource Busy!?!? Micah Linux - General 2 06-24-2005 02:21 PM
Device or Resource Busy what xrado Linux - General 1 04-23-2005 06:05 AM
Device or Resource Busy deepfrybonanza Linux - Wireless Networking 1 02-18-2005 03:27 PM
Device or resource busy teeno Linux - Newbie 3 03-09-2004 10:12 AM
emu10k1.o: Device or resource busy mrlucio79 Linux - Hardware 2 06-18-2003 07:31 PM

All times are GMT -5. The time now is 11:17 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration