LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-08-2006, 05:21 PM   #1
siq
LQ Newbie
 
Registered: May 2006
Distribution: SUSE Linux 10.0
Posts: 13

Rep: Reputation: 0
Suse Linux 10.0 Display Problems


hi everyone! ok this is really getting on my nerves...

Im new to the whole linux world so i expected problems but not dead ends!!

I installed SUSE Linux 10.0 64-bit edition. It showed me the GUI install and that went fine. It installed and at the very end it gave me a hearty Congrats on Linux ..

so i reboot and it shows "Out of Range" on the monitor and every so often it decrements the Hz. So after 6 or 10 installs (i lost count!), at the end of the install i would run yast2 to configure my monitor and vcard. (it autodetected everything properly). Here i tried all the settings: different resolutions, different sync ranges, and other stuff. NOTHING works. I would test and it would say "Sucessful" on the terminal then say "OUT OF RANGE" on my monitor. I have to hit ctrl+alt+backspace to kill it.

Can someone plzzzzz help me!!! i dont wanna turn my back on linux cuz windows is getting boring now ..but if this problem doesnt get solved then i shall shun linux forever ..lol
 
Old 05-09-2006, 05:12 AM   #2
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 393

Rep: Reputation: 47
In your /etc/X11/xorg.conf change the video driver to vesa and restart the x session. That should get you a graphical interface from which you can work. From there you can try to set up the correct driver.
 
Old 05-09-2006, 08:25 AM   #3
Spudley
Member
 
Registered: Mar 2003
Location: Berkshire, England.
Distribution: SuSE 10.0
Posts: 299

Rep: Reputation: 32
It sounds like Yast has been given the wrong settings for your monitor in its list of pre-sets. Which is a shame. (It may be that your monitor manufacturer used the same model number for more than one actual model).

In any case, you need to get to a command prompt, so you can work with it; ctrl+alt+backspace should get your there, or booting in recovery mode (or you could go just through the install process again).

Make sure you're logged in as root, type "yast2", and start playing.

Once you're in Yast, if you've got the technical specs for your monitor, you could compare them to what Yast says they should be. If you don't have them, try narrowing the range that Yast gives. Either way, Yast allows you to test your config before committing any changes, so make sure the settings you pick work.

If all else fails, try a lower resolution, or even a VESA mode (you won't get any decent resolutions with VESA, but you should be at least guaranteed to get something)

Also, what monitor is it? Tell us the model number; you never know -- someone may be a able to help you out with it specifically.

Hope that helps
 
Old 05-09-2006, 05:21 PM   #4
siq
LQ Newbie
 
Registered: May 2006
Distribution: SUSE Linux 10.0
Posts: 13

Original Poster
Rep: Reputation: 0
still with the gui problems ....

Hi guys ..thanks for the suggestions!! but sadly to say it still hasnt worked!!

My monitor is an LG Flatron L1750S (in yast it says its from GSM??) and my vcard is ATI Radeon X600 (im told a lot of ppl are having troubles with this card). But anyways i tried fiddling with xorg.conf. A friend of mine told me to use xorgcfg ..that didnt work...so i used xorgconfig and i answered all the questions just fine and it still doesnt work (typing >startx).

i tried this in my xorg.conf file:

Section "Device"
BoardName "Radeon X600 (RV370) 5B62 (PCIE)"
BusID "1:0:0"
Driver "ati"
EndSection

and in the monitor section the DisplaySize i put to 340 270 (from LG site) HorizSync is 31-83 and VertRefresh is 50-70

i "startx" and it says "No devices found" ... any ideas ?? thanks!!
 
Old 05-09-2006, 06:00 PM   #5
Spudley
Member
 
Registered: Mar 2003
Location: Berkshire, England.
Distribution: SuSE 10.0
Posts: 299

Rep: Reputation: 32
Okay, I don't know your monitor, but I've done a bit of hunting for you with Google. Not an easy thing to find info on, but searching for "L1750S suse" gave me this page (ironically, on the Ubuntu forums).

The page in question is a long discussion about monitor configuration in general, but if you search the page for L1750S, you'll find a bit of info from someone who's previously tried to get it working.

From the sound of it, it isn't the easiest monitor to get working, but it sounds like it can be done.

Hopefully that page will give you enough info to get you going.

All the best.
 
Old 05-10-2006, 01:52 AM   #6
siq
LQ Newbie
 
Registered: May 2006
Distribution: SUSE Linux 10.0
Posts: 13

Original Poster
Rep: Reputation: 0
Finally Got It Working!!

WOW!! I finally got it working!! KDE is very beautiful i must say! *whisper* better than windows!

Thank you very much Spudley as ur suggestions and link helped me to a SUCCESSFUL solution!

For anybody out there reading this and having the same problems, read what i did...

PROBLEM: After installing SUSE Linux 10.0 successfully, GUI is not displayed when Linux first boots up.

SYMPTOMS: Monitor flashes "OUT OF RANGE" (incorrect refresh rates), or possibly just blank (black) screen.

MY CONFIGURATION:
Monitor: LG Flatron L1750S
V-Card: ATI Radeon X600

SOLUTION:
1. Get into linux in the command prompt mode as ROOT
2. Get into the directory /usr/X11/bin and run the command xorgconfig (xorgcfg wont work cuz at this point you have no display!! so its pointless to use that)
3. What this TEXT-BASED program will do is ask you a bunch of questions about ur mouse, monitor, keyboard, and vcard. At the end of it, it will write your /etc/X11/xorg.conf file (the file that has ur display setups)
4. Go to /etc/X11/ and use an editor to modify xorg.conf (i used vi cuz thats all i know..sad? yes)
5. Now MOST LIKELY the problem is a combination of both your monitor AND video card. The MONITOR section should look like this (dont copy my comments in brackets):

NOTE: back up ur xorg.conf file FIRST using
Code:
cp xorg.conf xorg.conf.bak
Code:
Section "Monitor"
  Identifier "LG Flatron L1750S" <-- (a name to use in the screen section)
  HorizSync 30-83 <-- (specific to my monitor ONLY, use ur own specs!)
  VertRefresh 56-75 <-- (specific to my monitor ONLY, use ur own specs!)

  # The next two lines were obtained using a Modeline gen provided in the link Spudley gave
  # v-freq: 60.00 Hz // h-freq 63.73 KHz
  Modeline "1280x1024" 109.2 1280 1336 1472 1720 1024 1024 1026 1062
EndSection
6. Now edit your Graphics Device section, it should look like this if ur using ATI Radeon X600 128MB

Code:
Section "Device"
  Identifier  "ATI Radeon X600"
  Driver      "ati" <-- CHANGE THIS TO "vesa" !!!! (thanks to Glennzo)
  VendorName  "ATI"
  BoardName   "ATI Technologies Inc RV370 5B62 [Radeon X600 (PCIE)]"
  BusID       "PCI:1:00:0"
  #VideoRam   131072
EndSection
7. Now make sure ur Screen section is appropriate, should look like this. Make changes if neccessary:

Code:
Section "Screen"
  Identifier "Screen0"
  Device "ATI Radeon X600" <-- (same as above identifier)
  Monitor "LG Flatron L1750S" <-- (same as above identifier)
  DefaultDepth 24
  SubSection "Display"
    Depth 24
    Modes "1280x1024" "1024x768" <-- (there may be more so leave them)
  EndSubSection
EndSection
8. Now save this file making sure u made ur back up first! Now run the command
Code:
startx
and you should be able to see something. If not hit the keys CTRL+ALT+BACKSPACE to kill the xserver. When mine worked i went into Yast to see the settings of my monitor and it was not there! So I tried putting the monitor settings back it did the same thing. So basically it doesnt like my monitor.

WOW i feel like a linux dweeb already ..lol but thats okay i like the feeling. Thats why i got linux

I hope this helps anybody else having the same problems i did. Once u get it going its a sweet feeling lookin at the sexiness of SUSE KDE!

Since i am still a newbie to linux, i may have made a mistake so please feel free to correct me!

Last edited by siq; 05-10-2006 at 02:17 AM.
 
Old 12-12-2006, 03:28 PM   #7
jarome
LQ Newbie
 
Registered: Mar 2004
Posts: 6

Rep: Reputation: 0
There is a much easier way

As root, do
init 2
You can do this from a romote shell if need be.
Your console should go into text mode. Login as root.

As root do
sax2

This will let you adjust the video. You may find that if you djust the sizes too much, you get the dreaded "out of sync" message. If so, do ctrl-alt-backspace to abort sax2 and try it again. This will prevent the video file from being reread.

When you are done, do
init 5

Its very easy!
 
  


Reply

Tags
ati, display, lg, linux, monitor, radeon, range, suse, video, x600, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie: SUSE Linux 10.0 Graphics Display Problems siq Linux - Hardware 9 11-09-2006 06:15 PM
SuSE Linux 9 - Password and Display problems - noob lovelyguinness Linux - Distributions 4 10-31-2004 01:06 PM
Suse 9.1 display problems JLande37 Linux - Newbie 1 09-09-2004 08:03 PM
suse 9.1 display problems daveyboy Linux - Hardware 3 09-07-2004 04:29 PM
SuSE 9.0 display problems Patsy Linux - Newbie 3 02-21-2004 03:39 PM


All times are GMT -5. The time now is 11:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration