LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Sound still on speaker when headphone is plugged in (http://www.linuxquestions.org/questions/linux-newbie-8/sound-still-on-speaker-when-headphone-is-plugged-in-544605/)

krisyok 04-09-2007 02:50 PM

Sound still on speaker when headphone is plugged in
 
Hi all,

I am wondering how to disable the sound on the speaker when my headphone is plugged in (sound is activated on both devices). I have openSuSe 10.2 installed on my Acer notebook 5550AWXMi with Intel ICH7 sound. Thank you in advance.

GrueMaster 04-09-2007 03:10 PM

Need more information on your system. Could you run this script and post the resulting link?

Thanks

krisyok 04-09-2007 03:18 PM

Hi GrueMaster,

This is the result
http://pastebin.ca/431638

By the way, I have found some solution by using Alsamixer.
I haven't tried yet but if there is a solution for KMix
that I don't have to install anything, that would be better.
Thanks for your prompt reply.

alienux 04-09-2007 03:27 PM

If you open up the full set of controls in KMix, there should be several tabs at the top of the mixer box. Click on the "switches" tab and look for an option that says something about headphone sensing.

GrueMaster 04-09-2007 03:35 PM

I'm not sure if there is a real solution other than a new driver. 1.0.12rc1 is quite old in the alsa world. Support for your system didn't really exist until 1.0.13, and there has been major enhancements since then.

If you are willing to try a set of new drivers, I have a self-contained build environment you could try. Download this tar file, extract it with "tar -jxvf my-build.tar.bz2", then cd into the directory, and type (as root) "make && audio_install". This will rebuild the driver, libs and utils, generating rpm files for each and install them.

After that, if you still have problems, we can explore changes in the driver before the next release.

krisyok 04-09-2007 03:37 PM

Quote:

Originally Posted by alienux
If you open up the full set of controls in KMix, there should be several tabs at the top of the mixer box. Click on the "switches" tab and look for an option that says something about headphone sensing.

Hi alienux,

There is no such an option in my KMix. I see only Caller ID, Off-hook, 2xInput Source in the Switches tab. Any idea? Thanks for your reply.

alienux 04-09-2007 03:52 PM

Quote:

Originally Posted by krisyok
Hi alienux,

There is no such an option in my KMix. I see only Caller ID, Off-hook, 2xInput Source in the Switches tab. Any idea? Thanks for your reply.

Hmmm, not sure. My installations have always had that option (Slackware, PCLinuxOS, and Fedora). I'm not sure why you wouldn't have it. This probably won't be very helpful, but I found two places where others have the same issue, and also don't have the "Headphone Jack Sense" option, but unfortunately, neither link shows an actual solution:

http://www.mepis.org/node/12955

http://ubuntuforums.org/showthread.php?t=73358

krisyok 04-09-2007 04:38 PM

Quote:

Originally Posted by GrueMaster
If you are willing to try a set of new drivers, I have a self-contained build environment you could try. Download this tar file, extract it with "tar -jxvf my-build.tar.bz2", then cd into the directory, and type (as root) "make && audio_install". This will rebuild the driver, libs and utils, generating rpm files for each and install them.

After that, if you still have problems, we can explore changes in the driver before the next release.

I've just installed it. It looks more advanced than the one I had. Now I can only control the headphone volume. There is no sound on speaker although I enable the PC speaker option.

krisyok 04-09-2007 04:51 PM

Quote:

Originally Posted by krisyok
I've just installed it. It looks more advanced than the one I had. Now I can only control the headphone volume. There is no sound on speaker although I enable the PC speaker option.

I think now it's working perfectly with the new driver from GrueMaster (many thanks). I have noticed that the headphone is controlled by "Front" slider while the speaker is controlled by "Surround" slider (instead of "PC speaker"). I don't know the reason but it just works (after I tried all the 15 sliders. Thank you, GrueMaster :)

GrueMaster 04-10-2007 11:13 AM

krisyok, can you try reloading the driver with the following commands:

su
rmmod snd-hda-intel
modprobe snd-hda-intel model=acer

Make sure that there is no audio programs running before you do this. Type "lsmod | fgrep snd-hda-intel" to see if it is in use.

krisyok 04-11-2007 03:05 AM

Quote:

Originally Posted by GrueMaster
Make sure that there is no audio programs running before you do this. Type "lsmod | fgrep snd-hda-intel" to see if it is in use.

Nothing is reported but when I do
rmmod snd-hda-intel
I get an error saying that this module is in use.

Is it necessary to reload the driver?
I mean it's working fine now..

GrueMaster 04-11-2007 01:05 PM

Not really, but I wanted to verify that you are getting the correct model identification. From your description of the surround slider controlling the speakers, you aren't.

Fou can also add a line in /etc/modprobe.conf for the model parameter. Essentially, your modprobe.conf file should look like this:
Code:

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=acer

After adding the above lines, you can reboot to see the effect. This is easier than trying to kill all audio applications and reload the driver (although reloading the driver is much faster).

I hope you take a moment to try this, as if it works better with the "model=acer" option, then I can add your system info to the driver before it gets released.

krisyok 04-12-2007 03:41 AM

I don't see any changes after rebooting.
Basically I put these lines in /etc/modprobe.conf before
# end of i386 part for modeprobe.conf


All times are GMT -5. The time now is 07:30 PM.