LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-20-2011, 07:47 PM   #1
pccor
LQ Newbie
 
Registered: Mar 2007
Posts: 12

Rep: Reputation: 0
Unhappy Sound Card volumes keep resetting to zero.


I am running SUSE 11.4 with kernel 2.6.37.6-0.5-desktop i686 and kde 4.6.0 release 6. My problem is that my sound volume settings keep resetting to zero spontaneously. When I turn them up as root in YAST I click on OK to save them and sound works for a while but later cuts out and I have to reset them again. alsasound is enabled in system services. Is there a solution to this? Thanks in advance.
 
Old 10-21-2011, 01:03 PM   #2
62chevy
Member
 
Registered: Mar 2002
Location: West (By God) Virginia
Distribution: Debian Squeeze - Sid
Posts: 281

Rep: Reputation: 45
Quote:
Originally Posted by pccor View Post
I am running SUSE 11.4 with kernel 2.6.37.6-0.5-desktop i686 and kde 4.6.0 release 6. My problem is that my sound volume settings keep resetting to zero spontaneously. When I turn them up as root in YAST I click on OK to save them and sound works for a while but later cuts out and I have to reset them again. alsasound is enabled in system services. Is there a solution to this? Thanks in advance.

Open alsamixer and set all to at least 80%. You may need to unmute some things. hit Esc once or twice to exit when done. Run alsactl save.

You may need to run alsactl init first if nothing works.
 
Old 10-21-2011, 06:45 PM   #3
pccor
LQ Newbie
 
Registered: Mar 2007
Posts: 12

Original Poster
Rep: Reputation: 0
Did all as advised. Started with "alsactl init". Sound works at boot time but soon drops out. What next?
 
Old 10-21-2011, 09:31 PM   #4
62chevy
Member
 
Registered: Mar 2002
Location: West (By God) Virginia
Distribution: Debian Squeeze - Sid
Posts: 281

Rep: Reputation: 45
Hard to say not knowing what kind of sound card you have. If it is a PCI or on-board card then run the command ' lspci -v ' and post the info for your card. If it a USB card then " lsusb " and post that out put. run ' lsmod | grep snd ' when the card is working and when it is not working. When it has quit on you check the end of ' dmesg | less ' for any info. Is this the only OS you have installed if not how does it work in the others.
 
1 members found this post helpful.
Old 10-22-2011, 06:31 AM   #5
pccor
LQ Newbie
 
Registered: Mar 2007
Posts: 12

Original Poster
Rep: Reputation: 0
lspci -v gives:
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
Subsystem: ASUSTeK Computer Inc. Device 8277
Flags: bus master, fast devsel, latency 0, IRQ 41
Memory at f9ff8000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [130] Root Complex Link
Kernel driver in use: HDA Intel

When card not working, lsmod | grep snd gives:

snd_pcm_oss 48271 0
snd_mixer_oss 17521 1 snd_pcm_oss
snd_seq 57777 0
snd_seq_device 6678 1 snd_seq
snd_hda_codec_realtek 274527 1
snd_hda_intel 25104 4
snd_hda_codec 95891 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 6198 1 snd_hda_codec
snd_pcm 88841 4 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer 22055 2 snd_seq,snd_pcm
snd 67246 17 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,s nd_hwdep,snd_pcm,snd_timer
soundcore 7270 1 snd
snd_page_alloc 8121 2 snd_hda_intel,snd_pcm

When card is working lsmod | grep snd gives:

snd_hda_codec_realtek 274527 1
snd_hda_intel 25104 2
snd_hda_codec 95891 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 6198 1 snd_hda_codec
snd_pcm 88841 2 snd_hda_intel,snd_hda_codec
snd_timer 22055 1 snd_pcm
snd 67246 10 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore 7270 1 snd
snd_page_alloc 8121 2 snd_hda_intel,snd_pcm

I do have Win XP installed on a VM which has no sound when there is none in the host (Linux).
 
Old 10-22-2011, 05:28 PM   #6
62chevy
Member
 
Registered: Mar 2002
Location: West (By God) Virginia
Distribution: Debian Squeeze - Sid
Posts: 281

Rep: Reputation: 45
The oss drivers are trying to take over your sound card. If you try ' modprobe -r oss ' I'm will to bet your sound comes back. Anyways you need to blacklist the oss drivers or remove them from your system. I'm not familiar enough with SUSE to tell you how to do either one. Blacklisting should be in /etc/modprobe or /etc/modprobe.d.
 
1 members found this post helpful.
Old 10-24-2011, 07:36 PM   #7
pccor
LQ Newbie
 
Registered: Mar 2007
Posts: 12

Original Poster
Rep: Reputation: 0
That appears to have done it. Thanks for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound: VIA DXS keeps resetting digitalhead Slackware 8 03-27-2006 05:42 PM
Sound level keeps resetting Maverick1182 Linux - Newbie 10 01-06-2006 12:22 AM
Sound volumes not loading Mingthefirst Linux - Software 3 08-27-2004 06:08 PM
Resetting video card Adam555 Red Hat 2 11-23-2003 04:38 AM
sound volumes on boot up smittycb10 Linux - Newbie 3 03-31-2003 01:50 PM


All times are GMT -5. The time now is 02:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration