LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-16-2005, 12:34 PM   #1
Maverick1182
Member
 
Registered: Aug 2004
Location: London
Distribution: Gentoo
Posts: 277

Rep: Reputation: 30
Sound level keeps resetting


Hi i'm running SUSE 10 and i'm getting annoyed with trying to figure out the smallest thing!

I keep reseting the sound level (PCM scroll bar upto 100%) to its maximum in KMIX, but every time i advance to another song, the level resets to about 30% again. highly annoying as i cant seem to find some kind of LOCK for that scroll bar..... does anyone have any suggestions?
 
Old 10-16-2005, 01:25 PM   #2
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
If you mean that KMix is unable to comply?
KMix is linked to YaST module. You have to store your sound settings in YaST first and logout
 
Old 10-17-2005, 01:37 PM   #3
Maverick1182
Member
 
Registered: Aug 2004
Location: London
Distribution: Gentoo
Posts: 277

Original Poster
Rep: Reputation: 30
Kmix complies..... i change the volume..... and its fine, but everytime i advance to another song.... it resets the volume level......
 
Old 10-18-2005, 02:56 AM   #4
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
is aumix having the same problem? just curious...
 
Old 10-18-2005, 07:08 PM   #5
Maverick1182
Member
 
Registered: Aug 2004
Location: London
Distribution: Gentoo
Posts: 277

Original Poster
Rep: Reputation: 30
The oddest thing happened.... i rebooted and it seems to have oddly fixed the problem...... i dont know what i did to change it but i do remember updating all the patches in YAST if anyone has this problem again, i'd advise doing the same.... may have been a glitch in amarok.

thanks for the helps guys.
 
Old 11-10-2005, 06:55 PM   #6
Maverick1182
Member
 
Registered: Aug 2004
Location: London
Distribution: Gentoo
Posts: 277

Original Poster
Rep: Reputation: 30
HMMMM , its gone back to its usual business, i.e. resets to 36 percent ever time i advance to another song..... ARGH..... very annoying...... aumix has the same problem..... does anyone have any ideas? Is it something to do with my soundcard? its worked fine under Mandriva 2005LE but Suse10 has given me nothing but problems when it comes to sound..... video works fine though lol
 
Old 11-11-2005, 03:31 AM   #7
mjjzf
Member
 
Registered: Feb 2004
Location: Valby, Denmark / Citizen of the Web
Distribution: Slackware 14.1
Posts: 879

Rep: Reputation: 39
Can you change the settings with alsamixer?
 
Old 11-11-2005, 03:39 AM   #8
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
somewhere there is

.aumixrc I think alscontrol read it when PC boot up to reset
sound level (look in / / rc.d/sound script)

what happen if you were to set .aumixrc as readonly for
everybody incl root?

That may help you to track if it is an application problem
or mixer problem
 
Old 11-28-2005, 11:10 PM   #9
glennt11
LQ Newbie
 
Registered: Aug 2004
Location: NY
Distribution: Ubuntu,Red Hat,Centos 5
Posts: 29

Rep: Reputation: 0
I'm assuming from the last post that this problem was resolved, if not, here's an easier fix......

You stated you're using Amarok, which uses an engine to play it's music. The 2 that I know are Helix and Xine. As far as Helix is concerned you're on your own, but if you install the 'good' version of Xine that allows you to play any file you want....

Open Xine, right click on it and go to Settings --> Setup...

Change configuration experience level to Master of the known universe. Restart Xine

Go back to Setup, click on the Audio tab and at the very bottom you'll see the last 2 options are set startup volume and restore volume level at startup. Change to whatever sound level suits your tastes, hit Apply and you're ready to go.

Because Amarok uses another program to get it's sound, it uses that programs settings to play songs. SO if the volume is set low on that program, it'll likewise play low each and everytime you switch a song. It caused me a helluva headache till I actually started playing with Xine.

I hope this helps someone out there.
 
Old 11-29-2005, 12:57 AM   #10
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Solus
Posts: 2,254

Rep: Reputation: 47
Use alsamixer to set the volumes (in terminal) then do alsactl store
 
Old 01-06-2006, 01:22 AM   #11
MrLobster
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Rep: Reputation: 0
I have the same problem. amaroK uses Helix. alsactl store doesn't fix it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound: VIA DXS keeps resetting digitalhead Slackware 8 03-27-2006 06:42 PM
change sound level masood_mj Linux - Newbie 2 11-02-2005 07:05 PM
Sound level moniter kaega2 Linux - Software 3 01-11-2005 03:34 AM
Sound Level in RH9 sonesay Linux - Newbie 4 05-17-2004 11:12 AM
mplayer sound level and 4.1 speakers Cooldoud Linux - Newbie 0 04-27-2004 04:01 PM


All times are GMT -5. The time now is 12:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration