LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-26-2005, 02:30 AM   #1
bruse
Member
 
Registered: Feb 2005
Location: internet
Distribution: Debian
Posts: 821

Rep: Reputation: 30
remote desktop problem.


i am using mandrke10.0 +KDE+GNOME.

I WANT TO START REMOTE KDE IN MY LINUX BOX


SO HOW TO START REMOTE SYSTEM GNOME OR KDE IN MY LINUX BOX


I HAVE ONE ERROR WHILE SSH


[staff@localhost staff]$ ssh 10.255.240.103
[staff@Simlab-node3 staff]$ starx
-bash: starx: command not found
[staff@Simlab-node3 staff]$ startx
Using authority file /home/staff/.Xauthority
Writing authority file /home/staff/.Xauthority
Using authority file /home/staff/.Xauthority
Writing authority file /home/staff/.Xauthority
Authentication failed - cannot start X server.
Perhaps you do not have console ownership?xinit: Server error.
Couldnt get a file descriptor referring to the console
[staff@Simlab-node3 staff]$



[staff@Simlab-node3 staff]$ startx -- :6
Using authority file /home/staff/.Xauthority
Writing authority file /home/staff/.Xauthority
Using authority file /home/staff/.Xauthority
Writing authority file /home/staff/.Xauthority

Authentication failed - cannot start X server.
Perhaps you do not have console ownership?Y


what does mean this ..



some times the xserver starting in the remote linux box???


when i give "starkde " the kde starting in the remote linux box.



so how to get remote Desktop please..
 
Old 04-26-2005, 07:40 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Here is a howto that might help.
http://www.ibiblio.org/mdw/HOWTO/Remote-X-Apps.html

Does it work to run a application rather then running an entire session through SSH. In other words, with Xwindows running on the remote host. And running Xwindows on the local machine, just run the programs that you want to do through the tunnel.

If you can't do this, try the -X option to the ssh command. This will enable X11 forwarding for the session.
Also, the :6 in your command doesn't look right. SSH uses :10 I believe on one end and :0 on the other.

---

As an experiment, log in using SSH and check the value of the DISPLAY variable.
echo $DISPLAY

Then try:
xinit -- `$DISPLAY`

= = = = =

I tried a little experiment myself. I went to vt/2 and logged in as root. I was logged into KDE as a normal user on vt/7. I typed in 'xinit -- :1' and it failed. It gave a message about an invalid '-n' option to xvt. So instead I type in: 'xinit /usr/X11R6/bin/rxvt -- :1'
This almost worked but there was a message about rxvt not supporting UTF8 encoding.

So I tried 'xinit /usr/X11R6/bin/xterm -- :1'.
This brought up X-windows on vt/8. I then entered the window manager in xterm to start a session.

You could try:
ssh -X 10.255.240.103
xinit /usr/bin/startkde-- $(DISPLAY)

You might need to manually enter the value of DISPLAY.
When I tried
DISPLAY=':1.0'
xinit /usr/bin/startkde-- $(DISPLAY)
and
xinit /usr/bin/startkde-- `$DISPLAY`
Both attempts failed with a message about display :0 begin in use.
However
xinit /usr/bin/startkde-- :1
was successful.




Last edited by jschiwal; 04-26-2005 at 08:23 AM.
 
Old 04-26-2005, 08:41 AM   #3
bruse
Member
 
Registered: Feb 2005
Location: internet
Distribution: Debian
Posts: 821

Original Poster
Rep: Reputation: 30
sir i have to run my linux box KDE and remote computer GNOME in my linux box.

i mean KDE from my mandrake10.0.


GNOME from remote computer say redhat or fedora or whatever.


thanks..
 
Old 04-26-2005, 09:35 AM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
xinit /usr/bin/startgnome -- :1
 
Old 04-28-2005, 04:10 AM   #5
bruse
Member
 
Registered: Feb 2005
Location: internet
Distribution: Debian
Posts: 821

Original Poster
Rep: Reputation: 30
no sir normal user can not start a kde or gnome.

[staff@Simlab-node3 staff]$ startx -- :2
Using authority file /home/staff/.Xauthority
Writing authority file /home/staff/.Xauthority
Using authority file /home/staff/.Xauthority
Writing authority file /home/staff/.Xauthority
Authentication failed - cannot start X server.
Perhaps you do not have console ownership?xinit: Server error.
Couldnt get a file descriptor referring to the console
[staff@Simlab-node3 staff]$


ansd i login to root

and #startx -- :2

kde openning in the remote system but not in my system.
 
Old 04-29-2005, 05:35 AM   #6
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
It is possible for a normal user to start kde. You can use /usr/sbin/startkde. I just run from vt/2: xinit /usr/bin/startkde -- :1 and it was successful. You need to have the X running locally to be able to receive X-windows messages and have them displayed.

Firstly, try logging into an ssh session on the remote machine as a normal user. Look at the value of the DISPLAY environment variable. When using ssh, it sets this value. I think the value will be :10 but I'm not certain.
echo $DISPLAY

Suppose that the result is
:10

Then try the command in the ssh shell
xinit /usr/bin/startkde -- :10

Now on your local end, I think you want
xinit /usr/X11R6/bin/xterm -- :1
This will start xwindows with xterm on your local machine, and hopefully the x-windows signals will travel through the ssh tunnel.

This link may help you set things up:
Protecting Your Xwindows Session Using ssh-agent

Last edited by jschiwal; 04-29-2005 at 09:23 AM.
 
Old 04-29-2005, 08:19 PM   #7
LinuxDave
LQ Newbie
 
Registered: Dec 2004
Posts: 21

Rep: Reputation: 15
To start a remote KDE session on your local linux box:

On the local machine type:

xinit -- :1

This will start a second X server locally that will be empty and ready to receive the full KDE desktop.

export DISPLAY=localhost:1

This will set the current display to the new (blank) X server

ssh -X user@remote

This will connect you to the remote machine and enable X forwarding

On the remote machine type:

echo $DISPLAY

should display :10 -- if not, then X forwarding over ssh is not set up.

startkde (or "gnome-session" for gnome)

This will start the KDE desktop and display it on the local machine.

Note: Do Not Execute "xinit" on the remote machine!

Note 2: You may need to press control-alt-F8 to see the KDE desktop.


LinuxDave

Last edited by LinuxDave; 04-29-2005 at 08:29 PM.
 
Old 04-29-2005, 08:34 PM   #8
pokemaster
Member
 
Registered: Apr 2005
Location: Massachusetts, USA
Distribution: debian,ubuntu,slackware
Posts: 110

Rep: Reputation: 17
You can also try logging in to single-user mode, then run "kdm" at the prompt. KDM has the option to do a remote login (usually hit Alt+R at the login screen.)

It'll ask you for the remote hostname, and should connect you properly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Remote desktop software to control desktop GUI? Phaethar Linux - Software 3 06-27-2008 09:30 AM
Major problem with yum/centos 4.2 and remote desktop Lleb_KCir Linux - Software 7 11-22-2005 08:50 AM
Remote Desktop grim1234 Linux - Networking 5 11-04-2005 03:41 PM
Remote Desktop Problem kpanic Linux - General 1 05-16-2003 12:28 AM
RH9 & XP Remote Desktop Sharing Problem please help. Paul Parr Linux - Networking 5 05-03-2003 05:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration