LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-10-2005, 12:52 PM   #1
Influx
LQ Newbie
 
Registered: Sep 2005
Location: Canada
Distribution: Slackware 10.2
Posts: 27

Rep: Reputation: 15
Arrow Rebuilt kernel - no sound now :(


I have a 2.4.31 kernel running slackware 10.2, and I was trying to get the bootsplash to work, I patched the kernel, no errors, then ran make menuconfig, set all the options it told me to, and also removed some options that I knew I didn't need.

I ran make make dep, then make modules && make modules_install, no problems. ran make bzImage and left it at that for another day to pick up the project (didn't move .
Turns out, when I restarted, there was no sound! I tried using alsaconf and alsamixer and nothing, no cards were detected.
So this is obviously a newbie problem here, I don't know how to set up a pci card manually. It's a sound blaster live! 5.1. Did I accidentally delete the modules or what happened? I'm so confused
 
Old 10-10-2005, 01:03 PM   #2
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
i think you're supposed to recompile alsa when you recompile your kernel... no??
 
Old 10-11-2005, 08:56 AM   #3
Influx
LQ Newbie
 
Registered: Sep 2005
Location: Canada
Distribution: Slackware 10.2
Posts: 27

Original Poster
Rep: Reputation: 15
I think that did it
Once again, though, I think I did it the sloppy way, uninstalled the alsadriver slackware package, then reinstalled it as source so now it doesn't show up under the libraries :|
 
Old 10-11-2005, 09:28 AM   #4
Ray_Kovecses
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 66

Rep: Reputation: 15
I also think that you would need to make sure your sound cards modules are built in the kernel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just rebuilt kernel for the first time....kernel panic!!! cdavidson Linux - Newbie 3 04-03-2005 07:40 PM
splitting a larg file into smaller files to be rebuilt on a windows comp 1eyedgorilla Linux - Software 2 12-22-2004 06:30 PM
Tried 2.6. Now no sound in either kernel. jeramy Slackware 13 11-18-2003 08:35 PM
Can I load both oss (kernel sound drivers) and alsa in 2 sound cared system? cmisip Linux - General 0 04-12-2003 01:27 AM
no sound on sis onboard sound kernel 2.4.18 blither Linux - General 10 12-13-2002 05:53 AM


All times are GMT -5. The time now is 08:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration