LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-21-2002, 01:28 PM   #1
DedeHai
LQ Newbie
 
Registered: Nov 2002
Posts: 1

Rep: Reputation: 0
Angry Problems with Geforce kernel update


hi there
i got a problem while installing the new nvidia drivers.
there is no download for redhat 8.0, so i have to recompile the source file of the driver right?
so i downloaded the sourcefile for the GLX driver and the kernel update (so it supports the new nv driver)
compiling the GLX driver was no problem, everything was fine, no errors. but when i try to compile the kernel update (i think its an update) there are thousands of warnings and some errors.
thats how it starts when i start "make install":

make install
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DMODULE
-D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -DRM_HEAPMGR -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=3123 -DNV_UNIX -DNV_LINUX -DNVCPU_X86 -I. -I/usr/src/linux/include -Wno-cast-qual nv.c
In file included from /usr/include/linux/tqueue.h:18,
from nv-linux.h:54,
from nv.c:14:
/usr/include/asm/bitops.h:333:2: warning: #warning This includefile is not available on all architectures.
/usr/include/asm/bitops.h:334:2: warning: #warning Using kernel headers in userspace.
In file included from nv-linux.h:54,
from nv.c:14:
/usr/include/linux/tqueue.h:94: parse error before "tqueue_lock"
In file included from nv.c:14:
nv-linux.h:57:75: linux/vmalloc.h: Datei oder Verzeichnis nicht gefunden
In file included from /usr/include/linux/fs.h:23,
from /usr/include/linux/capability.h:17,
from /usr/include/linux/binfmts.h:5,
from /usr/include/linux/sched.h:9,
from /usr/include/linux/delay.h:12,
from nv-linux.h:60,
from nv.c:14:
/usr/include/linux/string.h:8:2: warning: #warning Using kernel header in userland!
In file included from /usr/include/linux/sched.h:14,
from /usr/include/linux/delay.h:12,
from nv-linux.h:60,
from nv.c:14:
/usr/include/linux/timex.h:173: field `time' has incomplete type
In file included from /usr/include/linux/signal.h:4,
from /usr/include/linux/sched.h:25,
from /usr/include/linux/delay.h:12,
from nv-linux.h:60,
from nv.c:14:
/usr/include/asm/signal.h:107: parse error before "sigset_t"
/usr/include/asm/signal.h:110: parse error before '}' token
In file included from /usr/include/linux/sched.h:81,
from /usr/include/linux/delay.h:12,
from nv-linux.h:60,
from nv.c:14:
/usr/include/linux/timer.h:45: parse error before "spinlock_t"
/usr/include/linux/timer.h:53: parse error before '}' token
/usr/include/linux/timer.h:67: parse error before "tvec_base_t"
/usr/include/linux/timer.h:101: parse error before "tvec_bases"
/usr/include/linux/timer.h: In function `init_timer':
/usr/include/linux/timer.h:105: dereferencing pointer to incomplete type
/usr/include/linux/timer.h:105: dereferencing pointer to incomplete type
/usr/include/linux/timer.h:106: dereferencing pointer to incomplete type
/usr/include/linux/timer.h: In function `timer_pending':
/usr/include/linux/timer.h:121: dereferencing pointer to incomplete type
In file included from nv-linux.h:60,
from nv.c:14:
/usr/include/linux/delay.h:13:23: asm/delay.h: Datei oder Verzeichnis nicht gefunden
In file included from nv-linux.h:64,
from nv.c:14:
/usr/include/linux/interrupt.h:44:25:
............................
and so on.
anyone can help???

 
Old 11-22-2002, 04:23 AM   #2
g0dzuki99
Member
 
Registered: Jan 2002
Posts: 56

Rep: Reputation: 15
did ./confiure run with any errors or just when you 'make install'?
 
Old 11-26-2002, 12:39 PM   #3
peeples
Member
 
Registered: Sep 2002
Location: Wichita Falls, TX
Distribution: tried a lot of 'em, now using kubuntu
Posts: 180

Rep: Reputation: 30
Could you post the entire output of the make command?

When I installed my Nvidia, I got some similar warnings and then it bombed out after mktemp was called. I had to go install mktemp. Then it bombed out a second time. Seems I have gotten into the (good) habit of doing "./configure" and "make" as my normal user, then doing "su root" before running the "make install" in normal situations. Well, for the Nvidia kernel source, I ended up having to run the "make" under superuser. Voila!

I don't know if that is your problem, that is why it might be useful to see the entire output.
 
Old 12-10-2002, 07:21 PM   #4
404
Member
 
Registered: Mar 2002
Location: USA
Distribution: slackware; what else is there?
Posts: 30

Rep: Reputation: 15
if you had Read The Manual you would have known that you dont ./configure or make to install the kernel module and the glx, maybe next time you will understand alittle RTFM'ing will get you a long ways
 
Old 12-10-2002, 07:32 PM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
DedeHai, please ignore that moron. Everyone else here is lovely.
 
Old 01-08-2003, 03:29 AM   #6
jerven
LQ Newbie
 
Registered: Jan 2003
Distribution: redhat 8.0
Posts: 2

Rep: Reputation: 0
I have the same problem

I unfortunatly haven;t solved it either but i think that it is because the include files are for a different kernel than th one we use.
Other wise I dont understand why so many different parse errors are reported because altough I have read the NVIDIA code i did not see any obvious file corruptions.

So If you found a solution elsewhere I would be much indebted if you would post the solution here.
 
Old 01-08-2003, 07:49 PM   #7
osprey
LQ Newbie
 
Registered: Jan 2003
Location: US of A
Distribution: RedHat 8.0
Posts: 6

Rep: Reputation: 0
I had nearly the same problem when installing my nvidia kernel. Get the latest version that matches your cpu type in tar.gz format, extract it, and then instead of typing make install try only make. After that, I just used the same version GLX in RPM format, and all was smooth

I donno, it worked for me.

Last edited by osprey; 01-08-2003 at 07:52 PM.
 
Old 01-09-2003, 02:02 AM   #8
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
have you tried using the NVchooser.sh script ?

this is available from nvidia,
get it and run it and it will tell you what number kernel update you need

there are many different numbered packages and sources available but not on the same page and with no immediately obvious links
the pages are confusing to say the least

(i've tried this 3 times so far but am missing the point somewhere as i end up with a black screen-though this is due to my ignorance rather than nvidia posting duff source files)

and there most certainly are RedHat8 specific packages available,
you just gotta go a hunting...

happy hunting
 
Old 01-09-2003, 06:19 PM   #9
osprey
LQ Newbie
 
Registered: Jan 2003
Location: US of A
Distribution: RedHat 8.0
Posts: 6

Rep: Reputation: 0
I just recently discovered a way that worked for me.

I downloaded the latest version of the tar.gzipped source, and after extracting both of them, I discovered that the README file in the kernel package has different install instructions than the one you find on the main page.

After following these different instructions, I had no problems.
 
Old 01-10-2003, 01:35 AM   #10
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Various
Posts: 1,736

Rep: Reputation: 146Reputation: 146
"I downloaded the latest version of the tar.gzipped source, and after extracting both of them, I discovered that the README file in the kernel package has different install instructions than the one you find on the main page.

After following these different instructions, I had no problems."

So i did the same....

error messages read as follows

[sal@localhost NVIDIA_kernel-1.0-3123]$ make
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -DNTRM -D_GNU_SOURCE -DRM_HEAPMGR -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=3123 -DNV_UNIX -DNV_LINUX -DNVCPU_X86 -I. -I/usr/src/linux/include -Wno-cast-qual nv.c
In file included from /usr/include/linux/prefetch.h:13,
from /usr/include/linux/list.h:6,
from /usr/include/linux/module.h:11,
from nv-linux.h:28,
from nv.c:14:
/usr/include/asm/processor.h:55: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm/processor.h:55: requested alignment is not a constant
In file included from /usr/include/linux/module.h:296,
from nv-linux.h:28,
from nv.c:14:
/usr/include/linux/version.h:2:2: #error "======================================================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
/usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/version.h:35:2: #error "======================================================="
In file included from nv-linux.h:28,
from nv.c:14:
/usr/include/linux/module.h:298: parse error before "UTS_RELEASE"
In file included from nv-linux.h:29,
from nv.c:14:
/usr/include/linux/version.h:2:2: #error "======================================================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
/usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h to"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/include/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/version.h:35:2: #error "======================================================="
In file included from nv.c:14:
nv-linux.h:31:40: missing binary operator before '('
nv-linux.h:33:42: missing binary operator before '('
nv-linux.h:35:42: missing binary operator before '('
nv-linux.h:37:42: missing binary operator before '('
nv-linux.h:39:42: missing binary operator before '('
nv-linux.h:43:4: #error This driver does not support 2.6.x or newer kernels!
In file included from /usr/include/asm/hardirq.h:6,
from /usr/include/linux/interrupt.h:45,
from nv-linux.h:64,
from nv.c:14:
/usr/include/linux/irq.h:65: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/irq.h:65: requested alignment is not a constant
In file included from /usr/include/linux/interrupt.h:45,
from nv-linux.h:64,
from nv.c:14:
/usr/include/asm/hardirq.h:16: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm/hardirq.h:16: requested alignment is not a constant
In file included from nv-linux.h:64,
from nv.c:14:
/usr/include/linux/interrupt.h:128: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/interrupt.h:128: requested alignment is not a constant
nv-linux.h:111:28: linux/autoconf.h: No such file or directory
nv.c:99:65: missing binary operator before '('
nv.c:697:65: missing binary operator before '('
nv.c:1011:65: missing binary operator before '('
nv.c:1040:65: missing binary operator before '('
nv.c:1383:65: missing binary operator before '('
nv.c: In function `nv_kern_mmap':
nv.c:1386: warning: implicit declaration of function `pgprot_writecombine'
nv.c:1386: incompatible types in assignment
nv.c:2926:65: missing binary operator before '('
make: *** [nv.o] Error 1

any ideas?
 
Old 01-10-2003, 03:51 PM   #11
osprey
LQ Newbie
 
Registered: Jan 2003
Location: US of A
Distribution: RedHat 8.0
Posts: 6

Rep: Reputation: 0
Yeah, I don't know what to say... it worked for me.
 
Old 01-10-2003, 04:20 PM   #12
membrax
Member
 
Registered: Nov 2002
Location: 50'48''N - 4'21''E
Distribution: SuSE7.1 - SuSE8.1 - SuSE8.2 - RH6.2 - RH7.1 - RH7.3 - RH8.0 - RH9.0 - Fedora Core 1
Posts: 281

Rep: Reputation: 30
Just in case :
the COMPLETE & DETAILED procedure :

First, visit the Linux section of the nVidia driver download area and get the following two files:

NVIDIA_GLX-1.0-4191.src.rpm (at top of page)
NVIDIA_kernel-1.0-4191.src.rpm (at bottom of page)

Save these files to your machine. Now, open up a terminal (konsole, gnome-terminal) and become root (also called superuser). Change to the directory containing the packages and install them with:

cd /path/to/packages

rpm -i NVIDIA* (or rpm -ivh NVIDIA* for verbose output and to print hash marks [#] indicating installation progress)

Since these are only source packages, we haven't actually installed any drivers yet, we've just placed the necessary files onto the system to get us started. To verify that everything is where it should be, issue the command:

ls /usr/src/redhat/SPECS/

You should see two files listed: NVIDIA_GLX.spec and NVIDIA_kernel.spec These two files simply tell RPM how to create packages using the source files. These source files were installed into /usr/src/redhat/SOURCES. Once you're satisfied everything went according to plan:

cd /usr/src/redhat/SPECS

This is the directory the source packages were installed into. /usr/src also contains the source code for the Linux kernel itself (assuming it was selected when you installed Psyche). Once inside the /usr/src/redhat directory, you might want to take a look around and see if you can get a feel for what the various directories are for. If you aren't comfortable with that, don't worry, it's not necessary. Next, the hard part (if you've been exploring, before you proceed make sure your working directory is /usr/src/redhat/SPECS – you can use the pwd command to display this for you):

rpmbuild -bb NVIDIA* (“rpmbuild” should be self-explanatory, the bb means “build binary” -- man rpmbuild at the console or #rpmbuild into Konqueror's address bar or a command box for more information)

It should only take a few minutes for the two packages to be built. You'll see information scrolling by as your request is carried out. Don't worry if you don't know what any of it means, since not many people do. Once the build process finishes, you're almost there. Now, to install the packages we just built:

cd /usr/src/redhat/RPMS/i386/ (this is where rpmbuild puts the packages after they are ready)

rpm -Uvh NVIDIA*

RPM will process for a moment, indicating its progress with hash marks and by displaying a percentage. If all has gone well, you should see both packages install and then be returned to a command prompt. At this point, I would suggest you view the README located on nVidia's website, as it contains a great deal of information about using, troubleshooting and customizing the nVidia drivers. For the impatient, I'll include here the minimum changes you need to make to your system to get the drivers working.

At this point the drivers themselves are installed and ready to go. Now all we have to do is tell XFree86 we want to use them instead of its own drivers. Since this requires making changes to the (vitally important!) XFree86 configuration file, we'll make a backup copy of it before going any further. This is extremely important! Without a clean working copy of this file, you will not be able to access your desktop.

cp /etc/X11/XF86Config /etc/X11/XF86Config-original

Now if you manage to mangle XF86Config you can copy XF86Config-original to XF86Config and start over with a known-good configuration. For those of us who aren't vi or emacs aficionados, Red Hat has included an excellent screen-based text editor called pico. Considering the number of capable and friendly GUI-based editors included with modern Linux distributions, you might question the need for using or even being aware of console-based alternatives -- until, like now, you're doing something that has the potential to render your GUI unavailable. As a general rule, you should always have a familiar console-based editor available for just such times. There are few things more frustrating than needing to make a simple change to a configuration file and being stumped because you have no idea how to do so from the command line. That being said, still as root user, issue the command:

pico -w /etc/X11/XF86Config (always use the -w switch with configuration files, since it prevents pico from applying any line wrapping and thus mangling the file)

Locate the line containing Driver "nv" and replace it with Driver "nvidia". To search in pico you press CTRL+W and enter the search term (shortcuts are displayed at the bottom of the interface). Now, find the section called Module and make sure Load "glx" is one of the entries. If not, add it to the list. Also in the Module section, remove or comment out any lines that contain Load "dri" and Load "GLcore". (You comment out a line by prefacing it with a hash mark, as in #Load "GLcore".)

That's it! You should be ready to go. Save all your work, and press CTRL-ALT-BACKSPACE to restart the X server. If all went well, you should see the nVidia splash screen pop up briefly and then be presented with the standard GDM login screen. Once your desktop has loaded, press ALT+F2 to bring up a command box and type in tuxracer (this assumes TuxRacer is installed, of course) to test your new drivers. If something has gone wrong along the way, make sure the nVidia packages are installed correctly and that your changes to XF86Config are correct (now you'll see why I pointed out the need for a backup file and an easy-to-use editor!).

rpm -qa |grep NVIDIA will query the RPM database for any installed package with "NVIDIA" in its name (as always, case matters). If you don't see both packages listed, something has gone wrong. Back up to the section that explains building the packages and try again.


This should be quite helpful.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Software 4 05-06-2007 10:27 AM
HELP:Problems about Update kernel 2.6.10 AK prince Slackware 5 09-22-2005 08:15 PM
Problems after Kernel update KR-data Linux - Hardware 6 12-05-2004 06:32 AM
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Distributions 0 10-13-2004 11:01 AM
Problems with kernel 2.6.3, vesafb and XFree with Geforce 2 ivan_stepaniuk Linux - Software 2 03-17-2004 02:47 PM


All times are GMT -5. The time now is 02:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration