LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-01-2010, 04:26 PM   #1
Draconious
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Rep: Reputation: 0
Problem with booting OpenSUSE Linux: FATAL: Module ip_tables not found.


Hi everyone, I have OpenSUSE 11 Linux installed on my laptop. I just used it last Friday and it was working alright. Then I switched back to Windows for two days and when I tried to start Linux again on Monday it suddenly stopped working. Halfway through the booting page it changes to a DOS-like interface and displays the following error message:

FATAL: Module ip_tables not found.
iptables v1.4.2-rcl: can't initialize iptables table 'filter': iptables who? (do you need to ins mod)?
Perhaps iptables or your kernel needs to be upgraded.


After that I could only login via command terminal and could not load to the graphic interface. Can anyone tell me what has gone wrong and how to fix it?

Thanks very much.
 
Old 04-01-2010, 05:00 PM   #2
gumaheru
LQ Newbie
 
Registered: Nov 2009
Posts: 20

Rep: Reputation: 0
Have you made any changes or conducted any upgrades to your kernel? This would be the init image since you are getting this issue at boot time. The easiest thing to do would be to use the previous kernel. Watch the boot menu and pick the kernel with a slightly older version and see if it boots. Then you can decide to stay there or upgrade to fix the issue and get to the latest version. Or, you can just upgrade the kernel from the command line using the yast2 tool. You can also install zypper which works a lot like Redhat's yum tool.

If you want to learn more about the system and trouble shoot these issues you can check the modules that are loaded. Use "lsmod |grep ip_tables" to see if this module is really loaded or not. Next try to load it. Run "modeprobe ip_tables". If it loads then unload the module and using "modprobe -r ip_tables". Then run "insmod ip_tables". If that doesn't work then you can be brave and mess with the init image but just a lot easier and faster to just upgrade or reinstall the bad kernel.

Just keep in mind if you upgrade your kernel, please keep the previous just in case the new one is bad you can fall back to the previous. You should always install the new one and not upgrade if you are doing it manually. I don't remember if the tools do that or not.
 
Old 04-01-2010, 06:35 PM   #3
Draconious
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Original Poster
Rep: Reputation: 0
The OS indicated last time that there were updates available so I installed them. I am not sure if that is the cause of the problem. Could you explain in detail how to select an old kernel? Thanks.
 
Old 04-02-2010, 11:19 AM   #4
gumaheru
LQ Newbie
 
Registered: Nov 2009
Posts: 20

Rep: Reputation: 0
After the computer does its check of memory and hard disks your boot manager , grub or lilo, will post a nice little menu. http://img30.imageshack.us/img30/5674/pic8f.png There should be multiple chooses. You use the up or down arrow to choose which version of the kernel you would like to boot with.

Select another boot loader then the one that is currently highlighted. If you only have failsafe then choose that one. Once your computer boots up you can run yast or yast2 to install the kernel update.
 
Old 04-02-2010, 11:32 AM   #5
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

Quote:
The OS indicated last time that there were updates available so I installed them. I am not sure if that is the cause of the problem.
Yup - sounds like it.

Strong suggestion:
1. Boot back into Suse Linux
<= There are two methods:
a) You can select an older kernel from the grub menu, like gumaheru suggested
... or ...
b) You can boot into "rescue mode" from your original install CD/DVD

2. Go into "yast", and perform *another* kernel update
Select "yes" to any defaults

3. Upon reboot, the problem should very likely be resolved

Please post back how it goes, in any case.

Thank you in advance ... and good luck!
 
Old 04-03-2010, 05:18 AM   #6
Draconious
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by gumaheru View Post
After the computer does its check of memory and hard disks your boot manager , grub or lilo, will post a nice little menu. http://img30.imageshack.us/img30/5674/pic8f.png There should be multiple chooses. You use the up or down arrow to choose which version of the kernel you would like to boot with.

Select another boot loader then the one that is currently highlighted. If you only have failsafe then choose that one. Once your computer boots up you can run yast or yast2 to install the kernel update.
I have four Linux available on that page. The problem is that 2 of them have the problem I described before. The other two are falsesafe. The problem with them is that with these two kernels no Internet connection is available even with my network cable connected. Even all my USBs are disabled under this kernel so I can't really perform kernel update I suppose. Any other suggestions?
 
Old 04-03-2010, 07:44 AM   #7
charchilp
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Rep: Reputation: 0
The OS indicated last time that there were updates available so I installed them. I am not sure if that is the cause of the problem. Could you explain in detail how to select an old kernel? Thanks.
 
Old 04-05-2010, 11:34 AM   #8
gumaheru
LQ Newbie
 
Registered: Nov 2009
Posts: 20

Rep: Reputation: 0
Charclip please read the posts that I and Paulsm4 wrote above. I even included a picture of what you should be looking for.

Draconious, I can't remember if the failsafe contains the driver modules for you nic's or not. Can you see any nic interfaces when you run `ifconfig -a`? Have you tried just restarting the network daemon? `/etc/init.d/network restart`. Or just run `ifup eth0`. If all else fails I would follow what Paulsm4 stated to do with the installation CD's and trying to get into recovery mode.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FATAL: Module off not found. cov Linux - Hardware 1 09-10-2007 04:19 PM
[SOLVED] Fatal Module not found Bryan7 Slackware 2 12-03-2006 01:02 AM
amsn problems + FATAL: Module ip_tables not found stevesk Slackware 6 06-16-2006 05:32 PM


All times are GMT -5. The time now is 02:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration