LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-27-2003, 04:41 AM   #16
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68

Any chance he was referring to lyx?

To install xforms it looks like you would read the 00README file and possible edit your Makefile to fit your system. Likely though you just skip the configure stage and just:
make
And pray for no errors. If there are none, usually following it with a:
make install
Will then allow lyx to pick it up in the configure stage.

Cool
 
Old 07-27-2003, 04:57 AM   #17
abd_bela
Member
 
Registered: Dec 2002
Location: algeria
Distribution: redhat 7.3, debian lenny
Posts: 620

Rep: Reputation: 31
to our friend newbie karim

I think you come from window$, you are familiar to mouse and double click to install.

so, instead of using tar.gz ( which need untaring, compiling installing ) software download the rpm's software.
for lyx download lyx rpm

the newversion lyx , for example lyx-1.3.1-1rh8-qt.i386.rpm
doesn't need xforms, it needs qt which is install in rh8 or rh9.
you can use the kpackage ( on kde ) to install, but it s better to use from the xterm

rpm has several options the more used are:

rpm -ivh package : to install package
rpm -qi package to get info on the package
rpm -ql package to get list of the file in the package
rpm -e package to erase the package

I hope this help you

bela
best regards
 
Old 07-27-2003, 06:15 AM   #18
Karin
LQ Newbie
 
Registered: Jul 2003
Location: Holland
Distribution: Red Hat 7.3
Posts: 26

Original Poster
Rep: Reputation: 15
I already tried to read the 00README file, but couldn't understand it.

I tried make and got this:

making all in ./lib/include...
/bin/sh: /usr/ccs/bin/make: No such file or directory
making all in ./lib...
/bin/sh: /usr/ccs/bin/make: No such file or directory
making all in ./image...
/bin/sh: /usr/ccs/bin/make: No such file or directory
making all in ./gl...
/bin/sh: /usr/ccs/bin/make: No such file or directory
making all in ./fdesign...
/bin/sh: /usr/ccs/bin/make: No such file or directory
making all in ./fd2ps...
/bin/sh: /usr/ccs/bin/make: No such file or directory
make: *** [all] Error 127
 
Old 07-27-2003, 06:18 AM   #19
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Wow, this is going great eh?

The readme should be readable with less:
less 00README

As far as all the errors go, it looks like it's pointing to the wrong location for make, see about editing that Makefile as it will likely have something like:
$MAKE = /usr/ccs/bin/make
And you'll wanna change that to the location of make on your system, to find out where that is type:
whereis make

Cool
 
Old 07-27-2003, 06:54 AM   #20
Karin
LQ Newbie
 
Registered: Jul 2003
Location: Holland
Distribution: Red Hat 7.3
Posts: 26

Original Poster
Rep: Reputation: 15
I looked at it found this...

00readme:
To build, unpack the distribution in the standard manner into your
favorite subdirectory.

Take a look at the `Imakefile' in the top level directory. In theory,
this is the only file you should have to mess with. If you have to
diddle with anything else, I've done something wrong and you should
tell me (please be gentle).

At the very top, you should find a collection on "#define" statements.
These should be the only items you should need to edit. Your choices
are usually "YES" and "NO".

Makefile:
# Makefile generated by imake - do not edit!

Imake file:
/* Configuration -- see 00README for details */

/* Fairly important stuff */

#define OptimizationLevel -O4
#define DoWall NO

#define BuildShared YES
#define StaticLink YES

#define BuildGL YES


/* Less Important or System Specific */

#define HaveStrerror YES
#define HaveSnprintf YES
#define HaveFloatH YES
#define DoOptimize YES
#define BuildDemos NO

#define DebugSymbols YES


/*
* You should only define this if you're running a 64 bit compile
* environment on Solaris.
*/

#define Solaris64Bit NO


/* Out in the Tall Weeds */

#define InstallNonstandard NO
#define XFormsNonstandardInstallDir /usr/local

#define NonstandardXpm NO

#define XpmIncLoc /usr/local/include
#define XpmLibLoc /usr/local/lib

#define NonstandardTiff NO

#define TiffIncLoc /usr/local/include
#define TiffLibLoc /usr/local/lib

#define NonstandardJpeg NO

#define JpegIncLoc /usr/local/include
#define JpegLibLoc /usr/local/lib

######################################################################
# #
# Move along. Nothing to see now. Move along. #
# #
######################################################################

... but have no clue...
 
Old 07-27-2003, 05:29 PM   #21
Karin
LQ Newbie
 
Registered: Jul 2003
Location: Holland
Distribution: Red Hat 7.3
Posts: 26

Original Poster
Rep: Reputation: 15
still have no clue
 
Old 07-28-2003, 01:58 AM   #22
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
(Note: After reading the README from the site where you got that tarball:
http://savannah.nongnu.org/download/...1.0/README-1.0
It would appear that after editing the Imakefile you'd then type:
xmkmf -a
If your version of xmkmf doesn't support the -a option then you would type instead:
xmkmf
make Makefiles
make includes
make depend
And after it all finishes, then run:
make
make install
And then
make install.man

But, read on...)

Alright, so I just did a little bit of studying on Lyx, try the following:

Grab this:
ftp://ftp.lyx.org/pub/lyx/contrib/xf...elease.src.rpm
It's the source rpm for xforms, then in the directory where you download that to type this:
rpm --rebuild xforms-1.0-release.src.rpm
When it's finished it will tell you where it has placed the binary RPM, go there and install the binary RPM with:
rpm -Uvh xforms-1.0.rpm (or whatever the final name is)

Then grab this:
ftp://ftp.lyx.org/pub/lyx/stable/lyx-1.3.2.tar.gz (which you already have I believe?) and compile and install it after installing the above package.
The alternative to grabbing this source and installing from it is to use:
ftp://ftp.lyx.org/pub/lyx/bin/1.3.2/...2-1_qt.src.rpm
And run it as you did with the above file:
rpm --rebuild lyx-1.3.2-1_qt.src.rpm
And then when it's finished use the file it creates and install as instructed above.

HTH

Cool
 
Old 07-28-2003, 08:19 AM   #23
Karin
LQ Newbie
 
Registered: Jul 2003
Location: Holland
Distribution: Red Hat 7.3
Posts: 26

Original Poster
Rep: Reputation: 15


after downloading xforms-1.0-release.src.rpm
and rpm --rebuild xforms-1.0-release.src.rpm:


make[1]: Leaving directory `/usr/src/redhat/BUILD/xforms-1.0-release/fd2ps'
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.94830
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd xforms-1.0-release
+ rm -rf /var/tmp/xforms-buildroot
+ %makeinstall_std DESTDIR=/var/tmp/xforms-buildroot OWNER=0 GROUP=0
/var/tmp/rpm-tmp.94830: fg: no job control
error: Bad exit status from /var/tmp/rpm-tmp.94830 (%install)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.94830 (%install)
 
Old 07-28-2003, 08:24 AM   #24
Karin
LQ Newbie
 
Registered: Jul 2003
Location: Holland
Distribution: Red Hat 7.3
Posts: 26

Original Poster
Rep: Reputation: 15


after downloading xforms-1.0-release.src.rpm
and rpm --rebuild xforms-1.0-release.src.rpm:


make[1]: Leaving directory `/usr/src/redhat/BUILD/xforms-1.0-release/fd2ps'
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.94830
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd xforms-1.0-release
+ rm -rf /var/tmp/xforms-buildroot
+ %makeinstall_std DESTDIR=/var/tmp/xforms-buildroot OWNER=0 GROUP=0
/var/tmp/rpm-tmp.94830: fg: no job control
error: Bad exit status from /var/tmp/rpm-tmp.94830 (%install)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.94830 (%install)
 
Old 07-28-2003, 10:56 AM   #25
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Whew, we are on a roll!!!

I grabbed the tarball:
http://savannah.nongnu.org/download/...rms-1.0.tar.gz

And here we go:
Untar that bad boy. It will create a directory, cd into that directory:
cd xforms-1.0
Edit the Imakefile if you need to, I suggest changing O4 to O2 or O3 probably O2 for ease. Then type:
xmkmf -a
Sit back and wait for it to finish, if you get errors from that, post em up.

Once it's done, then type:
make
If you get errors from that, post em up.

Finally, if all that went well, let's install that puppy:
make install
And:
make install.man

Once that's done, go back to lyx and give that bad boy a try

Post up any errors you get along the way.

Cool
 
Old 07-28-2003, 04:30 PM   #26
Karin
LQ Newbie
 
Registered: Jul 2003
Location: Holland
Distribution: Red Hat 7.3
Posts: 26

Original Poster
Rep: Reputation: 15
*kiss* No errors!!

Thank you so much!

can you explane me about: xmkmf -a??
 
Old 07-28-2003, 04:47 PM   #27
Karin
LQ Newbie
 
Registered: Jul 2003
Location: Holland
Distribution: Red Hat 7.3
Posts: 26

Original Poster
Rep: Reputation: 15
Oh no, I thanked you to soon, I got another error:

after lyx &:

lyx: error while loading shared libraries: libflimage.so.1: cannot open shared object file: No such file or directory
 
Old 07-29-2003, 02:05 AM   #28
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Whoa! We are getting somewhere though, that's good

Let's try the easy route first. As root type:
updatedb &&
ldconfig

And sit back until it's finished. When it's done try running:
lyx
Again. If you recieve the same error try this:
locate libflimage

If it returns a location GREAT! Jot down the location, then open up:
/etc/ld.so.conf
In a text editor. Add that location to the very bottom of the file, so for example let's say the file was at /usr/local/lib/libflimage.so.1 then you'll wanna add:
/usr/local/lib
To the bottom of that file, as the last line. Then, save and exit, and rerun:
ldconfig
After it's finished, try starting lyx again. Post up any errors you get.

Cool
 
Old 07-29-2003, 02:06 AM   #29
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
From the very top of the man page on xmkmf:
Quote:
xmkmf - create a Makefile from an Imakefile


For more info on it you can check out the man page:
man xmkmf

Cool
 
Old 07-29-2003, 05:22 AM   #30
Karin
LQ Newbie
 
Registered: Jul 2003
Location: Holland
Distribution: Red Hat 7.3
Posts: 26

Original Poster
Rep: Reputation: 15
updatedb &&
> idconfig
bash: updatedb: command not found

locate libflimage
bash: locate: command not found
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LyX and LyX-CJK wushan Linux - Software 0 07-27-2005 11:15 PM
Installing Lyx. Baix Linux - Software 3 02-23-2005 12:54 AM
Lyx printing problem drwolfson Linux - Software 0 10-07-2004 10:59 AM
Lyx font path problem? newbix Linux - Software 0 07-04-2004 02:33 PM
installing lyx on knoppix abd_bela Debian 2 06-01-2004 01:27 PM


All times are GMT -5. The time now is 04:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration