LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-11-2004, 04:07 AM   #1
stumblefingers
LQ Newbie
 
Registered: Apr 2004
Posts: 21

Rep: Reputation: 15
palm pilot and serial port not seen - how to fix?


I've installed jpilot and want to use it with a Palm Pilot Professional which connects to my pc viaa serial cable.

But when I run sync I get

******************************
synching on device /dev/pilot
Press the HotSynch button now
***************************

pi bind No such file or directory
Check your serial port and settings

Exiting with status SYNC_ERROR_BIND


I'm using Mandrake 10 and can't find out how to configure the serial port.

Anybody able to point me in the right direction to sort this out?


S
 
Old 06-04-2004, 07:40 AM   #2
Baryonic Being
Member
 
Registered: Mar 2004
Distribution: Arch
Posts: 139

Rep: Reputation: 15
I get exactly the same message with my Tungsten T3 (connecting via USB). I haven't a clue how to sort it out and I would also appreciate some help.
 
Old 06-04-2004, 08:45 AM   #3
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
Nice thing that you guys use jpilot (I never been successful using gnome-pilot). As root type (while pressing HotSync button):

tail -f /var/log/messages

And see what's the ouput and post it here. For USB I use /dev/ttyUSB1 and I think for the serial port I think it is /dev/ttyS1 (but it depends on the output of your tail -f /var/log/messages). I use Sony Clie instead. The /dev/pilot is not there yet, you have to create it, but I think just /dev/ttyUSB1 is fine.

Also take a look at my post here: http://www.linuxquestions.org/questi...highlight=clie

Last edited by chii-chan; 06-04-2004 at 08:53 AM.
 
Old 06-05-2004, 12:14 AM   #4
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
stumblefingers: I'll assume you are plugging your cable into the first serial port. This would correspond to /dev/ttyS0. You have two choices at this point with JPilot. Configure JPilot (through one of the menus) to use /dev/ttyS0 instead of /dev/pilot -OR- create a sym link for /dev/pilot. To do this, as root, type in a terminal

ln -s /dev/ttyS0 /dev/pilot

Also, if you want someone other than root to be able to sync your palm pilot, you must make sure that the permissions on ttyS0 allow others users to read and write...

ls -al /dev/ttyS0

If the resulting entry lists ttyS0 as either not readable or writeable for users other than the owner, use the following command (again as root) to change the permissions...

chmod 666 /dev/ttyS0

Baryonic: technically speaking, you should be able to substitude /dev/ttyUSB0 (or 1) for /dev/ttyS0, but I never have managed to get syncing to work correctly using a USB cable. One tip I could give you is that I have heard that you need to initiate the sync first on your device and then in JPilot for it to work successfully. Never tried it as I have it working via serial cable and just never cared to futz around with it again.
 
Old 06-05-2004, 06:20 AM   #5
Baryonic Being
Member
 
Registered: Mar 2004
Distribution: Arch
Posts: 139

Rep: Reputation: 15
For myself, the tail command gives this output:

Jun 5 11:00:00 tux CRON[7312]: (root) CMD (rm -f /var/spool/cron/lastrun/cron.hourly)
Jun 5 11:10:00 tux CRON[22003]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Jun 5 11:11:41 tux su(pam_unix)[22017]: session opened for user root by (uid=1000)
Jun 5 11:11:41 tux su(pam_unix)[22017]: session closed for user root
Jun 5 11:11:41 tux su(pam_unix)[22021]: session opened for user root by (uid=1000)
Jun 5 11:14:41 tux su(pam_unix)[22055]: session opened for user root by (uid=1000)
Jun 5 11:15:15 tux su(pam_unix)[22064]: session opened for user root by (uid=1000)
Jun 5 11:15:15 tux su(pam_unix)[22064]: session closed for user root
Jun 5 11:15:15 tux su(pam_unix)[22068]: session opened for user root by (uid=1000)
Jun 5 11:15:54 tux usb 2-2: new full speed USB device using address 3

It may seem silly to bring this up now, but I have heard that the 'usbserial' and 'visor' kernel modules need to be 'compiled in' to the kernel. I don't remember doing such a thing when I installed Gentoo Linux, but does the solution involve re-compiling the kernel, and how difficult is that to do?
 
Old 06-05-2004, 01:51 PM   #6
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
Baryonic: I can't really comment on what additional modules need to be compiled into the kernel. There may be some truth to what you suggest -- I'll let someone else who has gotten it to work via USB add to the discussion. As for recompiling a kernel, there are lots of good guides (both here on LQ and elsewhere on the net) to help you through your first kernel compile. My only suggestion would be to make sure you keep your old kernel around before trying to compile a new one (even if it is the same kernel source with the new modules added). This way you can play around with the new kernel until you get it working correctly. It probably took at least 3 or 4 times before I got everything "right". Good luck.
 
Old 06-07-2004, 05:22 AM   #7
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
I've mentioned the additional modules that need to be included in kernel compilation in the link in previous posting.
 
Old 06-07-2004, 03:29 PM   #8
Baryonic Being
Member
 
Registered: Mar 2004
Distribution: Arch
Posts: 139

Rep: Reputation: 15
Well, I'm actually not too keen on the idea of recompiling my kernel. I've got everything else on my system working just fine and I don't feel too confident about fiddling with it now. But thank you for your help.
 
Old 06-09-2004, 02:03 PM   #9
stumblefingers
LQ Newbie
 
Registered: Apr 2004
Posts: 21

Original Poster
Rep: Reputation: 15
Re: palm pilot and serial port not seen - how to fix?

Quote:
Originally posted by stumblefingers
I've installed jpilot and want to use it with a Palm Pilot Professional which connects to my pc viaa serial cable.

But when I run sync I get

******************************
synching on device /dev/pilot
Press the HotSynch button now
***************************

pi bind No such file or directory
Check your serial port and settings

Exiting with status SYNC_ERROR_BIND


I'm using Mandrake 10 and can't find out how to configure the serial port.

Anybody able to point me in the right direction to sort this out?


S
Below is the fix I got from another forum:

"/dev/pilot is not a real port, it's just a link to the real serial port.

See section 2.4 of the jpilot manual:

http://www.henrikbecker.de/jpilot/jp...nual-en-2.html

"Firstly you probably need to make a soft link to an actual /dev/ttyS. So you need a commandline like:

ln -s /dev/ttyS0 /dev/pilot"

After doing that it now works fine.

Stumblefingers

Then to test it there are some other tools:

stty is the most useful. tells you the port settings etc."
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Palm wont sync on serial port sirius57 Linux - Hardware 4 01-20-2005 12:38 PM
Can't get Belkin USB-Serial adapter to work for synchronizing palm pilot dmk2000 Linux - Hardware 1 11-05-2004 02:46 PM
Palm Pilot mikedelo Linux - Software 4 04-15-2004 11:17 PM
Palm Pilot not found DavidIanWarren Linux - Laptop and Netbook 0 03-09-2004 05:23 PM
Palm Pilot jd300 Linux - Newbie 1 10-02-2002 09:29 PM


All times are GMT -5. The time now is 09:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration