LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-11-2007, 12:36 AM   #1
ctlee
LQ Newbie
 
Registered: Mar 2007
Posts: 5

Rep: Reputation: 0
No sound using Slackware 11 and KDE


I have recently installed Slackware 11 on my machine and I have been able to get everything to work except for the sound.

I get the following 2 errors all the time:


Error #1:

artsmessage
Sound server fatal error:
cpu overload, aborting

Error #2:

aRts had to restart!


I have tried to use alsaconf and it detects my sound card (Creative Labs SB Audigy [rev 03] ) and then says it is configured.

After that, it says "Now ALSA is ready to use. For adjustment of volumes, use your favorite mixer."

My sound still does not work after this. Does anyone know how to go about fixing this problem?
 
Old 03-11-2007, 01:52 AM   #2
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 32
1. Add your user to the audio group.

2. Use alsamixer or kmix and set your volumes / unmute all applicable settings.

3. You may have the wrong server selected for aRTS. So go to the KDE Control Center > Sound and Multimedia > Sound System > Hardware tab. Be sure to choose ALSA (abbr) from the drop down list of audio devices. The default setting is 'Autodetect' and this may be the problem.
 
Old 03-11-2007, 12:39 PM   #3
ctlee
LQ Newbie
 
Registered: Mar 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Still no luck...

I opened the Konsole, changed to root, and entered this command to add me to the audio group:

usermod -g audio username

I made sure that the volume was not muted in the mixer.

I also chose ALSA from the list of audio devices in the Sound System's Hardware tab.


Any other suggestions?
 
Old 03-11-2007, 12:44 PM   #4
ctlee
LQ Newbie
 
Registered: Mar 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Oops... One more thing..

I did notice that it had changed the Sound System Hardware to "Autodetect".

If I try to change this to ALSA, it has a progress bar and above it, it says Starting Sound System.

I get Error #1 from the first post about 3 or 4 times during this progress and then, when it gets to 90%, it jumps back down to the beginning of the progress bar. It continues this over and over...
 
Old 03-12-2007, 11:58 PM   #5
ctlee
LQ Newbie
 
Registered: Mar 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Found my problem...

Okay I finally found my problem!!

I have an on-board sound card on my motherboard. All I had to do was disable the on-board sound on my motherboard.

Yay! Listening to music now!
 
Old 03-22-2007, 07:14 PM   #6
danne123
Member
 
Registered: Apr 2006
Distribution: Slackware 11.0, Gentoo 2006.1
Posts: 102

Rep: Reputation: 17
Quote:
Originally Posted by ctlee
Okay I finally found my problem!!

I have an on-board sound card on my motherboard. All I had to do was disable the on-board sound on my motherboard.

Yay! Listening to music now!

How did you find out that you had a on-board soundcard on your motherboard? And how did you disable it?
 
Old 03-26-2007, 10:42 PM   #7
ctlee
LQ Newbie
 
Registered: Mar 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Well, I knew that I had on-board sound on my motherboard since I bought it when I built the computer. I just didn't know that I was going to have to disable it in order for my sound to work with another sound card.

In order to disable it, I went into the BIOS configuration (when booting the computer) and there is a Peripheral section within the configuration. It is in the Peripheral configuration that I was able to enable or disable the on-board sound on the motherboard.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
non-kde sound in Slackware 10.1 thanto_ Linux - Software 18 06-17-2005 04:12 AM
slackware 10 and modest kde sound issue aus9 Slackware 1 07-03-2004 09:59 PM
no sound in KDE 3.1 SLackware 9.1 KT600 derfunkenstein Linux - Hardware 5 04-20-2004 10:15 PM
sound error in kde 3.1 / slackware 9 filiond Linux - Software 5 04-08-2003 09:30 AM
Slackware 8 sound in KDE php Linux - General 5 03-04-2002 12:36 PM


All times are GMT -5. The time now is 02:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration