LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-07-2006, 08:49 AM   #1
flatracer
LQ Newbie
 
Registered: Apr 2006
Posts: 7

Rep: Reputation: 0
No cursor in KDE


After getting Mandriva 2007 to install, I ran into a couple of problems. The first being caused by me not checking the screen resolution at the end of the install. When I booted, I couldn't see anything because the resolution and refresh rate were not compatible with my monitor. I fixed that, but noticed that there is no cursor when KDE starts. If you move the mouse, and it moves over a button, the button will highlight, but there is no cursor, it invisible. Also, when a window opens, the little clock that shows KDE is working on a command is visible, but goes away when completed. Has anyone else run into this problem? I'm wondering if I'll have to do another install the fix this. Any help will be greatly appreciated.
 
Old 12-07-2006, 08:59 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
If you can get into the Kde Control Center, click on Peripherals - Mouse and try to configure it.

From the keyboard, with the Kde menu displayed, use the up and down arrow keys to select menu items, then press enter.

Last edited by bigrigdriver; 12-07-2006 at 09:01 AM.
 
Old 12-07-2006, 11:28 AM   #3
flatracer
LQ Newbie
 
Registered: Apr 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Tried everything I could in KDE, but no luck. Kind of difficult to see where the cursor is, and the arrow keys don't always move the cursor depending on the menu presented.
 
Old 12-07-2006, 11:57 AM   #4
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware-current, Cross Linux from Scratch, Gentoo
Posts: 2,812
Blog Entries: 1

Rep: Reputation: 259Reputation: 259Reputation: 259
Bet ya' a nickel you have an nVidia GPU. It's a known bug, but apparently not well known. It doesn't matter whether you use the 'nv' or the 'nvidia' drivers. It's an easy fix though.

  • Open a root terminal session or change to the root account from a standard terminal session.
  • Edit the X Windows configuration file.
Code:
root@weibullone ~ # nano -w /etc/X11/xorg.conf
  • Revise the "Device" section as follows:
Code:
Section"Device"
	Identifier  "Videocard0"
	Driver      "nv"
	VendorName  "Videocard vendor"
	BoardName   "nVidia Corporation C51 PCI Express Bridge"
	## See RedHat Bug #182517
	Option      "HWCursor" "off"
	EndSection
  • Save the file and exit nano (or whatever you use).
  • Log out and log back in. Your mouse pointer should be restored.

Note: If you have this fix in place and install Compiz/XGL, you'll find that the mouse pointer disappears. Reverse this fix under Compiz/XGL.
 
Old 12-08-2006, 10:50 AM   #5
flatracer
LQ Newbie
 
Registered: Apr 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Arow,
Thanks for the the responce. I tried your suggestion, but no luck. I edited the file but still have no cursor. The funny thing is that in KMag, there is a cursor.

This is getting a little frustrating, but I guess I'll keep plodding along. The upside is I'm getting good at navigating the Desktop without a cursor. Sort of like Blind Mans Bluff.
 
Old 12-08-2006, 12:33 PM   #6
flatracer
LQ Newbie
 
Registered: Apr 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Arow
After the second reboot, the cursor came up. Many thanks for the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disabling icons next to cursor in KDE stonehurstX11 Linux - Newbie 2 01-15-2006 06:34 PM
KDE 3.2 Loading Cursor dave_starsky Linux - General 1 06-04-2004 02:49 PM
kde 3.1 cursor flaky - disappears hooya27 Mandriva 3 04-17-2004 03:41 PM
kde editors cursor snafu bulliver Linux - Software 2 07-27-2003 06:38 AM
KDE Little Black Cursor davecs Linux - Software 0 05-14-2003 05:49 PM


All times are GMT -5. The time now is 03:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration