LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-08-2007, 08:04 PM   #1
mz043
LQ Newbie
 
Registered: Mar 2007
Distribution: SuSe10.2, Gentoo 2006.1
Posts: 7

Rep: Reputation: 0
Need some help with gentoo


Hi all,

First of all I apologise if I'm posting in the wrong place --- I searched in distros and couldn't find gentoo. Second, I'm new to linux so probably the answers to my questions are obvious to you guys!

Ok, I recently installed openSuSe on my PC, works like a dream, no real problems there. Today I thought to be a bit ambitious and tried and installed gentoo on my laptop just to see what another distro is like. Now I 'm a bit overwhelmed, think I was a little over-ambitious

I have the following questions:

1. ACPI
I installed the kernel with the "gentoo acpi=on" option. Is there any way to check that I have acpi installed correctly with the appropriate options? I gather it is quite important, and any mistake can fry the hardware on the laptop that's why it's top of my list.

2. Change from GNOME to KDE
How do I do this? I want KDE as my default desktop to start every time the computer starts. I tried "switchdesk" or "startkde &" but neither work. There must be some conf file that I have to change -- does anybody know where this is and what changes do I have to make?

3. Sound card not working
The sound card on my laptop is Integrated Intel Chipset AD1881A - ICH 3, but it is not working. Do you know a solution to this? (not really important but would be nice to have sound).

4. (optional) What is the equivalent to Yast in Gnome?
How do I install additional packages in GNOME?

Any additional advice you might have for somebody like me who is not a computer genius and new (but very keen to learn more) to linux is very welcome.

Thank you so much.
Michael
 
Old 04-08-2007, 08:58 PM   #2
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
1. Depends on if you built the kernel manually or via genkernel. If you built it manually you could have enabled ACPI ... genkernel might have enabled it.
Try this:
Code:
# zcat /proc/.config.gz | grep -i acpi
2. If you are not using XDM/KDM/GDM then your .xinitrc file will define the Window Manager. Example, to use KDE your .xinitrc file should have "exec startkde" in it.

3. You would have to check to see if you have kernel/module support for your card:
Code:
#  zcat /proc/.config.gz | grep -i intel8x
4. With Gentoo you install all applications using Portage. ie. emerge xxxxx


Note: most of your questions could be found by looking at some of the Gentoo Documents.
One of the strongest things I found out about Gentoo is it's documentation ... including the Gentoo Wiki.

Last edited by dxqcanada; 04-08-2007 at 09:07 PM.
 
Old 04-10-2007, 08:38 AM   #3
mz043
LQ Newbie
 
Registered: Mar 2007
Distribution: SuSe10.2, Gentoo 2006.1
Posts: 7

Original Poster
Rep: Reputation: 0
Thumbs up Thanks

Thanks for your help. Turns out I had acpi enabled, also added acpid so it runs automatically at boot. I am using GDM, so compiling kde now (using Portage, which looks great).

Sound card...haven't cracked that yet, but its in the config file, checked out a forum that was saying to check lpsci (or something like that) and my soundcard looks fine there. I will crack that too (wish I had more time).

But gentoo is cool, i think i prefer it than SuSe.

Anyway, just want to say thanks!

/Michael
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xp/gentoo dual boot , gentoo on usb external hard drive gentoo2006 Linux - Laptop and Netbook 2 09-16-2007 12:55 PM
Gentoo live cd will not mount /dev/hdc on HP Omnibook xe3 (Gentoo 2006.0.0) tommygoober Linux - Software 3 03-16-2007 07:51 AM
How do I start installing stage 3 of gentoo from universal gentoo 2005-1? kazuya1977 Linux - General 1 11-11-2005 11:30 AM
pkg-config error with emerge -aD gnome-python on Gentoo 2.6.9-gentoo-r6 ghrellin Linux - Software 2 12-22-2004 07:37 PM
Dual boot w/ Gentoo/xp pro vs. gentoo-invalid partition table bobbear Linux - Software 3 02-10-2004 05:28 PM


All times are GMT -5. The time now is 12:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration