LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-02-2013, 11:23 PM   #1
ravindert
Member
 
Registered: Oct 2011
Posts: 68

Rep: Reputation: Disabled
mysql GLIBC error


Hi ,

I have running with the old version of the redhat version 2.1 Derry . Currently mysql version (mysql-3.23.58-1.72) is installed and running on the server .

To take the backup of the server from data protector we install its agent on the server and getting below error after the require data protector agent successfully installed saying GLIC_2.3 not found.

[root@vfaul063 cron.d]# telnet localhost 5555
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
inet: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by inet)
Connection closed by foreign host.

So can you please suggest me what if i will installed glibc_2.3 version ?? Will it impact the currently running mysql with GLIBC_2.2??

Below are the further detail of mysql dependencies on GLIB :

[root@vfaul063 cron.d]# rpm -qR mysql
/sbin/ldconfig
/sbin/install-info
grep
fileutils
chkconfig
bash >= 2
/bin/sh
/bin/sh
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
/bin/sh
/usr/bin/perl
libcrypt.so.1
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.2)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.2)
libm.so.6
libm.so.6(GLIBC_2.0)
libmysqlclient.so.10
libncurses.so.5
libnsl.so.1
libpthread.so.0
libpthread.so.0(GLIBC_2.0)
libpthread.so.0(GLIBC_2.1)
libpthread.so.0(GLIBC_2.2)
libreadline.so.4
libstdc++-libc6.2-2.so.3
libz.so.1
[root@vfaul063 cron.d]#

Last edited by ravindert; 07-03-2013 at 01:55 AM.
 
Old 07-03-2013, 04:03 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Glibc is one of the core packages of any Linux system and cannot be replaced.

I would recommend to stop using a Linux version that is 10 years old. Besides using old versions of programs, which in some cases cannot be upgraded, it also doesn't have any kind of support and has become a security risk.

The mysql version you mention (3.23) has also reached end-of-life a while ago (as of december 2010).

Bottom line: Upgrade to recent versions and keep them updated.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
glibc Dependency Issue siwelb Red Hat 2 09-11-2009 03:38 PM
Kernel<->GLIBC dependency question storkus Linux - Kernel 5 12-17-2008 04:33 AM
glibc dependency problem giovannym Linux - Newbie 4 07-14-2005 05:48 AM
Package dependency problem (glibc) jizlobber Linux - Newbie 1 10-08-2003 03:54 PM
glibc-common dependency blues... sylk Linux - Software 4 09-19-2003 08:08 PM


All times are GMT -5. The time now is 03:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration