LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-13-2005, 06:06 PM   #1
giovannym
LQ Newbie
 
Registered: Jun 2004
Location: Fontana, California
Distribution: RHEL
Posts: 22

Rep: Reputation: 15
Question glibc dependency problem


hello everyone,

I have a problem that I can't figure out. I'm trying to update my glibc package to at least glibc-2.3.4-2.9. Currently I have the following:


[root@sandbox oracle]# rpm -qa | grep -i glibc
glibc-2.3.4-2
glibc-kernheaders-2.4-9.1.87
glibc-common-2.3.4-2
glibc-headers-2.3.4-2
compat-glibc-6.2-2.1.3.2
glibc-devel-2.3.4-2

I downloaded the glibc that I needed and tried to install it as follows:

[root@sandbox oracle]# rpm -Uvh glibc-common-2.3.4-2.9.i386.rpm
error: Failed dependencies:
glibc-common = 2.3.4-2 is needed by (installed) glibc-2.3.4-2.i386


I figured, fine, I'll download the other one to satisfy the dependencies. However, when I tried to install the dependency I got the following:

[root@sandbox oracle]# rpm -Uvh glibc-2.3.4-2.9.i386.rpm
error: Failed dependencies:
glibc-common = 2.3.4-2.9 is needed by glibc-2.3.4-2.9.i386


So, they need each other. What should I do in this case? I'm fairly new so I'm not sure. Should I just force it? What do you guys suggest?

Thanks
 
Old 07-13-2005, 06:44 PM   #2
giovannym
LQ Newbie
 
Registered: Jun 2004
Location: Fontana, California
Distribution: RHEL
Posts: 22

Original Poster
Rep: Reputation: 15
got it

Just wanted to let you guys know I just forced it and it seems to work. I did:

[root@sandbox oracle]# rpm -Uvh --nodeps --force glibc-2.3.4-2.9.i386.rpm
Preparing... ########################################### [100%]
1:glibc ########################################### [100%]
Stopping sshd:[ OK ]
Starting sshd:[ OK ]
[root@sandbox oracle]# rpm -Uvh glibc-common-2.3.4-2.9.i386.rpm
Preparing... ########################################### [100%]
1:glibc-common ########################################### [100%]
[root@sandbox oracle]#

since, the new glibc needed a newer version of glibc-common, and the newer version of glibc-common was
held to the older version of glibc I was in a cycle. I just forced them since they were the only dependencies of each other. Everything seems to work. fine..
 
Old 07-13-2005, 08:30 PM   #3
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,158

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
You probably didn't need to --force the upgrade (and doingso with a package as critical as glibc can be very dangerous). You should just need to specify both packages as arguments and RPM will figure out that you're resolving all dependencies.
 
Old 07-14-2005, 04:27 AM   #4
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
upgrading glibc is a huge issue
you will now have to rebuild just about everything on you system after you figure out what user space kernel headers to use or you will have *this program has performed an illegal operation syndrom*
like you were back at Redmon
the fact that you could do this with rpms is one of the reasons rpm sucks so badly
 
Old 07-14-2005, 05:48 AM   #5
Harmaa Kettu
Member
 
Registered: Apr 2005
Location: Finland
Posts: 196

Rep: Reputation: 30
Quote:
upgrading glibc is a huge issue
you will now have to rebuild just about everything on you system after you figure out what user space kernel headers to use or you will have *this program has performed an illegal operation syndrom*
Not true. Different 2.3.* versions of glibc are binary compatible, upgrading shouldn't cause any problems. The same is true for most other libraries as well, as long as the first two parts of the version number are same, no problem. Bigger updates (like glibc 2.2 to 2.3) are another story.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem installing glibc-2.3.2-4.80.i686, glibc-common-2.3.2-4.80.8.i386.rpm martianpackets Red Hat 8 05-01-2009 04:22 PM
dependency problem canyon289 Linux - Software 3 11-23-2004 02:03 AM
how to solve failed dependency when dependency exists dwcramer Linux - Newbie 2 08-24-2004 10:03 PM
Package dependency problem (glibc) jizlobber Linux - Newbie 1 10-08-2003 03:54 PM
glibc-common dependency blues... sylk Linux - Software 4 09-19-2003 08:08 PM


All times are GMT -5. The time now is 06:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration