Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Red Hat This forum is for the discussion of Red Hat Linux.


  Search this Thread
Old 09-11-2009, 01:50 PM   #1
LQ Newbie
Registered: Sep 2009
Posts: 2

Rep: Reputation: 0
glibc Dependency Issue

I am attempting to install glibc-2.5.34.i386.rpm on RHEL 5 (necessary in order to install gcc, which in turn is needed to install Apache server). I mounted the RHEL 5 iso to /mnt and copied over the relevant RPM files to a separate directory). When I run rpm -ivh glibc-2.5-34.i386.rpm I am getting a dependency error stating the following:

error: Failed dependencies: glibc-common = 2.5-34 is need by glibc-2.5-34.i386
Okay, so I grabbed the glibc-common RPM from the RPM fiinder site and ran rpm -ivh on it. However, it complains that I have a newer version of glibc-common package installed (2.5-34.el5_3.1.i386) and then spits out a bunch of lines about conflicting files. So is there a way to somehow uninstall or rollback glibc-common to version 2.5-34 so that I can go ahead with the install of glibc?

Btw, I cannot use yum due to network connectivity issues.
Old 09-11-2009, 02:25 PM   #2
LQ 5k Club
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152
Welcome to LQ.

Touching the glibc packages manually isn't recommended.
Most often applies for a reinstall of the OS.

But if you are lucky, these should be usable ( latast updates.)

The update mirror ( EL5, free version = CentOS 5.3 )
Apache = httpd-2.2.3-22.el5.centos.1.i386.rpm is also in 'update'.
glibc-2.5-34.el5_3.1.i386.rpm		15-Aug-2009 14:01 	4.4M
glibc-2.5-34.el5_3.1.i686.rpm		15-Aug-2009 14:01 	5.2M
glibc-common-2.5-34.el5_3.1.i386.rpm	15-Aug-2009 14:01 	16M
glibc-devel-2.5-34.el5_3.1.i386.rpm	15-Aug-2009 14:01 	2.0M
glibc-headers-2.5-34.el5_3.1.i386.rpm	15-Aug-2009 14:01 	598K
glibc-utils-2.5-34.el5_3.1.i386.rpm	15-Aug-2009 14:01 	127K
All other packages

Last edited by knudfl; 09-11-2009 at 02:38 PM.
Old 09-11-2009, 02:38 PM   #3
Registered: Jul 2003
Location: Miami, Florida, USA
Distribution: Debian
Posts: 848
Blog Entries: 1

Rep: Reputation: 47
glibc is impossible to install unless you do it with a rescue CD; and even then it is not recommended. glibc is the heart of the OS. It is the general C libraries. Like 90% of all programs depend on it. It is better to just upgrade to OS.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel<->GLIBC dependency question storkus Linux - Kernel 5 12-17-2008 03:33 AM
glibc - gconv / iconv / locale dependency question onanisland Linux - Software 0 09-17-2006 07:32 PM
glibc dependency problem giovannym Linux - Newbie 4 07-14-2005 04:48 AM
Package dependency problem (glibc) jizlobber Linux - Newbie 1 10-08-2003 02:54 PM
glibc-common dependency blues... sylk Linux - Software 4 09-19-2003 07:08 PM

All times are GMT -5. The time now is 05:47 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration