LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-31-2005, 10:12 PM   #16
sonic04002
Member
 
Registered: Oct 2005
Posts: 143

Original Poster
Rep: Reputation: 15

I just read that you wanted me to change the fstab stuff, and i tried and it won't let me delete or add anything...
 
Old 10-31-2005, 10:30 PM   #17
BoldKiller
Member
 
Registered: Apr 2002
Location: Montreal, Quebec
Distribution: Debian, Gentoo, RedHat
Posts: 142

Rep: Reputation: 15
You need to be root in order to change fstab.
type "su" to become root.

By the way, you should post complete error messages. Simply saying it does not work will not allow us to help you to the best of our ability!
 
Old 10-31-2005, 10:48 PM   #18
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
you don't necessarily need to change the fstab. that was just a suggestion.


here's the root of the problem
/dev/cdrom/ is not a directory, it contains nothing: no files, no data.
/dev/cdrom is a driver. all the files in the cdrom are located in its mountpoint




looks like a lesson in the unix mount system is in store....
some background on the fstab: "file system table"
All devices in the unix system exist as files that are located in a directory called /dev. In order to build the unix file system, we need to make mount points, or places where we attach the device "drivers" to the unix file tree. You can specify any device to any mountpoint that you want (except for the root file harddrive, that must be located at mountpoint /) The /etc/fstab configuration file is actually relatively simple:

one of your fstab lines looked like this:
Code:
/dev/hdc /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
the first entry, on a line /dev/hdc is the device file that you want to mount. the second field on this line, /media/cdrecorder is the mountpoint. In order for the device to be mounted, the mount point MUST EXIST. the third field, yours is labeled "auto" is the file-system type. auto is ok, but I would suggest labeling this iso9660, which directly specifies it as a jolliet filesystem (cdrom iso). the fourth field, "pamconsole,exec,noauto,managed" are your user flags. This field tells which users or groups can mount/unmount the device. This section also contains the read-only or read/write flags for the device. The final two fields "0 0" represent the dump command and reboot checkup respectively. DON'T SCREW AROUND WITH THOSE. So, what we've learned by this little history lesson is that the fstab has shown you that your cdrom device /dev/hdc is being mounted at the mountpoint /media/cdrecorder. All files on the cdrom can be found in this directory when the device is mounted
 
Old 11-01-2005, 10:57 AM   #19
sonic04002
Member
 
Registered: Oct 2005
Posts: 143

Original Poster
Rep: Reputation: 15
So basicly it I need to change the auto thing in my fstab. And also when I tried changing the Fstab in root it still did not let me, it just opened it in a text editor but wouldn't let me acually change things. Sorry for being new to linux and posting, and thanks for the help. So after I change the fstab I should be about to mount if I put mount /dev/hdc /media/cdrecorder ? Sorry I would try it now but I am on a windows machine at school. so is that what you guys want me to do?
 
Old 11-01-2005, 01:37 PM   #20
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
***Forget I ever said to change your fstab. just
Code:
$ mount /dev/hdc
$ cd /media/cdrecorder
$ ls ./
(the $ is not to be typed into your command prompt, I just put it there to represent that you are doing this as a normal non-root user)
the files for your cdrom drive should be there. if not, then we have some other problem. Don't be sorry for being new to linux, we've all been there and done that... but once you start to learn the basics, it's one hell of an operating system!



SIDE NOTE
i'm guessing the reason why you can't manually change the fstab is b/c FC4 (I've never used it, so it's a guess) uses an external program to "dump" data into the fstab.
Code:
# This file is edited by fstab-sync - see 'man fstab-sync' for details
that's why I say that.
 
Old 11-01-2005, 01:41 PM   #21
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
I just realized why you might be thinking that you can't edit your fstab. This is a wild guess, but:

you are using the
Code:
vi /etc/fstab
command, and in order to type anything into the vi editor, you have to type the letter "i" for insert. that lets you type into the vi editor. then, in order to save, you need to press esc and type in ":wq" for write and quit.



ALSO, for anyone inquiring into this thread, I think the best way to determine what the root file for your device is would be by running:
Code:
bash$ df
I just realized that... but it would require the device to be mounted, so i guess it sorta doesn't work for this thread haha

Last edited by mrchaos; 11-02-2005 at 01:35 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to give not-root user ability to mount devices to any mount point??? jdupre Linux - General 8 02-04-2012 11:03 AM
NFS mount of smb mount of windows share: permission denied problem :( Bagatur Linux - Networking 4 07-07-2009 12:34 PM
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 08:29 PM
can mount C not D FAT: invalid media value (0x45) mount: wrong fs type, bad option Emmanuel_uk Linux - Newbie 10 11-29-2005 03:47 AM
automount: mount(generic): failed to mount (null) (type iso9660) on /mnt/media/ vasudevadas Slackware 5 10-17-2005 04:05 PM


All times are GMT -5. The time now is 12:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration