LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-30-2005, 09:06 PM   #1
sonic04002
Member
 
Registered: Oct 2005
Posts: 143

Rep: Reputation: 15
Mount CD


How do you mount a cd-rw/dvd-rw drive? I'm on fedora core 4. Thanks laters.
 
Old 10-30-2005, 10:21 PM   #2
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
post your /etc/fstab first of all.... the cdrom could be under any number of names (aka /dev/hdc, /dev/cdrom, /dev/dvd)


as for mounting, you simply run (in command prompt)
Code:
mount /dev/______
and
Code:
umount /dev/______
to unmount it
 
Old 10-30-2005, 11:07 PM   #3
gnubuddy
LQ Newbie
 
Registered: Oct 2005
Posts: 1

Rep: Reputation: 0
Quote:
Originally posted by mrchaos
post your /etc/fstab first of all.... the cdrom could be under any number of names (aka /dev/hdc, /dev/cdrom, /dev/dvd)


as for mounting, you simply run (in command prompt)
Code:
mount /dev/______
and
Code:
umount /dev/______
to unmount it
I noticed that the following often works for me:
Code:
mount /mnt/______
Code:
umount /mnt/______
of course ___ is the name of the cd already in /mnt/. Also, fyi, you might have to be logged in as root.
 
Old 10-30-2005, 11:39 PM   #4
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
yeah, the system draws a systemlink between the two when you use mount... so you can do that interchangeably
 
Old 10-31-2005, 06:13 AM   #5
sonic04002
Member
 
Registered: Oct 2005
Posts: 143

Original Poster
Rep: Reputation: 15
How do you know what the name of the drive is?
 
Old 10-31-2005, 07:54 AM   #6
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
sonic04002, post your /etc/fstab file first. we can't tell you anything until you do that.
 
Old 10-31-2005, 11:37 AM   #7
sonic04002
Member
 
Registered: Oct 2005
Posts: 143

Original Poster
Rep: Reputation: 15
How do you do that? I'm pretty new to linux.
 
Old 10-31-2005, 12:28 PM   #8
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
ok, open a terminal window (xterm or konsole works just fine), and type in:
Code:
gedit /etc/fstab
if you don't have gedit and it returns an error, type:
Code:
pico /etc/fstab
and if you don't have pico, we go to the last choice which is:
Code:
vi /etc/fstab
everyone has vi, it's the default viewer for unix systems

copy and paste the results here in this forum
 
Old 10-31-2005, 02:44 PM   #9
sonic04002
Member
 
Registered: Oct 2005
Posts: 143

Original Poster
Rep: Reputation: 15
# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hdc /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
 
Old 10-31-2005, 04:29 PM   #10
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
there you go! now to mount your cdrom, you must type in
Code:
mount /dev/hdc
and your mount point will be in /media/cdrecorder.




oh, if you don't like /dev/hdc, you can always symlink (ln -s) another device to /dev/hdc. For example, if you want to mount /dev/cdrom instead you would
Code:
ln -s /dev/hdc /dev/cdrom
then change the line in your fstab from /dev/hdc /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0 to /dev/cdrom /media/cdrecorder auto pamconsole,exec,noauto,managed





one more thing, do you only have one cd/dvd drive on your computer?
 
Old 10-31-2005, 04:56 PM   #11
alaskazimm
Member
 
Registered: Mar 2004
Location: Watching it snow in bush Alaska
Distribution: *ubuntu, Smoothwall, WinXP Pro
Posts: 126

Rep: Reputation: 15
Also, if you are just trying to use your cd-recorder to burn cds, you don't need to mount it. Just fire up your burning program (k3b, xcdroast, etc) and use it in the normal fashion. The only time you will need to mount the cd drive is if you need to read data from it or use it as an audio device. At lest I think you need to mount to listen to audio.

Hope this helps some more
 
Old 10-31-2005, 05:57 PM   #12
sonic04002
Member
 
Registered: Oct 2005
Posts: 143

Original Poster
Rep: Reputation: 15
I'm trying to install a game that i burned the iso of. I burned the iso in k3b. I tried mounting but this is what I got.


Code:
[Tai@localhost ~]$ su
Password:
[root@localhost Tai]# ln -s /dev/hdc /dev/cdrom
ln: `/dev/cdrom': File exists
[root@localhost Tai]# mount /dev/hdc
mount: block device /dev/hdc is write-protected, mounting read-only
mount: /dev/hdc already mounted or /media/cdrecorder busy
mount: according to mtab, /dev/hdc is already mounted on /media/cdrecorder
[root@localhost Tai]# umount /dev/hdc
[root@localhost Tai]# mount /dev/hdc
mount: block device /dev/hdc is write-protected, mounting read-only
[root@localhost Tai]#
 
Old 10-31-2005, 09:01 PM   #13
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
all of that is ok.
change the cdrom line of your fstab to this:
Code:
/dev/hdc        /media/cdrecorder      iso9660     users,unhide,noauto,ro   0   0
iso9660 is your standard (jolliett or whatever) cd file system.
Code:
block device /dev/hdc is write-protected, mounting read-only
this was outputted b/c the fstab did not have read-only specified nder user-flags. In the user,unhide,noauto,ro section of what I posted, the "ro" stands for read-only, and will tell the computer that you cannot actively change the data on this storage media (don't worry, k3b and nero will still work fine). I think you mounted your cd-rom correctly though. Don't expect the window to pop up like it does in windows, you actually have to cd (change directories) to /media/cdrecorder and that will be your cd-rom drive!

as for the symlink. don't worry about it, I use /dev/hdc as my default dvd-burner path... it's easier to remember
 
Old 10-31-2005, 10:04 PM   #14
sonic04002
Member
 
Registered: Oct 2005
Posts: 143

Original Poster
Rep: Reputation: 15
Well see I'm trying to access the setup.exe in one of the cds thru the terminal with Cedega. So I need to know the directories and all. It sort of worked and then it said that it could not find the file /dev/cdrom/setup.exe which is where it was. Sorry this is a pain to help me with.
 
Old 10-31-2005, 10:11 PM   #15
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
aha! cedega! so then you must have also downloaded point2play? the gui for cedega?


remember, you don't have /dev/cdrom in your fstab, so it doesn't know what to do with your request for /dev/cdrom (unless /dev/cdrom is already symlinked to your /dev/hdc) if you want to use /dev/cdrom cdrom path you will need to change /dev/hdc to /dev/cdrom in your fstab.

also, /dev/cdrom/setup.exe is not a valid path. once you have mounted the device, the work path is /media/cdrecorder/setup.exe. /dev/cdrom is a file (linux treats drivers as files) not a directory.

Last edited by mrchaos; 10-31-2005 at 10:13 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to give not-root user ability to mount devices to any mount point??? jdupre Linux - General 8 02-04-2012 11:03 AM
NFS mount of smb mount of windows share: permission denied problem :( Bagatur Linux - Networking 4 07-07-2009 12:34 PM
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 08:29 PM
can mount C not D FAT: invalid media value (0x45) mount: wrong fs type, bad option Emmanuel_uk Linux - Newbie 10 11-29-2005 03:47 AM
automount: mount(generic): failed to mount (null) (type iso9660) on /mnt/media/ vasudevadas Slackware 5 10-17-2005 04:05 PM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration