LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-12-2007, 02:22 PM   #1
BartVG
LQ Newbie
 
Registered: Sep 2007
Location: Gent, Belgium
Distribution: Slackware
Posts: 14

Rep: Reputation: 0
Keyboard mapping


Hi all,

I'm wondering where the keyboard layout is configured (roughly speaking: azerty/querty)? Is it the responsibility of the shell, X or the desktop manager? What file(s) need(s) to be configured the change from querty to azerty?
 
Old 09-13-2007, 06:20 AM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware 14.1 (32 and 64 bit)
Posts: 1,593

Rep: Reputation: 123Reputation: 123
My computer handles keyboard layout in the login shell by a script (it's Slackware, so I guess with most other machines the script is not /etc/rc.d/rc.keymap like on my machine). The important line is here "/usr/bin/loadkeys de-latin1.map" to load the German keyboard layout.

In graphical mode the X server controls which layout the keyboard has, i. e. the file /etc/X11/xorg.conf. My keyboard section to show you how it could look like for German layout:
Code:
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel"  "pc105"
        Option      "XkbLayout"  "de"
EndSection
KDE has its own stuff to handle this independently (but if you change xorg.conf correctly KDE will also have the right layout). In case you don't want to change xorg.conf look in the KDE control center for regional settings, in Gnome there should be something similar.


So changing "de" to "fr" (or whatever you want) in xorg.conf and finding and changing the console setting for your distribution (if you need azerty in login shell) should do it for you
 
Old 09-17-2007, 02:28 PM   #3
BartVG
LQ Newbie
 
Registered: Sep 2007
Location: Gent, Belgium
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
Hi-diddly-ho "Neighbour" (I'm from Belgium),

Thanks for the explanation. I uncommented the line with Xkblayout en changed "de" (which was the default, very strange) to "be". Now I'm happily typing azerty in desktop managers other than KDE.
 
Old 09-17-2007, 03:25 PM   #4
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware 14.1 (32 and 64 bit)
Posts: 1,593

Rep: Reputation: 123Reputation: 123
Fine Since I missed it in my first post: Welcome to linuxquestions.org
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
keyboard mapping xppower Linux - Kernel 6 08-09-2006 09:02 AM
Keyboard mapping cdhjrt Linux - Software 5 11-03-2005 05:29 PM
keyboard re-mapping bong.mau Linux - Software 1 10-26-2005 01:01 PM
Keyboard Mapping ZeroX-2 Slackware 4 10-02-2004 08:58 PM
keyboard mapping minike Slackware - Installation 4 09-01-2004 03:48 PM


All times are GMT -5. The time now is 08:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration