LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-02-2004, 01:53 PM   #1
ZeroX-2
LQ Newbie
 
Registered: Sep 2004
Posts: 13

Rep: Reputation: 0
Keyboard Mapping


I believe I posted a while back.

My keyboard mapping is not normal. My previous installation did not encounter this problem, seems its only this install.

Im running Slackware 10 Kernel: 2.4.26.

My keyboard mappings are incorrect for the most part. The keys A to Z work fine but If I want to do a back slash this is what happens

A list of some problematic keys would be as follows:

Orig Key My key

/ ................
\ ................
" ...............
' ................
[ ................^
]................
{................
}................

Thats just a small example.... My question marks come out as ""

Attached is my XORG.conf file if needed. Im running a Compaq keyboard model KB-9963. Its done the same thing on my HP keyboard. I dont know what else to do and at this point in time I do not want to re-install slackware.

(re-named to .txt extension for uploading purposes)

hxxp://zerosrealm.com/images/xorg.txt

Any help would be great. (board wont let me post url, replace the xx's with tt)

Last edited by ZeroX-2; 10-02-2004 at 01:56 PM.
 
Old 10-02-2004, 02:36 PM   #2
BoudewijnS
LQ Newbie
 
Registered: Oct 2004
Location: Netherlands
Distribution: Slackware
Posts: 3

Rep: Reputation: 0
I don't run X myself, so I can't make sure if what I'm saying makes any sence, but maybe you can try changing the

Option "XkbModel" "pc105"
Option "XkbLayout" "ca"

For XkbModel you could try "pc101", "pc102" or "pc104"
For XkbLayout you could try "us" or "uk"

But then again... maybe you already tried some of those options... If not, try changing the XkbLayout first...

Good luck!
 
Old 10-02-2004, 03:43 PM   #3
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
for UK english it's actually "gb" not "uk"
 
Old 10-02-2004, 05:25 PM   #4
ZeroX-2
LQ Newbie
 
Registered: Sep 2004
Posts: 13

Original Poster
Rep: Reputation: 0
I reinstalled for the hell of it.

The keyboard messes up when I config XORGCONFIG.

Before I even ran Xorgconfig I booted using startx and my keyboard was fine. Now it is messed up again...
 
Old 10-02-2004, 07:58 PM   #5
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
you are probably doing something wrong. What exactly are you changing when you run xorgconfig.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard mapping cdhjrt Linux - Software 5 11-03-2005 04:29 PM
keyboard re-mapping bong.mau Linux - Software 1 10-26-2005 12:01 PM
mapping terminal to keyboard. dr_zayus69 Linux - Hardware 2 12-17-2004 12:29 AM
keyboard mapping minike Slackware - Installation 4 09-01-2004 02:48 PM
X and keyboard mapping krajzega Slackware 1 02-24-2004 07:34 PM


All times are GMT -5. The time now is 10:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration