LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-18-2010, 06:19 AM   #1
sumeet inani
Member
 
Registered: Oct 2008
Posts: 883
Blog Entries: 26

Rep: Reputation: 47
"Invalid mount option when attempting to mount the volume." on plugging USB


I plugged in USB(single fat32 partiton of 2GB) and got message window

Cannot mount volume.
Invalid mount option when attempting to mount the volume.

I tried
# vol_id /dev/sdb1
ID_FS_USAGE=filesystem
ID_FS_TYPE=vfat
ID_FS_VERSION=FAT32
ID_FS_UUID=29AE-4380
ID_FS_UUID_ENC=29AE-4380
ID_FS_LABEL=
ID_FS_LABEL_ENC=
ID_FS_LABEL_SAFE=

Also did check in gparted , dosfsck and fsck.vfat but no errors reported.
What do you suggest ?
 
Old 01-18-2010, 06:23 AM   #2
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,591

Rep: Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244
Quote:
Originally Posted by sumeet inani View Post
Also did check in gparted , dosfsck and fsck.vfat but no errors reported.
What do you suggest ?
Try mounting it manually.

Code:
sudo mount -t vfat /dev/sdb1 /mnt
Evo2.
 
Old 01-18-2010, 06:34 AM   #3
sumeet inani
Member
 
Registered: Oct 2008
Posts: 883
Blog Entries: 26

Original Poster
Rep: Reputation: 47
I do that presently ( 'mount /dev/sdb1 /pd' ) where i have created folder /pd .
It works well )but as you know only root can mount so copying & deleting files to USB is tedious.
I think either I have to label the file-system (maybe then it will automount ) or find way so that ordinary user can mount /dev/sdb1 (atleast better than root doing it)

Last edited by sumeet inani; 02-23-2010 at 10:45 PM.
 
Old 01-18-2010, 07:05 AM   #4
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,591

Rep: Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244Reputation: 1244
Quote:
I do that presently ( 'mount /dev/sdb1 /pd' where i have created folder /pd . It works well )but as you know only root can mount so copying & deleting files to USB is tedious.
Just put an entry in your /etc/fstab then anyone can mount it.
Code:
/dev/sdb1	/pd	 vfat    defaults,user,noauto 0 0
The problem seems to be with whatever system you are using to automagically mount the device. I suggest you find out what that system is and investigate it. Perhaps some Ubuntu users will be able to help you (I dislike and don't use automounting for devices like usb sticks).

Cheers,

Evo2.

PS. After adding the fstab entry, anyone can mount with the following command
Code:
mount /pd

Last edited by evo2; 01-18-2010 at 07:14 AM. Reason: PS.
 
1 members found this post helpful.
Old 01-18-2010, 07:16 AM   #5
sumeet inani
Member
 
Registered: Oct 2008
Posts: 883
Blog Entries: 26

Original Poster
Rep: Reputation: 47
Thanks evo2.It worked well.
i will also try to understand the meaning of line added in /etc/fstab.
I did read to get basic idea that
Code:
entry in /etc/fstab is
device mountpoint filesystem option defaults dump check
(1)For external we keep 0 for last two meaning don't backup & check.
(2)we can use auto for type so system tries to detect.
(3)In option Defaults means root can mount.
(4)user option means anyone can mount but one who mounted has to unmount.
(5)users option ( see extra 's' ) means anybody can unmount.

Last edited by sumeet inani; 02-23-2010 at 10:46 PM.
 
Old 02-23-2010, 10:40 PM   #6
sumeet inani
Member
 
Registered: Oct 2008
Posts: 883
Blog Entries: 26

Original Poster
Rep: Reputation: 47
Questions
(1)Also i was wondering that in gparted > show features > they show operation possible for particular file system . Why is there a refresh button in it . Can i install some extras to enable something (say reading lable of fat32) ?

Last edited by sumeet inani; 03-08-2010 at 10:55 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I get KDE4 to automount all vfat usb-sticks with the "flush" mount option? ssenuta Mandriva 1 01-15-2010 01:14 AM
"mount.nfs: an incorrect mount option was specified" (soft) catkin Linux - Networking 2 09-19-2009 06:30 AM
why only "mount /dev/sda /mnt/usb" works and not "mount /dev/sda1..." ? gromot Linux - General 7 05-19-2009 11:18 AM
Invalid mount option when attempting to mount the volume Dell x300 kstanton7 Linux - Laptop and Netbook 0 11-01-2008 11:09 PM


All times are GMT -5. The time now is 11:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration