LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 09-18-2009, 03:58 AM   #1
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,512
Blog Entries: 27

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
"mount.nfs: an incorrect mount option was specified" (soft)


Hello

Adding NFS option "soft" in fstab results in "mount.nfs: an incorrect mount option was specified" on mount with -o remount. When "soft" is removed from fstab the same command completes silently.

Environment
  • ubuntu 8.04.3 host running:
    • Bridging (bridge-utils 1.2-2)
    • NFS server (nfs-kernel-server 1:1.1.2-2ubuntu2.2)
    • VirtualBox 3.0.6 with Slackware VM NIC configured as Bridged tap1
  • Slackware 13 guest. If NFS client software version is required, please tell me how to find it!
Option "soft" is wanted because Slackware sometimes looses the NFS connection with the host and this hangs shutdown. Otherwise the NFS mount works fine.

man 5 nfs on Slackware shows "soft" as an option.

Here's the relevant host exports and guest fstab lines
Code:
/home 192.168.1.46(rw,no_root_squash,no_subtree_check)
192.168.1.47:/home /home/c/hh nfs    bg,rw,soft      0 0
Best

Charles
 
Old 09-18-2009, 11:27 PM   #2
Smartpatrol
Member
 
Registered: Sep 2009
Posts: 196

Rep: Reputation: 38
...

Last edited by Smartpatrol; 03-11-2010 at 09:31 PM.
 
Old 09-19-2009, 05:30 AM   #3
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,512
Blog Entries: 27

Original Poster
Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Quote:
Originally Posted by Smartpatrol View Post
I might be mistaken but i believe its a soft mount by default.
Thanks Smartpatrol According to the nfs man page on Slackware 13, the default is hard:
Code:
       soft / hard    Determines  the  recovery  behavior  of the NFS client after an NFS request times out.  If
                      neither option is specified (or if the hard option is specified), NFS requests are retried
                      indefinitely.   ...
 
  


Reply

Tags
fstab, nfs, slackware, soft


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with mount NFS, with "RPC: port mapper failure" error alisa Linux - Networking 2 05-20-2008 02:52 AM
mount option "-F" and "ufs" dreamlemon Linux - Newbie 6 02-11-2007 09:10 AM
Receive "modprobe: Canít locate module block-major-" and disconnects NFS mount car182 Linux - Hardware 1 05-25-2006 08:46 AM
connecting openbsd to linux nfs mount - "unsupported protocol" error animehair *BSD 4 03-28-2005 01:21 AM
redhat 7.2 mount nfs"RPC:time out"problem bee33 Linux - Networking 1 02-19-2004 10:03 AM


All times are GMT -5. The time now is 11:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration